i installed ubuntu 10.10 on old powerbook g3 (6g hard disk, i think it lombard)m with xfce as desktop (xfce and not xubuntu wich is slower). anyway, everything works fine, but for some reson my vlc just cannot run video file. each time i play him it show a black screen and fall. i tried config his outpot video, and it still dont work, in smoe mode the audio working but the other.
i tried another movei player, and totem, kaffeine and xine work ok, although very slowly (the video work not smoothly). kaffeine works fine, but not enough. when i had ubuntu 8.04 in the smae computer vlc was the movie player i chose and he did his job perfectly.
can anyone help me with this problem? i search in the internet answer for days, but cannot find. her's the output when i run vlc (the important line is the two in the end):

VLC media player 1.1.4 The Luggage (revision exported)
warning: your CPU has Altivec instructions, but not your operating system.
some optimizations will be disabled unless you upgrade your OS
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
Blocked: call to setlocale(6, "")
Blocked: call to sigaction(17, 0x483b2ac4, 0x483b2a38)
Blocked: call to setlocale(6, "")
[0x108a8260] xcb_xv generic error: no available XVideo adaptor
Illegal instruction