Results 1 to 8 of 8

Thread: VirtualBox not recognizing VT-x processor

  1. #1
    Join Date
    Aug 2006
    Beans
    417
    Distro
    Ubuntu 13.04 Raring Ringtail

    VirtualBox not recognizing VT-x processor

    I have a Core 2 Duo E6600 processor which supports VT-x according to this list:

    http://ark.intel.com/VTList.aspx

    However VirtualBox (the Oracle version) does not seem to recognize that the processor supports VT-x. I tried to install 64-bit Natty in a VM and the installer indicated that the processor architecture was i686, not x86_64, and terminated. Incidentally the host OS is 64-bit. Also while other VMs run, Oracle VM Manager indicates that VT-x is not being used or detected.

    It's my understanding that a processor that supports VT-x and whose OS is 64-bit will allow the installation of a 64-bit VM.

    The logs seem to indicate that VM Manager can't detect virtualization on the processor:

    Code:
    VMX - Virtual Machine Technology       = 0 (1)
    though that's not exactly VT-x.

    Any suggestions?

  2. #2
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,432
    Distro
    Ubuntu Development Release

    Re: VirtualBox not recognizing VT-x processor

    Quote Originally Posted by Fraoch View Post
    I have a Core 2 Duo E6600 processor which supports VT-x according to this list:

    http://ark.intel.com/VTList.aspx

    However VirtualBox (the Oracle version) does not seem to recognize that the processor supports VT-x. I tried to install 64-bit Natty in a VM and the installer indicated that the processor architecture was i686, not x86_64, and terminated. Incidentally the host OS is 64-bit. Also while other VMs run, Oracle VM Manager indicates that VT-x is not being used or detected.

    It's my understanding that a processor that supports VT-x and whose OS is 64-bit will allow the installation of a 64-bit VM.

    The logs seem to indicate that VM Manager can't detect virtualization on the processor:

    Code:
    VMX - Virtual Machine Technology       = 0 (1)
    though that's not exactly VT-x.

    Any suggestions?
    When creating the virtual machine for natty, did you select Ubuntu (64-bit)
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  3. #3
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: VirtualBox not recognizing VT-x processor

    Quote Originally Posted by tgm4883 View Post
    When creating the virtual machine for natty, did you select Ubuntu (64-bit)
    That was my guess as well. I know I've run into that before.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  4. #4
    Join Date
    Aug 2006
    Beans
    417
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: VirtualBox not recognizing VT-x processor

    Quote Originally Posted by tgm4883 View Post
    When creating the virtual machine for natty, did you select Ubuntu (64-bit)
    I did feel stupid, because I didn't, but it still doesn't work, see attachment.

    Looks like a BIOS issue?
    Attached Images Attached Images

  5. #5
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,432
    Distro
    Ubuntu Development Release

    Re: VirtualBox not recognizing VT-x processor

    Quote Originally Posted by Fraoch View Post
    I did feel stupid, because I didn't, but it still doesn't work, see attachment.

    Looks like a BIOS issue?
    Yea could be a BIOS setting. I know I have that setting in the BIOS of both my work machine and my home machine.
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  6. #6
    Join Date
    Aug 2006
    Beans
    417
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: VirtualBox not recognizing VT-x processor

    Ah yes, that was it!

    There was a setting in the BIOS which was disabled.

    I set it and it runs fine.

    Thanks, and sorry for overlooking the obvious!

  7. #7
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,432
    Distro
    Ubuntu Development Release

    Re: VirtualBox not recognizing VT-x processor

    Quote Originally Posted by Fraoch View Post
    Ah yes, that was it!

    There was a setting in the BIOS which was disabled.

    I set it and it runs fine.

    Thanks, and sorry for overlooking the obvious!
    Your welcome. Please set the thread to solved.
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  8. #8
    Join Date
    Aug 2006
    Beans
    417
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: VirtualBox not recognizing VT-x processor

    Done. Thanks again.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •