Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Floppy USB drive failure.

  1. #11
    Join Date
    Aug 2007

    Re: Floppy USB drive failure.

    I had saved this information during my install of Ubuntu 10.04. It was somewhere on the forum.
    Maybe it will be of help for you.

    PROBLEM: Can't mount Floppy in 10.04 LTS

    To summarize, reading (and writing) a floppy disk in Lucid Lynx (10.04) requires three steps:

    1. Allow yourself to use the floppy by going to System->Administration->Users and Groups->Advanced Settings->User Privileges and click on "Use floppy drives"

    2. Use the old version of udisks () by going to System->Administration->Synaptic Package Manager, find the udisks package, mark udisks for reinstallation, click on Package->Force Version, and select the 1.0.1-1build1 version (which is the old version). Then click on apply to finish the installation.

    3. Remember to unclick udisks whenever Update Manager wants to install new updates, or you'll get the new version and floppy disks won't work anymore!

    After the old udisks is installed (and the machine is rebooted), when you insert a floppy a cute little icon comes up on the desktop and in Nautilus (and on Disk Mounter if you have that installed). Left clicking on the icon and select Mount Floppy Disk will put an icon in Nautilus, and then you read, write, and format the floppy just like any other drive.

    Finally found it:
    Posting #10

    Last edited by lkraemer; September 26th, 2011 at 12:31 AM.

  2. #12
    Join Date
    Oct 2011

    Question Re: Floppy USB drive failure.

    Is there also a solution for 10.10 (Maverick)? Because the "force version" option in synaptics is greyed out


    Under Ubuntu 10.10. Maverick I used:
    - 1. Allow yourself to use the floppy by going to
    System->Administration->Users and Groups->Advanced Settings->User Privileges and click on "Use floppy drives"

    - 2. Download 1.0.1-1build1 from here:
    Select the 1.0.1-1build1 and download your processor version; example
    for 32bit:

    - 3. In Maveric: open a terminal cd (go) to the download (folder) &:
    $ sudo dpkg -i udisks_1.0.1-1build1_i386.deb

    - 4. reboot

    If and which side effects this downgrade has/will have on other programs, is not known yet
    Last edited by tb2012; November 24th, 2011 at 08:00 AM. Reason: Solved

  3. #13
    Join Date
    Nov 2008
    Old Europe
    Lubuntu 13.04 Raring Ringtail

    Re: Floppy USB drive failure.

    Quote Originally Posted by warsev View Post
    I got a nice, new, cheap Mitsumi USB floppy for reading old disks and quickly found I had this exact same problem. After a day or so of messing around I found a good fix. The solution is to tell udev that the device isn't a floppy!! (go figure...) That's done by overriding the environment variable "ID_DRIVE_FLOPPY" from "1", which is set in the general rule, to "0". A custom udev rule is necessary to override the generic rule for USB floppies that's in /lib/udev/rules.d/80-udisks.rules. In this case I chose to make a custom rule that would only apply to my specific disk vendor and model, leaving all others to be handled generically. The rule looks like so:
    # This should run AFTER the general rule in /lib/udev/rules.d that deals with generic usb floppys
    ATTRS{vendor}=="MITSUMI*", ATTRS{model}=="USB UFDD 061M*", GROUP="floppy", ENV{ID_DRIVE_FLOPPY}="0"
    Upon stopping and restarting udev, it works perfectly, almost. When a floppy is inserted into the drive it is mounted and a file browser opens to the disk root. The only flaw is that the "Eject" option in some pull-down lists unmounts the disk but doesn't actually eject it. I have to manually press the button on the drive to eject the disk. (heck, I can live with that...)

    To find the vendor and model of your disk drive, first determine where in the device tree it's being loaded. Probably /dev/sdb or /dev/sdc. You can do that rather simply by just disconnecting the disk, looking at the /dev directory, connecting the disk, and looking at /dev again. Next, you can find many particulars suitable for use in udev rules. At a terminal type:
    udevadm info -a -p `udevadm info -q path -n /dev/sdc`
    You will get a long list of parameters and variables for the device and its parent devices. Somewhere you will find the vendor and model of the disk, like so:
        ATTRS{vendor}=="MITSUMI "
        ATTRS{model}=="USB UFDD 061M   "
    Plug those values into the rule as above to uniquely identify your drive.


    • Put your custom rule into /etc/udev/rules.d/, not /lib/udev/rules.d/ if you want it to survive your next OS upgrade.
    • Make sure the file name of your custom rule ends in ".rules" and collates after the name of the general rule (at this writing, "80-udisks.rules").
    • Make sure the permissions on your custom rule match the permissions of the other custom rules you find in /etc/udev/rules.d
    • Make sure you user name has access to group "floppy"
    Thx, it worked!!!

Page 2 of 2 FirstFirst 12


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts