So, I'm trying to use this tutorial ( to backup my Ubuntu 10.10 (ext3) operating system. I've successfully gotten it into a TAR file on my external hard-drive, but inside the archive are 2 folders: sda5 and media (/media/sda5/), sda5 ofcourse containing my operating system.

I run VMWare as my virtual machine software, but I could easily run Virtual Box if the situation calls for it.

On my virtual machine I created an Extended partition, made a 2GB swap space and the rest is ext3 (ext3 space is mounted as sda1) (at this point, Swap is OFF)

here is what I've tried to do inside the virtual machine to restore:

sudo -s
mkdir /media/FROM/
mkdir /media/TO/

mount /dev/sdb1 /media/FROM/
(sdb1 is the drive that has the tar file on it)

mount /dev/sda1 /media/TO/
(sda1 is the new ubuntu filesystem in the VM)

cd /

tar -xvpzf /media/FROM/Bac_201/KC201_Bac.tar.gz media/sda5/ -C /media/TO/
(Bac_201 is the folder on my external harddrive where KC201_Bac.tar.gz is located)
this is apparently supposed to extract the contents of /media/sda5 (a folder inside the tar file) to sda1 (the virtual hard drive)

but instead it just creates the directory sda5 under media of the live ubuntu cd

Do I need to CHRoot in these conditions?

AFTER I get the files successfully into the virtual machine, how do I go about restoring the grub2 bootloader?

Right now I haven't tried to restore grub on my hardware, but I would be interested in doing so. There are a vast immense amount of forum posts about this subject, but all are to mixed results. Can anybody tell me the absolute definite way to restore grub2 successfully, I don't want to try something if it's going to mess up my install, whether I've backed up or not. Just point me in the right direction please

for further reference, here is a link to the previous (failed) thread I made about this same subject: