Results 1 to 4 of 4

Thread: Debugging problem

  1. #1

    Red face Debugging problem

    Hi,

    I am trying to debug a C++ code, that uses threads [but I am debugging a single file/operation/method]. But the debugger does not flow sequentially as it should be. It skips some lines and repeats others, some lines it never reach even there are no conditions that prevent this.

    I guess it's threads issue [not sure], I searched the net but I found nothing useful.

    Any idea!

    Regards,
    Ibrahim
    Be a Bee...Work Like Me

  2. #2
    Join Date
    Oct 2007
    Beans
    1,914
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Debugging problem

    Try to:

    - Switch off optimizations (-O0 compilation parameters)
    - Rebuild the whole project
    - Make sure that you never insert/delete a line in some source code file between building the project and running the debugger.

  3. #3

    Re: Debugging problem

    Hi Zugzwang,

    I am using Netbeans, how can I switch off optimizations?

    Thank you,
    Be a Bee...Work Like Me

  4. #4

    Re: Debugging problem

    Yes, It was optimization problem. In Netbeans to disable optimization do the following:
    Right click the project node->Code Assistance->Reconfigure project. And add -O0

    Thanks,
    Ibrahim
    Be a Bee...Work Like Me

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •