Results 1 to 7 of 7

Thread: Wine + World of warcraft

Hybrid View

  1. #1
    Join Date
    Apr 2008
    Location
    Sweden
    Beans
    12
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Wine + World of warcraft

    Hey all,
    Need a little help over here.
    I just installed Linux Mint 10 before i used Ubuntu 10.10 but found Linux Mint faster some how.
    Well my problem is i've been playing world of warcraft in Ubuntu whit no problem and iam using the same drivers from ati's homepage that i used in Ubuntu.
    I have looked over the xorg.conf and it looks the same as the one in Ubuntu.

    But still when i start World of Warcraft i get a strange picture. I've upload the picture.

    And fglrxinfo give me this.

    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon HD 5400 Series 
    OpenGL version string: 4.1.10524 Compatibility Profile Context

    And glxinfo | grep rendering gives me
    Code:
    direct rendering: Yes

    This is my Xorg.conf
    Code:
    Section "ServerLayout"
       Identifier     "aticonfig Layout"
       Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Module"
    EndSection
    
    Section "Monitor"
       Identifier   "aticonfig-Monitor[0]-0"
       Option       "VendorName" "ATI Proprietary Driver"
       Option       "ModelName" "Generic Autodetecting Monitor"
       Option       "DPMS" "true"
    EndSection
    
    Section "Monitor"
       Identifier   "0-LVDS"
       Option       "VendorName" "ATI Proprietary Driver"
       Option       "ModelName" "Generic Autodetecting Monitor"
       Option       "DPMS" "true"
       Option       "PreferredMode" "1366x768"
       Option       "TargetRefresh" "60"
       Option       "Position" "0 0"
       Option       "Rotate" "normal"
       Option       "Disable" "false"
    EndSection
    
    Section "Device"
       Identifier  "aticonfig-Device[0]-0"
       Driver      "fglrx"
       Option       "Monitor-LVDS" "0-LVDS"
       BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
       Identifier "aticonfig-Screen[0]-0"
       Device     "aticonfig-Device[0]-0"
       DefaultDepth     24
       SubSection "Display"
          Viewport   0 0
          Depth     24
       EndSubSection
    EndSection

    Any one who had the same problem or might know what the problem is ?
    And i also have made some tweaks to the wow config.
    Attached Images Attached Images

  2. #2
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Wine + World of warcraft

    check that its not a xorg.conf issue:

    rename it to xorg.confold then reboot

  3. #3
    Join Date
    Apr 2008
    Location
    Sweden
    Beans
    12
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Wine + World of warcraft

    Quote Originally Posted by dino99 View Post
    check that its not a xorg.conf issue:

    rename it to xorg.confold then reboot
    Thanks for the reply and this was the first thing i tried and that did not work either.

    Sorry maybe should have wrote that

  4. #4
    Join Date
    Aug 2008
    Beans
    302

    Re: Wine + World of warcraft

    Does disabling UseGLSL do anything? If you haven't already done it.
    http://wiki.winehq.org/UsefulRegistryKeys

  5. #5
    Join Date
    Apr 2008
    Location
    Sweden
    Beans
    12
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Wine + World of warcraft

    Quote Originally Posted by Soulcage View Post
    Does disabling UseGLSL do anything? If you haven't already done it.
    http://wiki.winehq.org/UsefulRegistryKeys
    Well i haven't tried and i cant try either because i want back to Ubuntu.

  6. #6
    Join Date
    Aug 2008
    Beans
    302

    Re: Wine + World of warcraft

    UseGLSL is a wine setting...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •