Results 1 to 4 of 4

Thread: Rsync special charset

  1. #1
    Join Date
    Sep 2010
    Beans
    11

    Question Rsync special charset

    hi all,

    I have some issues with taking backups with rsync. Specially with filenames with special charset (......).

    I searched for some solutions but nothing seems to work "perfect". The last thing I tried is using the "--iconv" parameter".

    Explaination backup process/
    First we mount our Disk to our server (Ubuntu 10.04). Then we do rsync to a local folder called "Backup".
    I made some test files and tried the --iconv solution but still don't get the result i want (the original file names).
    Files on the disk:
    Spiltest.txt
    File in the backup folder:
    Sp__i_l_test.txt
    or
    Spiltest.txt
    The most command error in our log is also "vanished files", with the special charakters ias a "?".


    USED rsync option=> -vayP --iconv=ISO-8859-1,utf-8

    Website


    Kind Regards,
    Last edited by lt-mini; March 17th, 2011 at 12:20 PM.

  2. #2
    Join Date
    Sep 2010
    Beans
    11

    Re: Rsync special charset

    When i did a bit more of debugging, I see that it probably fails when i mount the drive.

    When the drive is mounted i get this:
    -rwxr-xr-x 1 root root 10 2011-03-17 11:37 Sp??i?l?test_ANSI.txt
    -????????? ? ? ? ? ? Sp??i?l?test.txt
    -rwxr-xr-x 1 root root 22 2011-03-17 11:37 Sp??i?l?test_unicode_UTF16.txt
    -rwxr-xr-x 1 root root 16 2011-03-17 11:36 Sp??i?l?test_UTF8.txt

    After that there will be a rsync. So the problem starts with the mounting.

    Is there any option in mounting four charsets?

    I searched and found iocharset (in man mount) but i will search further on this.

  3. #3
    Join Date
    Sep 2010
    Beans
    11

    Wink Re: Rsync special charset

    Problem solved.

    Problem was with mounting drive.


    Added iocharset=utf-8 in the mount line in /etc/fstab
    Last edited by lt-mini; March 18th, 2011 at 10:04 AM.

  4. #4
    Join Date
    Feb 2007
    Location
    Colfax, CA
    Beans
    2

    Re: Rsync special charset

    Quote Originally Posted by lt-mini View Post
    Problem solved.

    Problem was with mounting drive.


    Added iocharset=utf-8 in the mount line in /etc/fstab
    Many Thanks It-mini!

    This problem has plagued me for weeks and I just ran across your solution.

    Thanks Again
    - Frank

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •