Results 1 to 3 of 3

Thread: PHP-GTK Warning buildconf

  1. #1
    Join Date
    Mar 2011
    Location
    Thessaloniki, GR
    Beans
    82
    Distro
    Ubuntu 12.04 Precise Pangolin

    PHP-GTK Warning buildconf

    I am trying to install PHP-GTK-2.0.1 Source - 15 May 2008

    Code:
    paneas@paneasbox:~/Downloads$ ls
    php-gtk-2.0.1  php-gtk-2.0.1.tar.gz
    paneas@paneasbox:~/Downloads$ cd php-gtk-2.0.1/
    paneas@paneasbox:~/Downloads/php-gtk-2.0.1$ ./buildconf
    rebuilding config.h.in
    configure.in:150: warning: LTOPTIONS_VERSION is m4_require'd but not m4_defun'd
    aclocal.m4:2944: LT_INIT is expanded from...
    aclocal.m4:2979: AC_PROG_LIBTOOL is expanded from...
    configure.in:150: the top level
    configure.in:150: warning: LTSUGAR_VERSION is m4_require'd but not m4_defun'd
    configure.in:150: warning: LTVERSION_VERSION is m4_require'd but not m4_defun'd
    configure.in:150: warning: LTOBSOLETE_VERSION is m4_require'd but not m4_defun'd
    How I can fix this warning error ?

    EDIT:
    Instead of downloading : php-gtk-2.0.1 Source - 15-May-2008

    I used the other one from CVS server:
    Code:
    svn co http://svn.php.net/repository/gtk/php-gtk/trunk php-gtk
    No errors or warnings
    Last edited by Dr.Paneas; March 13th, 2011 at 04:29 PM. Reason: solution found

  2. #2
    Join Date
    Jan 2008
    Beans
    8

    Cool Re: PHP-GTK Warning buildconf

    I have the same Issue, cud you fix it?

  3. #3
    Join Date
    Sep 2009
    Beans
    1,293

    Re: PHP-GTK Warning buildconf

    Have you tried regenerating aclocal? Other autotools things may need refreshed too
    Code:
    # Generate aclocal.m4
    $ aclocal
    
    # maybe this, runs lots of autotools, 
    # forces all files obsolete and installs missing
    $ autoreconf -fi

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •