Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Can't change screen resolution.

  1. #1
    Join Date
    Mar 2011
    Location
    Florida, US
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Cool Can't change screen resolution.

    I've recently installed Ubuntu 10.10 on an old Dell computer I have. Everything seems to work fine, but I can't seem to change the screen resolution. In the monitor Preferences it says Monitor:Unknown. It's stuck on 1600x1200 and I'd like it to be closer to 1024x768

    I've tried changing the xorg.conf file to no avail. I've been browsing for 3 days now looking for a solution.

    Any help is appreciated.

    http://hamsterhutt.host56.com/WHATACOM-4ACEC222.xml
    These are my specs if it helps any, please ignore the windows installation info because I have it installed alongside ubuntu.

  2. #2
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Can't change screen resolution.

    Try following this guide:
    https://wiki.ubuntu.com/X/Config/Res...%20resolutions

    Greetings.

  3. #3
    Join Date
    Mar 2011
    Location
    Florida, US
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Unhappy Re: Can't change screen resolution.

    Quote Originally Posted by Krytarik View Post
    Try following this guide:
    https://wiki.ubuntu.com/X/Config/Res...%20resolutions

    Greetings.
    This method doesn't seem to work for me. I follow the instructions, and I get a new resolution in the monitor preferences, but when I try to load it I get a an error "configure crtc 0 failed" and "The selected configuration could not be applied"

    I heard that the crtc 0 failed error was because the refreshrate was too high, but I've set it as low as 30 and it still doesn't work.

  4. #4
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Can't change screen resolution.

    Are you able to add/apply the mode with the xrandr commands?

  5. #5
    Join Date
    Mar 2011
    Location
    Florida, US
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't change screen resolution.

    Quote Originally Posted by Krytarik View Post
    Are you able to add/apply the mode with the xrandr commands?
    I can add, but cannot apply. It gives me the option of another resolution in the monitor preferences immediately after I complete the commands, but when I try to apply that resolution It gives me an error "The selected configuration could not be applied"

  6. #6
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Can't change screen resolution.

    You should apply the added mode with the the respective xrandr command, not through the GUI, since I am not sure if that would work also.

    Could you please post the output of "xrandr" and which commands you use, and the output of them. Please use the code-tags therefore (the #-button in the editor).
    Last edited by Krytarik; March 14th, 2011 at 05:17 AM.

  7. #7
    Join Date
    Mar 2011
    Location
    Florida, US
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't change screen resolution.

    Code:
    robbie@Whatacomputer:~$ gtf 1024 768 59
    
      # 1024x768 @ 59.00 Hz (GTF) hsync: 46.90 kHz; pclk: 63.04 MHz
      Modeline "1024x768_59.00"  63.04  1024 1080 1184 1344  768 769 772 795  -HSync +Vsync
    
    robbie@Whatacomputer:~$ xrandr --newmode potatoes 63.04  1024 1080 1184 1344  768 769 772 795  -HSync +Vsync
    xrandr: Failed to get size of gamma for output default
    robbie@Whatacomputer:~$ xrandr --addmode default potatoes
    xrandr: Failed to get size of gamma for output default
    robbie@Whatacomputer:~$ xrandr --output default --mode potatoes
    xrandr: Failed to get size of gamma for output default
    xrandr: Configure crtc 0 failed
    robbie@Whatacomputer:~$
    This is how I've understood it to the best of my abilities. Like I said, doing this will show the 1024x768 resolution in the monitor preferences, but will not allow me to apply it. It also doesn't save the settings after a reboot.

  8. #8
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Can't change screen resolution.

    First, you should use "cvt" instead of "gtf" to get the modeline, as I understood that "cvt" is more appropriate.

    And I did websearch about the error messages you are getting.

    I would like to make sure that you are running the correct driver. Please post the output of:
    Code:
    lshw -c video
    Also check if a "/etc/X11/xorg.conf" is present, it shouldn't. But if it is, post its content as well.

    Then, why are you trying to set the mode to specifically 59 Hz? If you just leave that away (default is 60 Hz), does it work then?
    Last edited by Krytarik; March 14th, 2011 at 07:52 AM. Reason: corrected statement regarding "cvt"

  9. #9
    Join Date
    Mar 2011
    Location
    Florida, US
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't change screen resolution.

    Code:
    root@Whatacomputer:/home/robbie# lshw -c video
      *-display               
           description: VGA compatible controller
           product: 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 01
           width: 32 bits
           clock: 33MHz
           capabilities: pm vga_controller bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: irq:16 memory:e8000000-efffffff memory:feb80000-febfffff
    It's not an LCD monitor, it's an old crt I had lying around. I know it's capable of a 1024x768 resolution because my Windows installation on it worked, right?

    I do have a xorg.conf file, I don't remember whether it was already there, or whether I created it when I was trying to fix this issue a few days ago. It isn't original though.

    Code:
    Section "Monitor"
        Identifier    "Configured Monitor"
          Option      "DPMS"  "true"
          HorizSync    30.0-60.0
          VertRefresh  50.0-70.0
    EndSection
    
    Section "Screen"
        Identifier    "Default Screen"
        Monitor        "Configured Monitor"
        Device        "Configured Video Device"
          DefaultDepth      24
          SubSection "Display"
                      Depth         24
                      Modes         "1024x768" "800x600"
          EndSubSection
          
    EndSection
    And as far as the Refreshrate, I thought that maybe 60 was too high and causing problems, so I set it to 59. I will use 60 from now on.

    Thank you for responding so quickly.


    ::UPDATE::
    Using cvt with this same method changed nothing.
    Last edited by Kin2InuYasha; March 14th, 2011 at 07:20 AM. Reason: Add info

  10. #10
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Can't change screen resolution.

    Oh, I somewhat assumed (out of my experience here in the forums), that I'm almost the only one who is still using a CRT.

    And correction: It seems like "cvt" is always the better choice, so take it instead.

    Please at least rename your "xorg.conf".

    And yes, you are running the intel driver. I would like to upgrade it to the most recent version:
    https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
    Code:
    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get upgrade
    Then reboot/relogin.

    Also, you should always try to run a CRT at least at 75 Hz. Please check if it runs with that mode in Windows7.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •