Results 1 to 5 of 5

Thread: Getting Artifacts with some 720p files... VDPAU profile settings?

  1. #1
    Join Date
    Dec 2008
    Beans
    234
    Distro
    Ubuntu 10.04 Lucid Lynx

    Getting Artifacts with some 720p files... VDPAU profile settings?

    Hi all,

    I am having some issues with video quality.

    Some of the 720p files I play (mkv) give me artifacts with the VDPAU video profile. When I switch to the "high quality" or "CPU" playback video profiles, they play just fine.


    Full HD 1080p movies only play well with the VDPAU profile for me, so I would like to use that for everything, rather than keep switching.

    I like that one since it keeps my cpu usage down and works well with fast moving scenes.

    The CPU or the HIGH QUALITY video profiles can't handle 1080p and give me constant freezing.

    Has anyone run into this? Which profile do you think is better? Is there a way to tweak VDPAU?

    My Mythbox setup running with the following Hardware:

    Motherboard: MB ASUS M3N78-VM
    Video Card: Nvidia 9800GT
    AMD Phenom Quad-core 9850 2.50GHz Processor
    4GB DDR2 800 (PC2 6400) ram

    This is all on Myth .22

    Thanks!

  2. #2
    Join Date
    Jun 2007
    Location
    Poughkeepsie, NY
    Beans
    5,812
    Distro
    Ubuntu

    Re: Getting Artifacts with some 720p files... VDPAU profile settings?

    create your own profile. set it to use VDPAU at 1080 and for 720 under use ffmpeg & Xvideo.

    oh and upgrade to ubuntu 10.10, use mythtv .024 and use the newer nvidia driver. your issues may resolve on their own
    Last night I lay in bed looking up at the stars in the sky and I thought to myself, where the heck is the ceiling.

  3. #3
    Join Date
    Dec 2007
    Location
    Shakopee, MN USA
    Beans
    220
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Getting Artifacts with some 720p files... VDPAU profile settings?

    Are the artifacts tearing?

    http://www.mythtv.org/wiki/VDPAU#Tearing.2FStuttering

    I have this in my xorg.conf

    Code:
       Section "Extensions"
           Option "Composite" "Disable"
       EndSection

  4. #4
    Join Date
    Dec 2008
    Beans
    234
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Getting Artifacts with some 720p files... VDPAU profile settings?

    Quote Originally Posted by LowSky View Post
    create your own profile. set it to use VDPAU at 1080 and for 720 under use ffmpeg & Xvideo.

    oh and upgrade to ubuntu 10.10, use mythtv .024 and use the newer nvidia driver. your issues may resolve on their own
    Thank for your replies guys..

    I upgraded but the problem persists.

    What exactly do I put into the details for the profile? I created one but don't know what to put in it. There is some kind of format that you have to follow...

    Thanks!

  5. #5
    Join Date
    Dec 2008
    Beans
    234
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Getting Artifacts with some 720p files... VDPAU profile settings?

    Quote Originally Posted by novellahub View Post
    Are the artifacts tearing?

    http://www.mythtv.org/wiki/VDPAU#Tearing.2FStuttering

    I have this in my xorg.conf

    Code:
       Section "Extensions"
           Option "Composite" "Disable"
       EndSection
    Thanks, Ill try that...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •