Results 1 to 10 of 250

Thread: Wireless USB N300 Netgear install

Threaded View

  1. #11
    Join Date
    Mar 2013

    Question Re: Wireless USB N300 Netgear install

    Hi, everyone!
    I have read the thread fairly thoroughly and have followed the installation instructions therein. I've tried installing ndiswrapper 1.55 from the package, and also installing 1.58 from source. I'm using the package downloaded from here.

    I'm running a 32-bit version of Ubuntu 10.04, and can't upgrade this particular box since its reason for existence is to run some software to drive a milling machine, which won't run on later versions.

    Despite all my attempts, the interface is just not recognized by linux (does not show up in iwconfig).

    Here are the diagnostic messages I've gotten most recently:
    root@Linux-CNC:/home/walts/wna3100-drivers# lsusb
    Bus 002 Device 004: ID 08e6:0432 Gemplus GemPC432 SmartCard Reader
    Bus 002 Device 003: ID 049f:000e Compaq Computer Corp. Internet Keyboard
    Bus 002 Device 002: ID 0451:2036 Texas Instruments, Inc. TUSB2036 Hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 004: ID 0781:5576 SanDisk Corp. 
    Bus 001 Device 002: ID 0846:9020 NetGear, Inc. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    root@Linux-CNC:/home/walts/wna3100-drivers# ndiswrapper -l
    WARNING: All config files need .conf: /etc/modprobe.d/emc2, it will be ignored in a future release.
    bcmwlhigh5 : driver installed
        device (0846:9020) present
    root@Linux-CNC:/home/walts/wna3100-drivers# dmesg | grep ndis
    [ 1524.863239] ndiswrapper version 1.55 loaded (smp=yes, preempt=no)
    [ 1525.114988] ndiswrapper (import:242): unknown symbol: ntoskrnl.exe:'IoUnregisterPlugPlayNotification'
    [ 1525.115108] ndiswrapper (load_sys_files:206): couldn't prepare driver 'bcmwlhigh5'
    [ 1525.115418] ndiswrapper (load_wrap_driver:108): couldn't load driver bcmwlhigh5; check system log for messages from 'loadndisdriver'
    [ 1525.115976] usbcore: registered new interface driver ndiswrapper
    root@Linux-CNC:/home/walts/wna3100-drivers# ^C
    As I read this, the physical device is present, ndiswrapper has bcmwlhigh5 and sees the device - but the kernel can't load the driver because of teh unknown symbol.
    I have tried googling for 'IoUnregisterPlugPlayNotification' but could not find any help.

    I have a lot more experience with Windows than with linux and I may not be interpreting the messages correctly, but regardless, I need some help here, please.


    P.S. the interface works, on this box, when booted with Windows.
    Last edited by wscrivens1; March 8th, 2013 at 02:16 AM. Reason: spelling error


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts