Results 1 to 7 of 7

Thread: Apt authentification issue with GPG and CRAN

  1. #1
    Join Date
    Jan 2008
    Beans
    19

    Apt authentification issue with GPG and CRAN

    Starting a couple of days ago I get this on startup. CRAN repository was working well so far. Should I change anything?

    Code:
    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://cran.uib.no lucid/ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 51716619E084DAB9
    
    W: GPG error: http://cran.uib.no lenny-cran/ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 06F90DE5381BA480
    W: Failed to fetch http://cran.uib.no/bin/linux/ubuntu/lucid/Release  
    
    W: Some index files failed to download, they have been ignored, or old ones used instead.

  2. #2
    Join Date
    Aug 2005
    Beans
    27

    Re: Apt authentification issue with GPG and CRAN

    It's happening to me as well

  3. #3
    Join Date
    Dec 2006
    Location
    Copenhagen
    Beans
    325
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Apt authentification issue with GPG and CRAN

    So any solution? This has been happening for more than a week

  4. #4
    Join Date
    Sep 2007
    Location
    In here watching you!
    Beans
    Hidden!

    Re: Apt authentification issue with GPG and CRAN

    Enter these commands in a terminal. Then try to update again,
    Code:
    gpg --keyserver keyserver.ubuntu.com --recv 06F90DE5381BA480
    gpg --export --armor 06F90DE5381BA480  | sudo apt-key add -
    Use whatever OS or desktop works for you. Dual boot or use VMs if you want. Backup your computer regularly, and definitely before upgrading, partitioning, or installing an OS.

    No support requests by PM please.

  5. #5
    Join Date
    Jan 2008
    Beans
    19

    Re: Apt authentification issue with GPG and CRAN

    This did not work, I still get an error on apt-get update.

    Code:
    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://cran.uib.no lucid/ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 51716619E084DAB9
    I find the new key in the $ gpg --list-key but not the 517... to delete it.

    Quote Originally Posted by Old_Gray_Wolf View Post
    Enter these commands in a terminal. Then try to update again,
    Code:
    gpg --keyserver keyserver.ubuntu.com --recv 06F90DE5381BA480
    gpg --export --armor 06F90DE5381BA480  | sudo apt-key add -

  6. #6
    Join Date
    Jan 2008
    Beans
    19

    Re: Apt authentification issue with GPG and CRAN

    It did work thought with this key:


    Code:
     gpg --keyserver keyserver.ubuntu.com --recv-key E084DAB9
     gpg -a --export E084DAB9 | sudo apt-key add -

  7. #7
    Join Date
    Sep 2007
    Location
    In here watching you!
    Beans
    Hidden!

    Re: Apt authentification issue with GPG and CRAN

    Quote Originally Posted by valugi View Post
    It did work thought with this key:


    Code:
     gpg --keyserver keyserver.ubuntu.com --recv-key E084DAB9
     gpg -a --export E084DAB9 | sudo apt-key add -
    Now that you figured out that you need to substitute the key in the error message for the key in the two command I provided, you can help the dozen or so people posting every week that have the same problem.

    It could be your way of contributing to the FOSS community.
    Use whatever OS or desktop works for you. Dual boot or use VMs if you want. Backup your computer regularly, and definitely before upgrading, partitioning, or installing an OS.

    No support requests by PM please.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •