Results 1 to 5 of 5

Thread: Requires installation of untrusted packages

  1. #1
    Join Date
    Feb 2011
    Location
    In India
    Beans
    2
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Exclamation Requires installation of untrusted packages

    Here i am facing problem while updating my System,i am using Ubuntu 10.10
    System shows following error..

    Requires installation of untrusted packages


    The action would require the installation of packages from not authenticated sources.

    Details

    libvpx0


    How can i update my system??

  2. #2
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Beans
    684
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Requires installation of untrusted packages

    Quote Originally Posted by davidbarik View Post
    How can i update my system??
    Have you changed your update servers recently? I had similar thing recently when I had very slow data from the Australian server. I changed to a NZ mirror (selected as 'best server' after doing some tests) and started getting this "untrusted packages" message. I changed back to the "Server for Australia" and the problem went away. I have no idea what's going on: maybe some of the mirrors aren't official ones?

    Chris

  3. #3
    Join Date
    Jun 2007
    Location
    Funeralopolis
    Beans
    229
    Distro
    Ubuntu Development Release

    Re: Requires installation of untrusted packages

    Quote Originally Posted by davidbarik View Post
    Here i am facing problem while updating my System,i am using Ubuntu 10.10
    System shows following error..

    Requires installation of untrusted packages


    The action would require the installation of packages from not authenticated sources.

    Details

    libvpx0


    How can i update my system??
    open terminal, and say
    Code:
    sudo apt-get update
    And after that

    Code:
    sudo apt-get upgrade
    You need to put your password and possible press Y
    Forbidden Sorcery

  4. #4
    Join Date
    Feb 2011
    Location
    In India
    Beans
    2
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Wink Re: Requires installation of untrusted packages

    Thank You ..It works!!!

  5. #5
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Requires installation of untrusted packages

    I have another understanding of this issue. I may be wrong.

    When I go to the Update Manager and click on Settings I see some tabs. The Ubuntu Software tab has some check boxes, which include "Canonical Supported Open Source Software" and "Community Maintained Open Source Software". I assume these to be trusted sources.

    There is another tab - Other software. The check boxes on this tab are for Canonical Partners (software packaged by Canonical for their partners). This I also assume is a trusted source.

    Then there are check boxes for Independent (software provided by third party developers). These are links direct to the developers website. They are called PPAs and I have put these links in myself. I think these are what Canonical is saying are untrusted sources not because the developers are necessarily untrustworthy but because we have chosen to put the update links there and they work outside of the Ubuntu arrangement for updates.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •