Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Paquests trencats en libimobiledevice

  1. #1
    Join Date
    Nov 2007
    Location
    Barcelona - Ferreries
    Beans
    18
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Paquests trencats en libimobiledevice

    Tinc instal·lat l'Ubuntu 10.10 Maverick Meerkat i l'estic intentant sincronitzar el meu iphone 3Gs.

    A través del synaptic he volgut instal·lar: libimobiledevice però de tots els fitxers no m'ha permès instal·lar el següent, diu:
    Els següents paquets tenen dependències que no es poden resoldre

    libimobiledevice1-dbg:
    Depèn: libimobiledevice1 (=1.0.1-1) però s'instal·larà 1.0.4-1ubuntu1~lucid1
    Quan he volgut instal·lar-me el programa sbManager d'acord amb aquestes instruccions:

    sudo apt-get install build-essential automake autoconf libtool libgnutls-dev libglib2.0-dev libxml2-dev libreadline5-dev swig python-dev libusbmuxd-dev libplist-dev libplist++-dev libplist++1 libzip-dev libclutter-1.0-dev libclutter-gtk-0.10-dev intltool
    m'ha sortit el següent missatge una altra vegada:

    S'està llegint la llista de paquets... Fet
    S'està construint l'arbre de dependències
    S'està llegint la informació de l'estat... Fet
    libxml2-dev ja es troba en la versió més recent.
    S'ha marcat libxml2-dev com instal·lat manualment.
    build-essential ja es troba en la versió més recent.
    libglib2.0-dev ja es troba en la versió més recent.
    S'ha marcat libglib2.0-dev com instal·lat manualment.
    libgnutls-dev ja es troba en la versió més recent.
    S'ha marcat libgnutls-dev com instal·lat manualment.
    libplist++1 ja es troba en la versió més recent.
    S'ha marcat libplist++1 com instal·lat manualment.
    libusbmuxd-dev ja es troba en la versió més recent.
    S'ha marcat libusbmuxd-dev com instal·lat manualment.
    libplist-dev ja es troba en la versió més recent.
    S'ha marcat libplist-dev com instal·lat manualment.
    No s'han pogut instal·lar alguns paquets. Això pot ser degut a que vàreu
    requerir una situació imposible o a que esteu emprant la distribució
    unstable i alguns paquets requerits encara no han estat creats o bé
    encara no els hi han afegit.
    La informació següent pot ajudar-vos a resoldre la situació:

    Els següents paquets tenen dependències sense satisfer:
    libplist++-dev : Depèn: libplist1 (= 1.3-1) però s'instal·larà 1.3-1ubuntu1~ppa1
    E: Paquets trencats
    Com puc arreglar aquests paquets que diu que estan trencats?

    En aquest fil també s'han trobat amb algun problema, però crec que no és el mateix.

    Moltes gràcies!

  2. #2
    Join Date
    May 2007
    Location
    Castalla (País Valencià)
    Beans
    599
    Distro
    Ubuntu Development Release

    Re: Paquests trencats en libimobiledevice

    si fas

    sudo apt-get install -f

    l'opció "-f" arregla els paquets que estan trencats.

    http://linux.die.net/man/8/apt-get
    T’adones amic? Hi ha gent a qui no agrada que es parle, s’escriga o es pense en català. És la mateixa gent a qui no els agrada que es parle, s’escriga o es pense
    Ovidi Montllor
    Usuari GNU/Linux #500768

  3. #3
    Join Date
    Nov 2007
    Location
    Barcelona - Ferreries
    Beans
    18
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Paquests trencats en libimobiledevice

    gràcies, kukat. he fet: sudo apt-get install -f
    i el resultat ha estat:

    S'està llegint la llista de paquets... Fet
    S'està construint l'arbre de dependències
    S'està llegint la informació de l'estat... Fet
    0 actualitzats, 0 nous a instal·lar, 0 a suprimir i 0 no actualitzats.
    i després he provat de tornar a instal·lar:

    sudo apt-get install build-essential automake autoconf libtool libgnutls-dev libglib2.0-dev libxml2-dev libreadline5-dev swig python-dev libusbmuxd-dev libplist-dev libplist++-dev libplist++1 libzip-dev libclutter-1.0-dev libclutter-gtk-0.10-dev intltool
    S'està llegint la llista de paquets... Fet
    S'està construint l'arbre de dependències
    S'està llegint la informació de l'estat... Fet
    libxml2-dev ja es troba en la versió més recent.
    S'ha marcat libxml2-dev com instal·lat manualment.
    build-essential ja es troba en la versió més recent.
    libglib2.0-dev ja es troba en la versió més recent.
    S'ha marcat libglib2.0-dev com instal·lat manualment.
    libgnutls-dev ja es troba en la versió més recent.
    S'ha marcat libgnutls-dev com instal·lat manualment.
    libplist++1 ja es troba en la versió més recent.
    S'ha marcat libplist++1 com instal·lat manualment.
    libusbmuxd-dev ja es troba en la versió més recent.
    S'ha marcat libusbmuxd-dev com instal·lat manualment.
    libplist-dev ja es troba en la versió més recent.
    S'ha marcat libplist-dev com instal·lat manualment.
    No s'han pogut instal·lar alguns paquets. Això pot ser degut a que vàreu
    requerir una situació imposible o a que esteu emprant la distribució
    unstable i alguns paquets requerits encara no han estat creats o bé
    encara no els hi han afegit.
    La informació següent pot ajudar-vos a resoldre la situació:

    Els següents paquets tenen dependències sense satisfer:
    libplist++-dev : Depèn: libplist1 (= 1.3-1) però s'instal·larà 1.3-1ubuntu1~ppa1
    E: Paquets trencats
    què puc fer més?

  4. #4
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    2,060
    Distro
    Ubuntu 17.04 Zesty Zapus

    Re: Paquests trencats en libimobiledevice

    Segons l'últim missatge que mostra sembla que tens un dipòsit "ppa" habilitat que interfereix amb el programa que vols instal·lar.

    Mira en els dipòsits que tens en "Altre programari" al synaptic si pots veure aquest dipòsit ppa i si pots deshabilitar-lo.

  5. #5
    Join Date
    Nov 2007
    Location
    Barcelona - Ferreries
    Beans
    18
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Paquests trencats en libimobiledevice

    gràcies, wgracia. no sé quin dipòsit deu ser:


  6. #6
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    2,060
    Distro
    Ubuntu 17.04 Zesty Zapus

    Re: Paquests trencats en libimobiledevice

    Tot i que tens tots els ppa desactivats, sembla que el paquet libplist-dev no està ben instal·lat. Fent un "sudo apt-cache search libplist-dev" surt

    libplist-dev - Library for handling Apple binary and XML property lists

    Així que ara pots provar primer

    sudo apt-get install --reinstall libplist-dev

    a veure si s'arregla. Si no s'arregla també pots fer

    ls /var/cache/apt/libplist*

    veure el nom exacte del fitxer "deb" on ve aquest paquet, i fer

    dpkg-deb -I /var/cache/apt/<nom del fitxer deb de libplist-dev>

    i et mostrarà les dependències, i repassar-les a veure si les tens tots instal·lades.

  7. #7
    Join Date
    Nov 2007
    Location
    Barcelona - Ferreries
    Beans
    18
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Paquests trencats en libimobiledevice

    he fet:

    sudo apt-cache search libplist-dev
    libplist-dev - Library for handling Apple binary and XML property lists
    sudo apt-get install --reinstall libplist-dev
    S'està llegint la llista de paquets... Fet
    S'està construint l'arbre de dependències
    S'està llegint la informació de l'estat... Fet
    No es possible la reinstal·lació del paquet libplist-dev, no es pot baixar.
    0 actualitzats, 0 nous a instal·lar, 0 a suprimir i 0 no actualitzats.
    ls /var/cache/apt/libplist*
    ls: no s’ha pogut accedir a /var/cache/apt/libplist*: El fitxer o directori no existeix
    he buscat si hi haiva algun fitxer en un altre lloc i he trobat aquest:

    dpkg-deb -I /var/cache/apt/archives/libplist++1_1.3-1_i386.deb
    paquet de debian nou, versió 2.0.
    mida 26166 octets: arxiu de control= 888 octets.
    712 octets, 17 línies control
    212 octets, 3 línies md5sums
    135 octets, 7 línies * postinst #!/bin/sh
    132 octets, 7 línies * postrm #!/bin/sh
    25 octets, 1 línies shlibs
    Package: libplist++1
    Source: libplist
    Version: 1.3-1
    Architecture: i386
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Original-Maintainer: Julien Lavergne <julien.lavergne@gmail.com>
    Installed-Size: 116
    Depends: libc6 (>= 2.1.3), libgcc1 (>= 1:4.1.1), libplist1 (>= 0.16), libstdc++6 (>= 4.1.1)
    Section: libs
    Priority: optional
    Homepage: http://github.com/JonathanBeck/libplist
    Description: Library for handling Apple binary and XML property lists
    libplist is a library for reading and writing the Apple binary and XML
    property lists format. It's part of the libiphone stack, providing access
    to Ipod and Iphone devices.
    .
    This library is the C++ implementation of the libplist API.
    he d'instal·lar els fitxers següents o poden estar en algun altre lloc?

    Depends: libc6 (>= 2.1.3), libgcc1 (>= 1:4.1.1), libplist1 (>= 0.16), libstdc++6 (>= 4.1.1)

  8. #8
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    2,060
    Distro
    Ubuntu 17.04 Zesty Zapus

    Re: Paquests trencats en libimobiledevice

    Al Gestor de paquets Synaptic del menú Sistema, prova d'entrar "libplist" al quadre de cerca, i mira si pots reinstal·lar el paquet des d'aquí.

    Una altra possibilitat és amb "sudo apt-get install" intentar instal·lar les dependències que has trobat.

  9. #9
    Join Date
    Nov 2007
    Location
    Barcelona - Ferreries
    Beans
    18
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Paquests trencats en libimobiledevice

    no hi ha manera. el synaptic diu el següent:



    i si instal·lo la resta de dependències em diu el següent per a cadascuna:
    ja es troba en la versió més recent.
    El paquet següent s'ha instal·lat automàticament i ja no serà necessari:
    ipheth-dkms
    Empreu «apt-get autoremove» per a suprimir-los.
    alguna altra suggerència? gràcies!

  10. #10
    Join Date
    Feb 2007
    Location
    L'Hospitalet de Llobregat
    Beans
    2,060
    Distro
    Ubuntu 17.04 Zesty Zapus

    Re: Paquests trencats en libimobiledevice

    Pots mostrar el que tens a la carpeta /etc/apt/souces.list.d:

    ls /etc/apt/sources.list.d

    i adjuntar el fitxer

    /etc/apt/sources.list

    ?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •