Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Plugging in headphones doesn't mute laptop speakers

  1. #11
    Join Date
    Jan 2012
    Beans
    2

    Re: Plugging in headphones doesn't mute laptop speakers

    hi lidex,

    i encountered the same error with thelastspud, followed your comments and get

    Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
    Uploading information to www.alsa-project.org ... Done!

    Your ALSA information is located at http://www.alsa-project.org/db/?f=a6...21891eca866ba9

    Please inform the person helping you.

    What should I do next? By the way I have ASUS K52J series running in Ubuntu 10.10


    Thanks in advance

  2. #12
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: Plugging in headphones doesn't mute laptop speakers

    Quote Originally Posted by gmangalo View Post
    hi lidex,

    i encountered the same error with thelastspud, followed your comments and get

    Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
    Uploading information to www.alsa-project.org ... Done!

    Your ALSA information is located at http://www.alsa-project.org/db/?f=a6...21891eca866ba9

    Please inform the person helping you.

    What should I do next? By the way I have ASUS K52J series running in Ubuntu 10.10


    Thanks in advance
    Try editing your alsa-base.conf:
    Code:
    gksu gedit /etc/modprobe.d/alsa-base.conf
    Change this line:
    Code:
    options and-hda-intel model=k52j position_fix=1
    to this:
    Code:
    options snd-hda-intel model=hp-laptop
    Save. Close. Reboot.

  3. #13
    Join Date
    Jan 2012
    Beans
    2

    Re: Plugging in headphones doesn't mute laptop speakers

    hi lidex,

    thanks!!! works like gem!

  4. #14
    Join Date
    May 2011
    Beans
    2

    Re: Plugging in headphones doesn't mute laptop speakers

    Quote Originally Posted by lidex View Post
    It's not available for that kernel. Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.
    when i ran the script it seem i never got a upload back this is what i got back.
    some information i have is I'm using a thinkpad x120e with ubuntu 10.10


    --2012-01-18 07:39:52-- http://www.alsa-project.org/alsa-info.sh
    Resolving www.alsa-project.org... 77.48.224.243
    Connecting to www.alsa-project.org|77.48.224.243|:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: http://git.alsa-project.org/?p=alsa-...s/alsa-info.sh [following]
    --2012-01-18 07:39:54-- http://git.alsa-project.org/?p=alsa-...s/alsa-info.sh
    Resolving git.alsa-project.org... 77.48.224.243
    Reusing existing connection to www.alsa-project.org:80.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/plain]
    Saving to: `alsa-info.sh'

    [ <=> ] 27,247 27.4K/s in 1.0s

    2012-01-18 07:39:56 (27.4 KB/s) - `alsa-info.sh' saved [27247]

    ALSA Information Script v 0.4.60
    --------------------------------

    This script visits the following commands/files to collect diagnostic
    information about your ALSA installation and sound related hardware.

    dmesg
    lspci
    lsmod
    aplay
    amixer
    alsactl
    /proc/asound/
    /sys/class/sound/
    ~/.asoundrc (etc.)

    See 'alsa-info.sh --help' for command line options.

    alsa-info.sh: line 42: ping: command not found

    An error occurred while contacting the www.alsa-project.org.
    Your information was NOT automatically uploaded.

    Your ALSA information is in /tmp/alsa-info.txt.mp0SrX3DfG

  5. #15
    Join Date
    May 2007
    Location
    Copenhagen, Denmark
    Beans
    5
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Plugging in headphones doesn't mute laptop speakers

    Hi, I got the same problem,
    the output from the script is here:
    Code:
    http://www.alsa-project.org/db/?f=d17c142cca0f7f0232830e561a8d3e497741b057
    As far as I understood. the problem is that there is no alsa driver for the kernel version I am using:
    Code:
    angelo@angelo-K50AF:~$ uname -r
    3.0.0-17-generic
    Following the instructions from lidex:
    Quote Originally Posted by lidex View Post
    Try editing your alsa-base.conf:
    Code:
    gksu gedit /etc/modprobe.d/alsa-base.conf
    Change this line:
    Code:
    options and-hda-intel model=k52j position_fix=1
    to this:
    Code:
    options snd-hda-intel model=hp-laptop
    Save. Close. Reboot.
    I guess editing the alsa-base.conf can resolve this problem, changing the line to something like this, as my computer is an ASUS:
    Code:
    options snd-hda-intel model=asus-laptop
    Is this the right way to risolve the problem?

  6. #16
    Join Date
    Jun 2007
    Beans
    13,066

    Re: Plugging in headphones doesn't mute laptop speakers

    'asus-laptop' is not a valid keyword. YOu have a VIA VT1708 codec, and a lot of jack sensing issues are resolved with ALSA 1.0.25, so try the latest driver:

    Code:
    sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
    sudo apt-get update
    sudo apt-get install alsa-hda-dkms

  7. #17
    Join Date
    May 2008
    Beans
    11
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Plugging in headphones doesn't mute laptop speakers

    Quote Originally Posted by Temüjin View Post
    'asus-laptop' is not a valid keyword. YOu have a VIA VT1708 codec, and a lot of jack sensing issues are resolved with ALSA 1.0.25, so try the latest driver:

    Code:
    sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
    sudo apt-get update
    sudo apt-get install alsa-hda-dkms

    I was having the same problem (Ubuntu 10.10) and the above fixed it for me.

    Thanks very much!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •