Page 6 of 8 FirstFirst ... 45678 LastLast
Results 51 to 60 of 79

Thread: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it here

  1. #51
    Join Date
    May 2007
    Beans
    2,334

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    Quote Originally Posted by jimmybondo View Post
    Looks like it is:

    Code:
    @ginny:~$ dmesg | grep command
    [    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=14269af7-9967-47ba-a9e7-604442117bb7 ro splash vga=799 quiet splash irqpoll vt.handoff=7
    Jim
    Hi,

    Then sorry I'm not sure what your problem is.

    Regards
    Ian Dobson
    Walking on water and writing software to specification is easy if they're frozen.

    My corner of the internet http://www.planet-ian.com

  2. #52
    Join Date
    Dec 2007
    Beans
    47

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    Distro and release (eg. Ubuntu 10.10, Fedora 13):
    Mythbuntu 11.10

    Full version of the MythTV Backend package (eg. dpkg -l mythtv-backend*):
    2:0.24.0+fixes.20110908.1de0431-0ubun

    Where you get your mythtv packages from (standard repos, avenard repos, mythbuntu repos, compile from source, etc):

    Mythbuntu

    Tuners you see the issue on:
    HD PVR

    Other tuners on your system:
    None

    Firmware version version (eg. 'dmesg | grep hdpvr')
    Code:
    [   25.071685] hdpvr 1-2:1.0: firmware version 0xf dated Mar 11 2009 06:03:02
    [   25.071688] hdpvr 1-2:1.0: untested firmware, the driver might not work.
    [   25.256293] hdpvr 1-2:1.0: device now attached to video0
    Kernel Version (uname -a):
    3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:34:47 UTC 2011 i686 athlon i386 GNU/Linux

    Snippet of dmesg around the time the issue is happening:
    Couldn't find anything remarkable, but here it goes:
    Code:
    [ 2342.471796] show_signal_msg: 6 callbacks suppressed
    [ 2342.471801] mythpreviewgen[2145]: segfault at b3138130 ip 0538e43a sp b2449d00 error 6 in libmythavcodec.so.52.86.1[4fec000+513000]

    Any other info you think is relevant:
    About 50% or so of my recordings end up as 0 byte. When I get ONE 0byte recording, I have to restart the HD-PVR, otherwise all subsequent recordings are 0byte too.
    Sometimes the 0byte recordings don't happen for a week, at other times it happens constantly.
    This started happening shortly after a distro-upgrade. I believe it was when upgrading Myth 0.23 to 0.24, but I am NOT absolutely certain.
    Even though I am currently running 11.10, it also happened with 11.4. I did two clean installs, issue was not fixed. I am currently considering dumping all recordings and going back to 0.23.
    Last edited by stefanst; December 26th, 2011 at 12:21 AM.

  3. #53
    Join Date
    Mar 2009
    Beans
    116
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    I just want to say that all of my problems are resolved by actually making use of the storage directories from within Mythtv. I still have my older/slower SATA drives in use, but by allowing the system to determine load balancing, I am able to record on 4 channels simultaneously and without regard to one of the station's signals getting atmospheric interference (OTA). Since actually setting my system up the way the designers seemed to have envisioned it, I have gone from ~40-50% of my recordings being lost, to no 0-byte recordings at all. And the system is transcoding up to 2 shows at a time while recording.

    In my case, I mark this down to operator error
    Out of the ashes of disaster grow the roses of success

    Are you for Linux? Is Linux for you?

  4. #54
    Join Date
    Apr 2007
    Beans
    780

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    Distro and release (eg. Ubuntu 10.10, Fedora 13): mythbuntu 11.10

    Where you get your mythtv packages from (standard repos, avenard repos, mythbuntu repos, compile from source, etc): downloaded live CD
    Tuners you see the issue on: unknown, but all tuners are DVB

    Any other info you think is relevant: Noticed I was getting failure to lock on live TV, so I doubled the default timeout. I think it needs to be a bit longer still, because maybe this caused the 0 byte recording.

    Edit: noticed this was happening on one channel only so far - all in one digital transport stream, that is. Doubled my signal and tuning timeouts in the card config for all cards. First couple of tests worked, so will monitor and see what happens.
    Last edited by ubnewbie2; January 8th, 2012 at 01:10 AM.

  5. #55
    Join Date
    Nov 2009
    Beans
    7

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    Distro and release (eg. Ubuntu 10.10, Fedora 13):
    Mythbuntu 10.04 LTS

    Full version of the MythTV Backend package (eg. dpkg -l mythtv-backend*):
    mythtv-backend 0.23.1+fixes26 A personal video recorder application (serve
    mythtv-backend 0.23.1+fixes26 Metapackage to setup and configure a "Master

    Where you get your mythtv packages from (standard repos, avenard repos, mythbuntu repos, compile from source, etc):

    Mythbuntu

    Tuners you see the issue on:
    HD PVR

    Other tuners on your system:
    HVR-2250 (using analog for SD cable) Happened before adding this tuner.

    Firmware version version (eg. 'dmesg | grep hdpvr')
    Code:
    [ 11.601821] hdpvr 1-7:1.0: untested firmware version 0x15, the driver might not work
    [ 11.928897] hdpvr 1-7:1.0: device now attached to video0
    [ 11.928916] usbcore: registered new interface driver hdpvr


    Kernel Version (uname -a):
    2.6.32-37-generic #81-Ubuntu SMP Fri Dec 2 20:32:42 UTC 2011 x86_64 GNU/Linux

    Snippet of dmesg around the time the issue is happening:
    System has been rebooted since the last time, so nothing to give you.


    Any other info you think is relevant:

    I am using Gavin Hurlbut's "hdpvr killer device" to automatically power cycle the hd-pvr when it locks up. It doesn't happen very frequently but once in a while. The last few times it happened are on 2011-12-12, 2011-12-19 and 2011-12-23 and none since.
    I've seen this happen for a long time, always on 0.23 and through several different kernel upgrades.
    The blue halo will stay on from the last successful recording and will then fail on the next start of recording. Once it locked in switching to Live TV and rebooting the computer alone (couldn't get out of Live TV mode) fixed the problem, without having to power cycle the HD-PVR.

    HD-PVR is Rev D2, power supply fried recently so I replaced it with another 5V, 2A switching PS with no difference in locking behaviour.
    HD-PVR is connected to USB2 port on it's own bus

    lsusb:
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 003: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
    Bus 004 Device 002: ID 0bc7:0008 X10 Wireless Technology, Inc. Wireless Transceiver (ACPI-compliant)
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 002: ID 1241:f766 Belkin
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 005: ID 2040:4901 Hauppauge
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

  6. #56
    Join Date
    Dec 2009
    Location
    Muscatine, IA
    Beans
    83
    Distro
    Lubuntu 13.10 Saucy Salamander

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    Quote Originally Posted by dborn View Post
    Distro and release (eg. Ubuntu 10.10, Fedora 13):
    Mythbuntu 10.04 LTS

    Full version of the MythTV Backend package (eg. dpkg -l mythtv-backend*):
    mythtv-backend 0.23.1+fixes26 A personal video recorder application (serve
    mythtv-backend 0.23.1+fixes26 Metapackage to setup and configure a "Master

    Where you get your mythtv packages from (standard repos, avenard repos, mythbuntu repos, compile from source, etc):

    Mythbuntu

    Tuners you see the issue on:
    HD PVR

    Other tuners on your system:
    HVR-2250 (using analog for SD cable) Happened before adding this tuner.

    Firmware version version (eg. 'dmesg | grep hdpvr')
    Code:
    [ 11.601821] hdpvr 1-7:1.0: untested firmware version 0x15, the driver might not work
    [ 11.928897] hdpvr 1-7:1.0: device now attached to video0
    [ 11.928916] usbcore: registered new interface driver hdpvr


    Kernel Version (uname -a):
    2.6.32-37-generic #81-Ubuntu SMP Fri Dec 2 20:32:42 UTC 2011 x86_64 GNU/Linux

    Snippet of dmesg around the time the issue is happening:
    System has been rebooted since the last time, so nothing to give you.


    Any other info you think is relevant:

    I am using Gavin Hurlbut's "hdpvr killer device" to automatically power cycle the hd-pvr when it locks up. It doesn't happen very frequently but once in a while. The last few times it happened are on 2011-12-12, 2011-12-19 and 2011-12-23 and none since.
    I've seen this happen for a long time, always on 0.23 and through several different kernel upgrades.
    The blue halo will stay on from the last successful recording and will then fail on the next start of recording. Once it locked in switching to Live TV and rebooting the computer alone (couldn't get out of Live TV mode) fixed the problem, without having to power cycle the HD-PVR.

    HD-PVR is Rev D2, power supply fried recently so I replaced it with another 5V, 2A switching PS with no difference in locking behaviour.
    HD-PVR is connected to USB2 port on it's own bus

    lsusb:
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 003: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
    Bus 004 Device 002: ID 0bc7:0008 X10 Wireless Technology, Inc. Wireless Transceiver (ACPI-compliant)
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 002: ID 1241:f766 Belkin
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 005: ID 2040:4901 Hauppauge
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    I'm not sure if this will help you or not, but you might want to check over at http://www.linuxtv.org (the people who are creating the drivers for your TV Tuner). Taylor Ralph (might be Ralph Taylor also) submitted a patch for the HD-PVR that's supposed to help it work with firmware versions > 15. I realize that your version is 15, but his patch may have fixed some of your issues.

    Plus, you can post the issue there on their mailing list, and possibly get help with it.

    Have a great day
    Patrick.

  7. #57
    Join Date
    Apr 2007
    Beans
    780

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    Hmmm, thought things were going well, but I just got three 0-byte recordings in one night !!! One of them I really wanted

    Are any fixes coming through trying to address this issue??

  8. #58
    Join Date
    Apr 2007
    Beans
    780

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    Edit: I seem to have this solved now. Guess I am one the lucky ones, but the fix for me was to add vmalloc=192M to the GRUB_CMDLINE_LINUX_DEFAULT line in Grub's config.

    ================================================== =====

    0 byte recordings is getting so bad I can't rely on mythtv to record shows. I am missing 2 or 3 every night lately.


    Distro and release (eg. Ubuntu 10.10, Fedora 13): Mythbuntu 11.10

    Full version of the MythTV Backend package (eg. dpkg -l mythtv-backend*): mythtv-backend 2:0.24.1+fixes

    Where you get your mythtv packages from (standard repos, avenard repos, mythbuntu repos, compile from source, etc): mythbuntu

    Tuners you see the issue on: WinFast DTV1000-T cx2388x based DVB/ATSC card (2 of these) and ASUS My Cinema U3100 Mini DVBT Tuner

    Other tuners on your system: no others

    Firmware version version (eg. 'dmesg | grep hdpvr'): n/a
    Kernel Version (uname -a):Linux mythbuntu4 3.0.0-15-generic #25-Ubuntu SMP Mon Jan 2 17:45:26 UTC 2012 i686 athlon i386 GNU/Linux


    Snippet of dmesg around the time the issue is happening:


    Any other info you think is relevant:
    mythbackend log

    2012-01-22 21:14:29.579 TVRec(3): ASK_RECORDING 3 29 0 0
    2012-01-22 21:15:02.965 TVRec(3): Changing from None to RecordingOnly
    2012-01-22 21:15:03.026 TVRec(3): HW Tuner: 3->3
    2012-01-22 21:15:03.460 AutoExpire: CalcParams(): Max required Free Space: 7.0 GB w/freq: 4 min
    2012-01-22 21:15:03.666 Started recording: "Jurassic Park III": channel 1073 on cardid 3, sourceid 1
    2012-01-22 21:15:03.853 DVBSH(/dev/dvb/adapter1/frontend0) Warning: Opening DVR device /dev/dvb/adapter1/dvr0 failed : Cannot allocate memory
    2012-01-22 21:15:04.009 DVBSH(/dev/dvb/adapter1/frontend0):
    Failed to open DVR device /dev/dvb/adapter1/dvr0 : Cannot allocate memory
    2012-01-22 21:15:04.112 ProgramInfo(1073_20120122211500.mpg), Error: GetPlaybackURL: '1073_20120122211500.mpg' should be local, but it can not be found.
    2012-01-22 21:15:04.202 ProgramInfo(1090_20120122183000.mpg), Error: GetPlaybackURL: '1090_20120122183000.mpg' should be local, but it can not be found.
    2012-01-22 21:15:13.207 AutoExpire: CalcParams(): Max required Free Space: 7.0 GB w/freq: 4 min
    Last edited by ubnewbie2; January 26th, 2012 at 01:05 AM.

  9. #59
    Join Date
    Feb 2012
    Beans
    4

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    Distro and release (eg. Ubuntu 10.10, Fedora 13):
    Mythbuntu 11.10

    Full version of the MythTV Backend package (eg. dpkg -l mythtv-backend*):
    mythtv-backend 2:0.24.2+fixes

    Where you get your mythtv packages from (standard repos, avenard repos, mythbuntu repos, compile from source, etc):

    Mythbuntu repos

    Tuners you see the issue on:
    2 x Hauppauge Nova-T DVB-T USB Stiicks

    Other tuners on your system:
    None.

    Firmware version version (eg. 'dmesg | grep hdpvr')
    Not certain what you want here - dmesg | grep dvb didn't suggest a firmware version

    Kernel Version (uname -a):
    3.0.0.15-generic #26-Ubuntu SMP Fri Jan 20 15:59:53 UTC 2012 i686 i686 i386 GNU/Linux

    Snippet of dmesg around the time the issue is happening:
    System has been rebooted since the last time, so nothing to give you.


    Any other info you think is relevant:

    Zero length recordings on 80% of attempts until I disabled EIT scanning, now seems to work 100% using XMLTV.

    Tuning delays of 350ms and 425ms in the tuning options for the cards.

    Max of 2 recordings per tuner

    lsusb:
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 002: ID 2040:7060 Hauppauge Nova-T Stick 2
    Bus 005 Device 003: ID 2040:7060 Hauppauge Nova-T Stick 2

    Peter

  10. #60
    Join Date
    Oct 2010
    Beans
    3

    Re: RFH: Do you get 0-byte recordings? (Even infrequently) Please post info about it

    I was experiencing daily 0-byte recordings to the point where my HD-PVR was essentially unreliable/useless. It would require a reboot of the MythTV machine to get it working again.

    Then I read a thread about inadequate ventilation of the HD-PVR and bought a mini wire-rack shelf from the local dollar store. After placing the HD-PVR on top of it (now with 2-3 inches clearance below it), the difference was night and day, and I'm running nearly 3 months without a single 0-byte recording.

    I haven't changed any other settings/software, kernels or distros during this time.

Page 6 of 8 FirstFirst ... 45678 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •