In an attempt to be the coolest cat on the net, I decided to try to install the latest version of amsn (i believe that was my goal, I can't quite remember).
After a few hours of dependency hell(The newest version required the latest gstreamer among a slew of other things to build from source), I said screw it and gave up. Now a couple of days later I fire up cheese, and lo and behold : This

I tried uninstalling my source-built gstreamer packages and --reinstalling all the ones from the repository, but I'm having no luck whatsoever.