Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Can't connect to Wired/Wireless Internet

  1. #1
    Join Date
    Feb 2011
    Beans
    7

    Can't connect to Wired/Wireless Internet

    Hi everyone,

    I've installed ubuntu for the first time today and am having trouble with the internet connection. I cannot connect wired or wireless, the computer doesn't pick it up. It's fine on my Windows 7 though. I've read through some previous threads about similar problems, but I found it either too confusing, not the same version, or not the exact same problem. The problem is with my HP laptop and if you're curious I am posting from my other computer.

    Here are some details about my laptop:

    When running lspci -v:
    Code:
    00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 64
    
    00:02.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Graphics Port 0) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 00009000-00009fff
        Memory behind bridge: bfe00000-bfefffff
        Prefetchable memory behind bridge: 00000000c0000000-00000000dfffffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp
    
    00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=07, sec-latency=0
        Memory behind bridge: f0200000-f02fffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp
    
    00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=08, subordinate=0d, sec-latency=0
        I/O behind bridge: 0000a000-0000afff
        Memory behind bridge: be000000-be0fffff
        Prefetchable memory behind bridge: 00000000f0400000-00000000f04fffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp
    
    00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA (prog-if 01 [AHCI 1.0])
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 21
        I/O ports at 8440 [size=8]
        I/O ports at 8434 [size=4]
        I/O ports at 8438 [size=8]
        I/O ports at 8430 [size=4]
        I/O ports at 8400 [size=16]
        Memory at f0309000 (32-bit, non-prefetchable) [size=1K]
        Capabilities: <access denied>
        Kernel driver in use: ahci
        Kernel modules: ahci
    
    00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0) (prog-if 10 [OHCI])
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
        Memory at f0304000 (32-bit, non-prefetchable) [size=4K]
        Kernel driver in use: ohci_hcd
    
    00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1) (prog-if 10 [OHCI])
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17
        Memory at f0305000 (32-bit, non-prefetchable) [size=4K]
        Kernel driver in use: ohci_hcd
    
    00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2) (prog-if 10 [OHCI])
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 18
        Memory at f0306000 (32-bit, non-prefetchable) [size=4K]
        Kernel driver in use: ohci_hcd
    
    00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3) (prog-if 10 [OHCI])
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17
        Memory at f0307000 (32-bit, non-prefetchable) [size=4K]
        Kernel driver in use: ohci_hcd
    
    00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4) (prog-if 10 [OHCI])
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 18
        Memory at f0308000 (32-bit, non-prefetchable) [size=4K]
        Kernel driver in use: ohci_hcd
    
    00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI) (prog-if 20 [EHCI])
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 19
        Memory at f0309400 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>
        Kernel driver in use: ehci_hcd
    
    00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: 66MHz, medium devsel
        I/O ports at 8410 [size=16]
        Capabilities: <access denied>
        Kernel driver in use: piix4_smbus
        Kernel modules: i2c-piix4
    
    00:14.1 IDE interface: ATI Technologies Inc SB600 IDE (prog-if 80 [Master])
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
        I/O ports at 01f0 [size=8]
        I/O ports at 03f4 [size=1]
        I/O ports at 0170 [size=8]
        I/O ports at 0374 [size=1]
        I/O ports at 8420 [size=16]
        Kernel driver in use: pata_atiixp
        Kernel modules: pata_atiixp
    
    00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, slow devsel, latency 64, IRQ 16
        Memory at f0300000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
    
    00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, 66MHz, medium devsel, latency 0
    
    00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (prog-if 01 [Subtractive decode])
        Flags: bus master, 66MHz, medium devsel, latency 64
        Bus: primary=00, secondary=0e, subordinate=13, sec-latency=64
    
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
        Flags: fast devsel
        Capabilities: <access denied>
    
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
        Flags: fast devsel
    
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
        Flags: fast devsel
        Kernel modules: amd64_edac_mod
    
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
        Flags: fast devsel
        Capabilities: <access denied>
        Kernel driver in use: k8temp
        Kernel modules: k8temp
    
    01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, fast devsel, latency 0, IRQ 44
        Memory at c0000000 (32-bit, prefetchable) [size=512M]
        I/O ports at 9000 [size=256]
        Memory at bfef0000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at bfe00000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: radeon
        Kernel modules: radeon
    
    01:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
        Subsystem: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at bfeec000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
    
    02:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
        Subsystem: Hewlett-Packard Company Device 1509
        Flags: bus master, fast devsel, latency 0, IRQ 18
        Memory at f0200000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: b43-pci-bridge
        Kernel modules: ssb
    
    08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
        Subsystem: Hewlett-Packard Company Device 3055
        Flags: bus master, fast devsel, latency 0, IRQ 43
        I/O ports at a000 [size=256]
        Memory at f0410000 (64-bit, prefetchable) [size=4K]
        Memory at f0400000 (64-bit, prefetchable) [size=64K]
        [virtual] Expansion ROM at f0420000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: r8169
        Kernel modules: r8169
    When running ifconfig -a:
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:21:cc:38:91:d5  
              inet6 addr: fe80::221:ccff:fe38:91d5/64 Scope:Link
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:2278 errors:0 dropped:0 overruns:0 frame:0
              TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:142612 (142.6 KB)  TX bytes:8925 (8.9 KB)
              Interrupt:43 Base address:0xa000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:244 errors:0 dropped:0 overruns:0 frame:0
              TX packets:244 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:19176 (19.1 KB)  TX bytes:19176 (19.1 KB)
    When running iwconfig:
    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    When running uname -r:
    Code:
    2.6.35-22-generic
    Thank you for your time and effort
    Last edited by decirue; February 6th, 2011 at 01:59 AM.

  2. #2
    Join Date
    Feb 2011
    Beans
    7

    Re: Can't connect to Wired/Wireless Internet

    Suggestions anyone?

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,575
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Can't connect to Wired/Wireless Internet

    Let's get the wired working first; it will make getting wireless going a lot easier. Please be sure the ethernet cable is attached and then run:
    Code:
    sudo lshw -C network
    Does the ethernet card show 'link=no' even though the cable is attached? Then see: http://ubuntuforums.org/showthread.php?t=53844
    As of 27 May 2007, in kernel 2.6.21.3, you may experience the issues with the r8169 driver if you dual boot Windows on some systems. Windows by defaults disables the NIC at Windows shutdown time in order to disable Wake-On-Lan, and this NIC will remain disabled until the next time Windows turns it on
    After the ethernet is working, go to System > Administration > Additional Drivers and activate your Broadcom wireless.

    Post back if you need additional guidance.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #4
    Join Date
    Feb 2011
    Beans
    7

    Re: Can't connect to Wired/Wireless Internet

    Thanks for the help. Now when I connected my ethernet cable, I was able to connect wired, which is odd since it wouldn't before. Anyway now there's a new problem. I opened additional drivers and it tells me "No proprietary drivers are in use on this system." In addition, when I update using the update manager, it takes a really long time to load after I click authenticate. Then when it's done loading, the checkboxes remain and what I thought was just updated, remains un-updated.

  5. #5
    Join Date
    Feb 2011
    Beans
    7

    Re: Can't connect to Wired/Wireless Internet

    Quote Originally Posted by decirue View Post
    Thanks for the help. Now when I connected my ethernet cable, I was able to connect wired, which is odd since it wouldn't before. Anyway now there's a new problem. I opened additional drivers and it tells me "No proprietary drivers are in use on this system." In addition, when I update using the update manager, it takes a really long time to load after I click authenticate. Then when it's done loading, the checkboxes remain and what I thought was just updated, remains un-updated.
    Scratch that. Now the drivers showed up after a few times- the update problem however still remains.

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,575
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Can't connect to Wired/Wireless Internet

    Let's troubleshoot the wired connection. Please run and post:
    Code:
    ifconfig eth0
    ping -c3 www.google.com
    sudo ethtool eth0
    Let's also see what's happening with your wireless:
    Code:
    dmesg | grep b43
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Feb 2011
    Beans
    7

    Re: Can't connect to Wired/Wireless Internet

    ifconfig eth0 gives me
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:21:cc:38:91:d5  
              inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::221:ccff:fe38:91d5/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:24798 errors:0 dropped:0 overruns:0 frame:0
              TX packets:18384 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:30401014 (30.4 MB)  TX bytes:2089793 (2.0 MB)
              Interrupt:43 Base address:0x8000
    ping -c3 www.google.com gives me
    Code:
    PING www.l.google.com (74.125.127.103) 56(84) bytes of data.
    64 bytes from pz-in-f103.1e100.net (74.125.127.103): icmp_req=1 ttl=53 time=19.9 ms
    64 bytes from pz-in-f103.1e100.net (74.125.127.103): icmp_req=2 ttl=53 time=20.1 ms
    64 bytes from pz-in-f103.1e100.net (74.125.127.103): icmp_req=3 ttl=53 time=20.7 ms
    
    --- www.l.google.com ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2002ms
    rtt min/avg/max/mdev = 19.929/20.256/20.726/0.340 ms
    sudo ethtool eth0 gives me
    Code:
    sudo: ethtool: command not found
    The dmesg command gave me
    Code:
    [    1.251720] b43-pci-bridge 0000:02:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
    [    1.251732] b43-pci-bridge 0000:02:00.0: setting latency timer to 64
    [   17.690386] b43-phy0: Broadcom 4322 WLAN found (core revision 16)
    [   17.790191] b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 8, Type 4, Revision 4)
    [   17.790307] b43: probe of ssb0:0 failed with error -95
    Also, the authenticate is still running for updating my drivers so I don't think wireless works yet. Wired is still OK. I also just got a message saying the Jockey backend has crashed (message for Additional Drivers update).

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,575
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Can't connect to Wired/Wireless Internet

    Let's wait until your updates run and install. Your wired appears to be working perfectly. When the updates are done. please run:
    Code:
    lspci -nn | grep -i 14e4
    If the pci.id for your Broadcom is 14E4:432C Broadcom Corporation BCM4322 802.11b/g/n, then b43 and ssb are incorrect. You'll need to do:
    Code:
    sudo apt-get install bcmwl-kernel-source
    wl is the correct driver for your device. If the pci.id is different, post back and we'll get it going.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #9
    Join Date
    Feb 2011
    Location
    kolkata
    Beans
    63
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can't connect to Wireless Internet and no sound output

    Sorry but i have a similar problem with my hp laptop. i just installed ubuntu 9.04.
    my laptop model no. is hp g42-460tu.
    my wireless connectivity is not working thou the wired one is working fine. i m new to ubuntu so need help id that. i hope no one mind me posting on a already posted thread. i m not that known to the rules of this forum so apologies in advance. just tel me what u want to know of my laptop or os and help me please. also the inbuilt sound is not working but if i connect to external speaker or headset its working fine. help me

  10. #10
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,575
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Can't connect to Wireless Internet and no sound output

    Quote Originally Posted by piymon View Post
    Sorry but i have a similar problem with my hp laptop. i just installed ubuntu 9.04.
    my laptop model no. is hp g42-460tu.
    my wireless connectivity is not working thou the wired one is working fine. i m new to ubuntu so need help id that. i hope no one mind me posting on a already posted thread. i m not that known to the rules of this forum so apologies in advance. just tel me what u want to know of my laptop or os and help me please. also the inbuilt sound is not working but if i connect to external speaker or headset its working fine. help me
    It's considered impolite to join another thread unless your hardware is exactly the same. Please run:
    Code:
    lspci -nn
    If your wireless device is not a Broadcom BCM4322, post a new thread and quote what it is. If it is the same, simply watch this thread for instructions.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •