Results 1 to 3 of 3

Thread: Application in focus move when changing workspace

  1. #1
    Join Date
    Oct 2007
    Beans
    7

    Application in focus move when changing workspace

    Hi,

    Just installed a new computer with ubuntu 10.10. I assign shortkey alt+1 to move workspace left and alt+2 to move workspace right.

    When I move workspace the focus application move with me to the new workspace. That is kind of annoying since I usually build up my workspace with mail here, music here, surf here. After sometime with this new "feature/bug" I got application all over the place.

    1) How do I turn this off?
    2) How do I enable dragging application from one workspace to another.

    (Visual effects is set to Normal)

    Thanks!

  2. #2
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Application in focus move when changing workspace

    1. Where (and how) exactly did you configure this shortcut?

    Compiz plugins have two separate options for moving from a desktop to another, a normal one and then one that moves the active window with you. Sounds like you binded the shortcut to wrong one...

    2. In CompizConfig Settings manager, under Desktop Wall/Viewport Switching or Rotate Cube/General (depending on which one you are using) enable the the "Edge Flip Move"-option.

  3. #3
    Join Date
    Oct 2007
    Beans
    7

    Re: Application in focus move when changing workspace

    Quote Originally Posted by mcduck View Post
    1. Where (and how) exactly did you configure this shortcut?

    Compiz plugins have two separate options for moving from a desktop to another, a normal one and then one that moves the active window with you. Sounds like you binded the shortcut to wrong one...

    2. In CompizConfig Settings manager, under Desktop Wall/Viewport Switching or Rotate Cube/General (depending on which one you are using) enable the the "Edge Flip Move"-option.
    Well, now I feel kinda stupid. I did the change in System -> Preference -> Keyboard shortcuts.

    But I just noticed that i had put alt+1 to "Move window one workspace to the left" instead of "Switch to workspace on the left of the current workspace".

    Thanks m8, all good now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •