Results 1 to 3 of 3

Thread: How do I disable LIBGL_ALWAYS_INDIRECT?

  1. #1
    Join Date
    Apr 2008
    Beans
    33

    How do I disable LIBGL_ALWAYS_INDIRECT?

    Hi all,
    I've upgraded my graphic card to ATI Radeon HD 5570 and installed the latest Catalyst driver found on ATI website.

    But I ran into problems running for example StarCraft 2 via Wine.

    Wine complains about DirectDraw being turned off.
    After a bit of searching I found this:
    glxinfo | grep rendering
    Code:
    direct rendering: No (LIBGL_ALWAYS_INDIRECT set)
    When I do unset LIBGL_ALWAYS_INDIRECT and then launch StarCraft 2 from the terminal, it works.
    But only for that terminal session.

    How do I disable LIBGL_ALWAYS_INDIRECT permanently?
    Thanks.

  2. #2
    Join Date
    Apr 2008
    Beans
    33

    Re: How do I disable LIBGL_ALWAYS_INDIRECT?

    Still no luck.
    Haven't even found any config files containing text LIBGL_ALWAYS_INDIRECT.

    I had nVidia driver before, is it possible that some part of it didn't uninstall and is now causing the problem?

  3. #3
    Join Date
    Jun 2007
    Beans
    12,960

    Re: How do I disable LIBGL_ALWAYS_INDIRECT?

    You may want to put this at the end of your ~/.bashrc
    Code:
    export LIBGL_ALWAYS_INDIRECT=no
    Warning: I sometimes lack patience. Don't take it personally.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •