Results 1 to 6 of 6

Thread: Update manger crashed, now I can't run it or synaptic or apt-get

  1. #1
    Join Date
    Dec 2007
    Beans
    16

    Update manger crashed, now I can't run it or synaptic or apt-get

    Help!

    Update manager crashed last time I used it (although the updates seemed to happen OK.) Now it quits immediately if I try to run it, as does Synaptic. If I try apt-get from the command line, I get a Segmentation fault, e.g.

    $ sudo apt-get autoclean
    Reading package lists... Done
    Segmentation faulty tree... 50%

    How can I repair this?

    Running 10.10 on a Dell XPS M1330 laptop.

  2. #2
    Join Date
    Sep 2009
    Beans
    8,874
    Distro
    Ubuntu Development Release

    Re: Update manger crashed, now I can't run it or synaptic or apt-get

    Try these commands.
    sudo dpkg --configure -a
    sudo apt-get -f install
    Last edited by wilee-nilee; January 31st, 2011 at 01:32 AM.





  3. #3
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,460
    Distro
    Ubuntu Development Release

    Re: Update manger crashed, now I can't run it or synaptic or apt-get

    Wilee-nilee has a typo:
    sudo apt-get -f install
    Remember hence where you come and pass it down.
    Ubuntu Forums member #899097 and Ubuntu Member:
    http://www.ubuntupocketguide.com/index_main.html
    Main Page -

  4. #4
    Join Date
    Sep 2009
    Beans
    8,874
    Distro
    Ubuntu Development Release

    Re: Update manger crashed, now I can't run it or synaptic or apt-get

    Quote Originally Posted by garvinrick4 View Post
    Wilee-nilee has a typo:
    sudo apt-get -f install
    Thanks for noticing, the cheat sheet got mixed up in editing.





  5. #5
    Join Date
    Dec 2007
    Beans
    16

    Re: Update manger crashed, now I can't run it or synaptic or apt-get

    Thanks! That fixed it. )

  6. #6
    Join Date
    May 2007
    Beans
    16
    Distro
    Ubuntu

    Re: Update manger crashed, now I can't run it or synaptic or apt-get

    Doesn't work for me. Still getting Segmentation faultsts... 0% on any update or upgrade attempts

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •