Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Must Disable, then Enable Networking for Wireless...

  1. #11
    Join Date
    Jan 2011
    Location
    Nelsonville, OH
    Beans
    15
    Distro
    Ubuntu Development Release

    Re: Must Disable, then Enable Networking for Wireless...

    No, the network driver pretty much took care of itself upon OS installation. I haven't messed with it since either. At least we're starting to get past most of the stuff I've already checked though. lolz

    Keep it coming guys... We'll fix this yet! ^_^
    "Such are the heights of wickedness to which men are driven by religion." - Lucretius (99-55 BCE)

  2. #12
    Join Date
    Nov 2010
    Location
    NM
    Beans
    1,121
    Distro
    Lubuntu Development Release

    Re: Must Disable, then Enable Networking for Wireless...

    Quote Originally Posted by theirishfrog.sh View Post
    No, the network driver pretty much took care of itself upon OS installation. I haven't messed with it since either. At least we're starting to get past most of the stuff I've already checked though. lolz

    Keep it coming guys... We'll fix this yet! ^_^
    Try this code in the terminal before you click the network manager

    Code:
    sudo lshw -C network
    Then repeat after you get the wireless established.

    Oh by the way also do a
    Code:
    uname -a
    or even better try
    cat /etc/lsb-release
    Last edited by nm_geo; February 5th, 2011 at 12:15 AM.
    Boot Info Script
    Ubuntu User number is # 32763
    Linux User number is # 527179

  3. #13
    Join Date
    Dec 2009
    Location
    Southern Maryland
    Beans
    1,575
    Distro
    Ubuntu

    Re: Must Disable, then Enable Networking for Wireless...

    May also need to look at what drivers are loading BEFORE and AFTER you enable it in the network manager to see if it's just a missing module on startup and you enabling it may do the same as the modprobe command. Just a thought but I may be way off.

    Restart the computer and when it's fully booted, go into a terminal and type in
    Code:
    lsmod
    and THEN enable the wireless like you did before and again go into a terminal and
    Code:
    lsmod
    again. Paste both outputs here and we'll find the missing driver if that's the issue. If it is, then it's just a gedit of /etc/modules and adding it to the end of the list. And hopefully it's not somehow blacklisted, but that's another thing for later if this doesn't work.

  4. #14
    Join Date
    Jan 2011
    Location
    Nelsonville, OH
    Beans
    15
    Distro
    Ubuntu Development Release

    Re: Must Disable, then Enable Networking for Wireless...

    The only difference that I noticed was that after the network was enabled, the configuration lists my local IP address. Does that help at all?

    Code:
    david@david-Satellite-L505D:~$ sudo lshw -C network
    [sudo] password for david: 
      *-network               
           description: Wireless interface
           product: RTL8187SE Wireless LAN Controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: wlan0
           version: 22
           serial: 70:f1:a1:2c:d7:38
           width: 32 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=r8180 latency=0 multicast=yes wireless=802.11b/g
           resources: irq:16 ioport:7000(size=256) memory:92100000-92103fff
      *-network
           description: Ethernet interface
           product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: eth0
           version: 02
           serial: 00:26:6c:4d:c1:36
           size: 10MB/s
           capacity: 100MB/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10MB/s
           resources: irq:43 ioport:6000(size=256) memory:90010000-90010fff memory:90000000-9000ffff memory:90020000-9003ffff
    Code:
    david@david-Satellite-L505D:~$ sudo lshw -C network
      *-network               
           description: Wireless interface
           product: RTL8187SE Wireless LAN Controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: wlan0
           version: 22
           serial: 70:f1:a1:2c:d7:38
           width: 32 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=r8180 ip=192.168.2.2 latency=0 multicast=yes wireless=802.11b/g  link
           resources: irq:16 ioport:7000(size=256) memory:92100000-92103fff
      *-network
           description: Ethernet interface
           product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: eth0
           version: 02
           serial: 00:26:6c:4d:c1:36
           size: 10MB/s
           capacity: 100MB/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10MB/s
           resources: irq:43 ioport:6000(size=256) memory:90010000-90010fff memory:90000000-9000ffff memory:90020000-9003ffff
    Code:
    david@david-Satellite-L505D:~$ uname -a
    Linux david-Satellite-L505D 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:44 UTC 2011 x86_64 GNU/Linux
    Code:
    david@david-Satellite-L505D:~$ cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=10.10
    DISTRIB_CODENAME=maverick
    DISTRIB_DESCRIPTION="Ubuntu 10.10"
    Last edited by theirishfrog.sh; February 5th, 2011 at 06:29 PM.
    "Such are the heights of wickedness to which men are driven by religion." - Lucretius (99-55 BCE)

  5. #15
    Join Date
    Jan 2011
    Location
    Nelsonville, OH
    Beans
    15
    Distro
    Ubuntu Development Release

    Re: Must Disable, then Enable Networking for Wireless...

    Is this any help at all?

    Code:
    david@david-Satellite-L505D:~$ lsmod
    Module                  Size  Used by
    cryptd                  8140  0 
    aes_x86_64              7936  495 
    aes_generic            27631  1 aes_x86_64
    binfmt_misc             7984  1 
    parport_pc             30086  0 
    ppdev                   6804  0 
    dm_crypt               13381  0 
    snd_hda_codec_realtek   300173  1 
    snd_hda_intel          26115  2 
    snd_hda_codec         100919  2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep               6660  1 snd_hda_codec
    snd_pcm                89104  2 snd_hda_intel,snd_hda_codec
    snd_seq_midi            5932  0 
    snd_rawmidi            22207  1 snd_seq_midi
    snd_seq_midi_event      7291  1 snd_seq_midi
    joydev                 11395  0 
    snd_seq                57512  2 snd_seq_midi,snd_seq_midi_event
    snd_timer              23850  2 snd_pcm,snd_seq
    snd_seq_device          6912  3 snd_seq_midi,snd_rawmidi,snd_seq
    snd                    64181  13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore               1240  1 snd
    fglrx                2523725  31 
    r8187se               167912  0 
    snd_page_alloc          8588  2 snd_hda_intel,snd_pcm
    edac_core              46822  0 
    i2c_piix4              10047  0 
    edac_mce_amd            9387  0 
    k10temp                 3535  0 
    shpchp                 34910  0 
    eeprom_93cx6            1789  1 r8187se
    lp                     10201  0 
    psmouse                62080  0 
    serio_raw               4910  0 
    parport                37032  3 parport_pc,ppdev,lp
    usbhid                 42030  0 
    hid                    84710  1 usbhid
    ahci                   22210  2 
    video                  22176  0 
    output                  2527  1 video
    r8169                  42254  0 
    libahci                26148  1 ahci
    mii                     5261  1 r8169
    Code:
    david@david-Satellite-L505D:~$ lsmod
    Module                  Size  Used by
    cryptd                  8140  0 
    aes_x86_64              7936  871 
    aes_generic            27631  1 aes_x86_64
    binfmt_misc             7984  1 
    parport_pc             30086  0 
    ppdev                   6804  0 
    dm_crypt               13381  0 
    snd_hda_codec_realtek   300173  1 
    snd_hda_intel          26115  2 
    snd_hda_codec         100919  2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep               6660  1 snd_hda_codec
    snd_pcm                89104  2 snd_hda_intel,snd_hda_codec
    snd_seq_midi            5932  0 
    snd_rawmidi            22207  1 snd_seq_midi
    snd_seq_midi_event      7291  1 snd_seq_midi
    joydev                 11395  0 
    snd_seq                57512  2 snd_seq_midi,snd_seq_midi_event
    snd_timer              23850  2 snd_pcm,snd_seq
    snd_seq_device          6912  3 snd_seq_midi,snd_rawmidi,snd_seq
    snd                    64181  13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore               1240  1 snd
    fglrx                2523725  32 
    r8187se               167912  0 
    snd_page_alloc          8588  2 snd_hda_intel,snd_pcm
    edac_core              46822  0 
    i2c_piix4              10047  0 
    edac_mce_amd            9387  0 
    k10temp                 3535  0 
    shpchp                 34910  0 
    eeprom_93cx6            1789  1 r8187se
    lp                     10201  0 
    psmouse                62080  0 
    serio_raw               4910  0 
    parport                37032  3 parport_pc,ppdev,lp
    usbhid                 42030  0 
    hid                    84710  1 usbhid
    ahci                   22210  2 
    video                  22176  0 
    output                  2527  1 video
    r8169                  42254  0 
    libahci                26148  1 ahci
    mii                     5261  1 r8169
    Last edited by theirishfrog.sh; February 5th, 2011 at 06:31 PM.
    "Such are the heights of wickedness to which men are driven by religion." - Lucretius (99-55 BCE)

  6. #16
    Join Date
    Nov 2010
    Location
    NM
    Beans
    1,121
    Distro
    Lubuntu Development Release

    Re: Must Disable, then Enable Networking for Wireless...

    David your OS/flavor is still Maverick 10.10

    david@david-Satellite-L505D:~$ cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=10.10
    DISTRIB_CODENAME=maverick
    DISTRIB_DESCRIPTION="Ubuntu 10.10"
    But that is a good thing for now. I know you checked it in the System > About Ubuntu and read you have Natty but that is a bug.. I forget the launchpad number, but it does not matter. Believe me if you had Natty you would have more problems right now.

    Synaptic upgrade to ubuntu-docs - 10.10.4ubuntu0.1 will fix the incorrect text about Natty

    So basically you can use your wireless but you must enable it manually each time your boot up? Correct?

    And yes your IP showing up after the manual enable of wireless is important.
    Last edited by nm_geo; February 5th, 2011 at 09:01 PM.
    Boot Info Script
    Ubuntu User number is # 32763
    Linux User number is # 527179

  7. #17
    Join Date
    Nov 2010
    Location
    NM
    Beans
    1,121
    Distro
    Lubuntu Development Release

    Re: Must Disable, then Enable Networking for Wireless...

    I have been trying to reproduce your manual connect problem here and I think the answer is in the network-manager settings. I know you were asked earlier if you are sure the automatically connect radio button was clhecked on Right? Let's look at another part go to >System > Preferences> Network Connections> wireless tab > pick your connection and edit

    Better yet let's just create a new connection: hit Add

    connection name your SSID (david or whatever)
    Make sure the Connect Automatically box is checked
    Put in your SSID
    Mode infrastructure (normally)
    MTU should be automatic too

    at the bottom check Available to all users

    Wireless security tab
    Security (whatever your wireless uses) mine is WPA & WPA2 Personal be sure your matches your wireless.
    Password _________ whatever is set up in your wireless
    show password if you like and you are the only users typically

    Be sure the Available to all users is checked at the bottom.

    After you reboot the new one should have Auto in front of the connection name (this may not appear but it should connect automatically)
    Last edited by nm_geo; February 5th, 2011 at 07:28 PM.
    Boot Info Script
    Ubuntu User number is # 32763
    Linux User number is # 527179

  8. #18
    Join Date
    Jan 2011
    Location
    Nelsonville, OH
    Beans
    15
    Distro
    Ubuntu Development Release

    Re: Must Disable, then Enable Networking for Wireless...

    Well, I tried recreating the network information as a new connection, but it didn't change the fact that I had to manually enable it, after reboot.

    Also, how do I do the Synaptic update to ubuntu-docs - 10.10.4ubuntu0.1?
    "Such are the heights of wickedness to which men are driven by religion." - Lucretius (99-55 BCE)

  9. #19
    Join Date
    Nov 2010
    Location
    NM
    Beans
    1,121
    Distro
    Lubuntu Development Release

    Re: Must Disable, then Enable Networking for Wireless...

    Quote Originally Posted by theirishfrog.sh View Post
    Well, I tried recreating the network information as a new connection, but it didn't change the fact that I had to manually enable it, after reboot.

    Also, how do I do the Synaptic update to ubuntu-docs - 10.10.4ubuntu0.1?
    Go to Synaptic in the quick search type ubuntu-docs check installed and latest versions. Yours should be an older version install the newer it fixes the bug that states you are running Natty 11.04.

    If you followed the instruction above and shut down all the way before booting, I am about out of ideas.

    Try this
    Code:
    cat /etc/network/interfaces
    Boot Info Script
    Ubuntu User number is # 32763
    Linux User number is # 527179

  10. #20
    Join Date
    Oct 2005
    Location
    Wabasha MN
    Beans
    2,439
    Distro
    Ubuntu

    Re: Must Disable, then Enable Networking for Wireless...

    Mine must of gotten fixed on the last update.
    Screenshot-Ubuntu - Linux for Human Beings!.png
    Information on my Main laptop. Information on my small laptop Dell 11 3000
    Using a Asus 3632QM laptop with 8gig RAM, 250 SSD.
    Machine Registered 366271, 366273, 366275.
    Registered Ubuntu user number 18630. Registered Linux user number 458093.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •