Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: cannot set en_US locale

  1. #11
    Join Date
    Jan 2011
    Beans
    6

    Smile Re: cannot set en_US locale

    Quote Originally Posted by eponymous alias View Post
    You're trying to use the en_US locale, but it doesn't exist on your machine. The en_US.UTF-8 locale is a different locale. To create the en_US locale, run:

    # locale-gen en_US
    Generating locales...
    en_US.ISO-8859-1... done
    Generation complete.

    and you should be good to go.
    Well that was easy. Thank you, that seems to have fixed my problem.

  2. #12
    Join Date
    Apr 2006
    Beans
    23

    Re: cannot set en_US locale

    I usually change it via Openoffice-Options-LanguageSettings menu, very straightforward and it seem to set the locale systemwide.
    That might be something nice to put in the preferences menu.

  3. #13
    Join Date
    Feb 2011
    Beans
    1

    Lightbulb Re: cannot set en_US locale

    Quote Originally Posted by draycor View Post
    @DanneStrat:
    My system does not have system > administration > locale.

    It does have System > Administration > Language Support
    This shows English (United States) followed by an English line. I have Clicked the "Apply System-Wide" button, but it does not seem to change anything.

    The language support software should give you a button that says "Install/Remove Languages", if the English (United States) is already installed just re-install either in here (Mine gave me the option to install English package again even though it was already installed on my PC) or in a terminal window with the get-apt command as later directed in this forum Discussion.

    However, as to the clicking that "Apply System-wide" button and it not responding, the software is set-up to only ask you for permission/confirm your changes once you've changed something. Mine didn't ask me to authenticate my system changes until I moved the English line above the English (United States) line and then moved it back to it's original position and clicked the "Apply System-Wide" button. It should ask for the same kind of authentication when installing/removing any locale packages in the same software, but not in the terminal window.

    *Just a quick add-on tip for any new Ubuntu 10.10 users

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •