Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Ubuntu 10.10 x32 only boots with ACPI off

  1. #21
    Join Date
    Jun 2008
    Location
    switzerland
    Beans
    44
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Ubuntu 10.10 x32 only boots with ACPI off

    hey all

    have made a upgrade from 10.04 to 10.10.. and get the same problem: system stopping, blinking cursor, last line on boot process:
    registered taskstats version 1

    i now added pci=noacpi to the kernel line:
    edit: /etc/default/grub (normally i use vi to edit files like this)
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noacpi"

    then: sudo update-grub
    . reboot.. and voilą...

    there is also another kernel option, that work "nolapic"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nolapic"
    this option seems to work better with eg. changing sound up/down over Fn keys..

    the system works fine.. all seems ok..

    but at the end.. maybe there is a bug on launchpad.. already made a short search, but can't find one..

    cheers
    thomi

  2. #22
    Join Date
    Apr 2011
    Beans
    3

    Re: Ubuntu 10.10 x32 only boots with ACPI off

    For anyone still suffering from this problem, you might want to try this solution, if you're using a machine like the OP on that thread.
    Worked for his Toshiba Satellite L670D-102 and my Toshiba Satellite C660-153.

  3. #23
    Join Date
    Feb 2010
    Beans
    6

    Wink Re: Ubuntu 10.10 x32 only boots with ACPI off

    Quote Originally Posted by thomi_ch View Post
    hey all

    have made a upgrade from 10.04 to 10.10.. and get the same problem: system stopping, blinking cursor, last line on boot process:
    registered taskstats version 1

    i now added pci=noacpi to the kernel line:
    edit: /etc/default/grub (normally i use vi to edit files like this)
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noacpi"

    then: sudo update-grub
    . reboot.. and voilą...

    there is also another kernel option, that work "nolapic"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nolapic"
    this option seems to work better with eg. changing sound up/down over Fn keys..

    the system works fine.. all seems ok..

    but at the end.. maybe there is a bug on launchpad.. already made a short search, but can't find one..

    cheers
    thomi
    After tying this:
    now added pci=noacpi to the kernel line:
    edit: /etc/default/grub (normally i use vi to edit files like this)
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noacpi"

    I had to change it to:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic acpi=off"

    and system was able to boot properly

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •