Results 1 to 4 of 4

Thread: "held broken packages"

  1. #1
    Join Date
    Jun 2010
    Beans
    23

    "held broken packages"

    i tried to install my ATI propertary driver and it says

    E:Unable to correct problems, you have held broken packages


    i have held broken packages and it wont download/install the driver :S what should i do?

    i have had a similar problem before i think, also when i used peppermint i couldnt install my driver, but forget it i like ubuntu the best....

    so what is the easiest way to fix this? i have no clue how to find/fix broken packages....could this happen because i clicked skip during some parts of the installation of ubuntu?

  2. #2
    wojox is offline I Ubuntu, Therefore, I Am
    Join Date
    Apr 2009
    Beans
    8,628

    Re: "held broken packages"

    Open you terminal and run:

    Code:
    sudo apt-get install -f
    sudo dpkg --configure -a
    sudo apt-get clean
    sudo apt-get update
    Last edited by wojox; January 17th, 2011 at 05:32 PM.

  3. #3
    Join Date
    May 2010
    Location
    Lahore Pakistan
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: "held broken packages"

    manually you can restore or recover broken package..

    restart the computer
    Then start ubuntu in recovery mood.
    there is option about and like 'dpkg Repair broken Packages'. select this your broken packages recovered ..
    Last edited by adeee; January 17th, 2011 at 05:41 PM.

  4. #4
    Join Date
    Jun 2010
    Beans
    23

    Re: "held broken packages"

    Quote Originally Posted by wojox View Post
    Open you terminal and run:

    Code:
    sudo apt-get install -f
    sudo dpkg --configure -a
    sudo apt-get clean
    sudo apt-get update

    worked like a charm....gotta remember to write that down!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •