Results 1 to 2 of 2

Thread: Ubuntu Software center authentication lock

  1. #1
    Join Date
    Feb 2008

    Unhappy Ubuntu Software center authentication lock

    I have a problem with the ubuntu software center. I can't get authentication to work to install anything. The error I get is:

    Previous Installation hasn't been completed

    The installation could have failed because of an error in the corresponding software package or it was cancelled in an unfriendly way. You have to repair this before you can install or remove any further software.

    I have no idea how to "repair this". I was trying to install XML copy editor and something happened during installation. Since then I rebooted but nothing seems to fix the error. I looked through the installed software and couldn't find program. I looked for some script solutions but they were for specific programs, not for the software center itself.

  2. #2
    Join Date
    Feb 2008

    Talking Re: Ubuntu Software center authentication lock

    I found a solution and got more impressed with Linux and ubuntu.

    One poster on a related thread said to try to install the same package using synaptic. I tried that and synaptic threw off an error message saying in effect that the entire package management system just got corrupted (this isn't supposed to happen in Linux) but that I should run the listed script as sudo in a terminal window and all would be well.

    So I did what was suggested with no expectations, but after about two minutes the terminal prompt came back. Everything worked after that. My god, an error identified and solution that worked suggested. Amazing.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts