Quote Originally Posted by raywjohnson View Post
Greetings jayk_s4,

The first thing I would do is change the [Dialer Verizon 4G] to [Dialer Verizon4G] (remove the space). Then use wvdial Verizon4G to start the connection.

Did you activate the device via windows before you tried to connect via Linux?

You should have received a new SIM card with the UML 290 modem. Every time I have upgraded or had a modem replaced, Verizon always sent a new SIM.

It might also be a problem with the Verizon service. I get this problem about once week now. I cannot connect to 4G for whole day.

Also, I no longer use this line: Init3 = AT+CGDCONT=3,"IPV4V6","vzwinternet","",0,0

I cannot connect with that line in the config, here is my current configuration:
OK, thanks I will modify my script. At the moment I can't even run the script though because linux won't recognize the modem at all. I don't even have a /dev/ttyACM0.

If 4G service is down and the modem isn't forced into 3G mode, does linux just ignore the device? It is possible 4G is down in the area, it's been over 24 hours now, but maybe I just didn't notice outages before because it automatically switched to 3G.

The Pantech modem was originally activated on a windows box about a year ago. I used it in a cradlepoint router for most of that time but got lots of disconnects from the router. Then I bought a LG VL600 from ebay with no SIM card and moved my SIM card into the LG modem and then updated the IMEI or MEID at verizonwireless. This worked a little better but still disconnected. I had to throttle it to lower than 3G speeds to keep it connected. Apparently the USB device on the cradlepoint can't handle high speeds very well. That is why I decided to put it in my linux box and use that as the router.

I couldn't get the LG device to connect so I moved the SIM card back into the Pantech. And you know the rest of the story after that. The only difference is that i didn't update verizonwireless this time with the correct device ID that is being used with the SIM card. Verizon still thinks I have a LG modem rather than the Pantech. Maybe they detected that and turned off my 4G access?

Thanks for the help!