Results 1 to 5 of 5

Thread: Trying to install php5-intl

  1. #1
    Join Date
    Feb 2011
    Beans
    16

    Trying to install php5-intl

    Hello,

    I'm trying to install php5-intl on my ubuntu 12.04 server. However I'm getting:

    The following packages have unmet dependencies:
    php5-intl : Depends: libicu44 (>= 4.4.1-1) but it is not installable
    E: Unable to correct problems, you have held broken packages.
    I've also tried with pecl

    pecl install intl
    But it asks me for the ICU Libraries and headers. I'm uncertain where those would be. I've tried the default and it gives me:

    ERROR: `/tmp/pear/temp/intl/configure --with-icu-dir=DEFAULT' failed

  2. #2
    Join Date
    Jul 2011
    Location
    Montreal, QC
    Beans
    99
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Trying to install php5-intl

    Try
    Code:
    apt-get update --fix-missing
    apt-get upgrade -f

  3. #3
    Join Date
    Feb 2011
    Beans
    16

    Re: Trying to install php5-intl

    Thanks for responding, that was the first thing I tried, although I gave it another go when I saw you posted this. It didn't resolve the issue.

    I'm sure another repository has libicu44 Does anyone know a repo I can add to get it working?

    Quote Originally Posted by beboylips View Post
    Try
    Code:
    apt-get update --fix-missing
    apt-get upgrade -f

  4. #4
    Join Date
    Feb 2011
    Beans
    16

    Re: Trying to install php5-intl

    ok it seems in Ubuntu 12.04 libicu44 has been superseeded with llibicu48...

    Now I need to figure out how to get a php & php-intl package that uses libicu48...

  5. #5
    Join Date
    Feb 2011
    Beans
    16

    Re: Trying to install php5-intl

    Managed to get it working adding the:

    ondrej-php5-precise

    repository. Now to figure out php5-apc...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •