Results 1 to 3 of 3

Thread: Tools package missing from Java?

  1. #1
    Join Date
    Feb 2006

    Tools package missing from Java?

    For some time I've been using the Impose tool in Multivalent.jar to do pdf impositions, but all of a sudden the same script I've always used fails with the message:

    Exception in thread "main" java.lang.NoClassDefFoundError: tool/pdf/Impose
    Caused by: java.lang.ClassNotFoundException: tool.pdf.Impose
    at$ 202)
    at Method)
    at ava:190)
    at java.lang.ClassLoader.loadClass( 07)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launche
    at java.lang.ClassLoader.loadClass( 48)
    Could not find the main class: tool.pdf.Impose. Program will exit.
    The command that produces this is:

    java -classpath ~/Multivalent.jar tool.pdf.Impose -dim 4x2 -layout 16,1,4,13,9u,8u,5u,12u,14,3,2,15,11u,6u,7u,10u -paper "17x11 in" document.pdf
    "java -version" yields:

    java version "1.6.0_21"
    Java(TM) SE Runtime Environment (build 1.6.0_21-b06)
    Java HotSpot(TM) 64-Bit Server VM (build 17.0-b16, mixed mode)

    On another forum, someone with this same problem was told that the latest version of Java doesn't include the tools package, but no mention was made of how to remedy that lack. I can't seem to find any mention of a "tools package" on the Oracle website.

    Has anyone else run into this problem and a solution?

  2. #2

    Re: Tools package missing from Java?

    Woof Woof!

    What multivalent build are you using? in latest

    Multivalent20091027.jar (2.6 MB)

    tools have been removed, so, you need a previous build

    you can download here (a multivalent build with tools inside)

  3. #3
    Join Date
    Feb 2006

    Re: Tools package missing from Java?

    Oh, I see, it was not Java but Multivalent that had the tools package missing. That is odd, because I don't remember downloading a new Multivalent version since the last time my script worked. Oh, well. Must be getting senile. Thanks for the link. That worked.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts