Results 1 to 3 of 3

Thread: Can't update MPC's database.

  1. #1
    Join Date
    Jan 2005

    Cool Can't update MPD's database.

    I haven't tried to update MPD's database in a good bit. I tried today and ran into this error: "error: you don't have permission for "update"" when using mpc.

    gMPC just throws all kinds of errors. Disconnects me, binds up MPD. I have to eventually restart MPD to settle things down.

    Have some things changed with permissions I don't know about?

    I run MPD as a service and have edited the configs as root.

    Any help?
    Last edited by MetalMusicAddict; January 3rd, 2011 at 01:06 AM. Reason: Typo

  2. #2
    Join Date
    Apr 2013

    Re: Can't update MPC's database.

    I am replying to a rather old post here, hoping to help out anybody who googled his way here in search of an answer (like myself).

    I got the exact same message from mpc; in fact, almost every mpc command would return "you don't have permission for...", including the rather innocent mpc status.
    $ mpc status
    error: you don't have permission for "status"

    In my case, the reason was quite logical: mpd was password-protected. Check your configuration files (/etc/mpd.conf and ~/.mpdconf); see if there is a line starting with the word 'password'.
    $ grep '^password' /etc/mpd.conf ~/.mpdconf
    /etc/mpd.conf:password "foo@read,add,control,admin"
    grep: /home/ruud/.mpdconf: No such file or directory

    Alright, so your password is 'foo'; specify it when calling mpc:
    $ mpc --host foo@localhost update
    Updating DB (#6) ...
    volume: n/a repeat: off random: off single: off consume: off

    HTH; and if so, you may want to set environment variable MPD_HOST, as proposed in the manual (man mpc).

  3. #3
    Join Date
    Feb 2008
    Ubuntu Development Release

    Re: Can't update MPC's database.

    Thanks for sharing! Old thread closed!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts