Page 5 of 5 FirstFirst ... 345
Results 41 to 49 of 49

Thread: RealTek 8192e and 64 bit amd not working

  1. #41
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Beans
    782
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: RealTek 8192e and 64 bit amd not working

    I can't find that download on Realtek's site either so I guess you'll have to trust that guy.

    And yes you'll need build-essential and the kernel headers to do that.

  2. #42
    Join Date
    Jan 2011
    Beans
    27

    Re: RealTek 8192e and 64 bit amd not working

    yeah im positive you pointed me to the wrong driver. I found the driver name from this ubuntoforums post:

    http://ubuntuforums.org/showpost.php...0&postcount=44

    since the link for that driver was broken I googled rtl8192e_linux_2.6.0014.0401.2010 and found that site.

  3. #43
    Join Date
    Jan 2011
    Beans
    27

    Re: RealTek 8192e and 64 bit amd not working

    grrrrr STILL not working I am sooo frustrated. I almost wish I had not dbanned my hard drive. If I had known linux would not support realtek network cards I wouldn't have done this.

  4. #44
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Beans
    782
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: RealTek 8192e and 64 bit amd not working

    Give the compat-wireless drivers from the Linux kernel wireless team a shot:

    http://wireless.kernel.org/en/users/Download

  5. #45
    Join Date
    Jan 2011
    Beans
    27

    Re: RealTek 8192e and 64 bit amd not working

    warmaster@warmaster-laptop:~$ sudo apt-get install linux-backports-modules-wireless-lucid-generic
    [sudo] password for warmaster:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    linux-backports-modules-wireless-lucid-generic is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    warmaster@warmaster-laptop:~$

    how can I get the drivers and everything back to its original state after first installing ubunto? The reason I ask is, what if something I tried 20 steps ago is affecting what I just did?

  6. #46
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Beans
    782
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: RealTek 8192e and 64 bit amd not working

    You can reboot to make sure your kernel modules state is default.

    I would just give the compat-wireless drivers a shot because:
    A. they're the latest, greatest, and most sure to work drivers the Linux kernel team has to offer
    B. they do a good job of getting all other drivers out of the way so they'll clear out any old cruft you have going

    They've also been updated 20 times or so since Ubuntu last made their package of them.

  7. #47
    Join Date
    Jan 2011
    Beans
    27

    Re: RealTek 8192e and 64 bit amd not working

    I have a viable solution for myself. This may not work for everyone. I didn't buy the computer because it was 64 Bit, I bought the computer rather because it was the best bang for the buck so to speak. So I installed a 32 bit version of 10.04.1 and now the video doesn't work after upgrading to 10.10 so I am off to figure that one out lol. But, the wireless works out of the box on the 32 bit so it is just the fact that it is a 64 bit OS that is giving the realtek the trouble. Thanks for the help Patches.

    JJ

  8. #48
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Beans
    782
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: RealTek 8192e and 64 bit amd not working

    If you have 3 GB of RAM or less, there really isn't a reason to run a 64-bit OS. I'm running 32-bit Ubuntu right now simply because my netbook doesn't have a 64-bit processor and I was too lazy to download two ISOs.

    Glad to hear everything is working okay now.

  9. #49
    Join Date
    Feb 2011
    Beans
    5

    Re: RealTek 8192e and 64 bit amd not working

    Using Ubuntu 10.10 64bits

    Hi. I have the same problem. But, readying so many forum and post, I resolved the problem.

    Sorry for my bad english.

    First, open your terminal.

    Run the code:

    lsmod | grep 819

    I think will show:

    r8192e_pci
    r8192se_pci

    This is the conflicting drivers.

    Now, run this code (to add r8192se_pci in blacklist):

    sudo su
    echo "blacklist r8192se_pci" >> /etc/modprobe.d/blacklist.conf
    exit


    Reboot

    Now, Download the newest driver from realtek, they mail me with instructions and file (I post in some servers)

    http://eldergs.4shared.com
    http://hotfile.com/dl/107013470/ed38...10.tar.gz.html
    http://www.megaupload.com/?d=F2R0S36T

    Now do what the support from realtek say:

    Hi Sir,

    Thanks for your email.

    Please find the attached for latest RTL8192E 32bit and 64bit Linux driver which is the updated one different from the one you used.

    Just kindly remind, please install by the below steps.
    The following is the installing steps:
    1. Change to the driver directory
    2. sudo su
    3. make
    4. make install
    5.reboot
    6. ./wlan0up or ./wlan1up

    Note: 1. if permission denied, change perperty with `chmod 777 wlan0up`
    2. or enable driver with `ifconfig wlanx up`(wlanx denote wlan interface name).

    If your OS is 64bit, maybe there is kernel self driver for RTL8192E, you should delet it first before install:


    1) cd /lib/modules/2.6.3x.xx.xx/
    2) find -name "r8192e_pci.ko"
    3) delet all the r8192e_pci.ko
    4) install our RTL8192E driver
    5) reboot.


    if there’s still any other problem, please let us know.
    Thanks a lot

    Regards,
    Kidman


    Reboot

    Now, You can use your Wireless and have fun.


Page 5 of 5 FirstFirst ... 345

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •