Quote Originally Posted by hansum_rahul View Post
I removed adobe-flashplugin and flashplugin-nonfree... and I downloaded the deb for Ubuntu 8.04+ for my Hardy Box... from the adobe website... pretty much what the plugin does...

The plug-in did not work for me however... and kept crashing on my firefox 3.6.14-pre browser

Works now! Thanks!
No Problem! Glad I could help!