Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: laptop internal speakers don't work

  1. #11
    Join Date
    Dec 2010
    Beans
    3

    Re: laptop internal speakers don't work

    Thank you very much Lidex, that worked like a charm

  2. #12
    Join Date
    Sep 2005
    Beans
    28

    Re: laptop internal speakers don't work

    I'm having similar problems with my new HP Compaq Mini CQ10-510CA netbook -- neither the internal speakers or the internal mic will work. Internal web cam works just fine. I tried the switch <<options snd-hda-intel model=ideapad>> without success.

    Here's the result of lspci on my box:

    trevor@trevor-netbook:~$ lspci
    00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge
    00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
    00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
    00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
    00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
    00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
    00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
    00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
    00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
    00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
    00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
    00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
    00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
    01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 04)
    01:00.1 Class ff00: Realtek Semiconductor Co., Ltd. Device 5288 (rev 01)
    02:00.0 Network controller: Broadcom Corporation Device 4727 (rev 01)

    I'm running Ubuntu 10.04 netbook version with a clean install.

    Any suggestions on a switch that might work for me?

  3. #13
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: laptop internal speakers don't work

    @Trevor4706
    I'll need some more info.
    Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.
    [Terminal="Applications->Accessories->Terminal"]

  4. #14
    Join Date
    Sep 2005
    Beans
    28

    Re: laptop internal speakers don't work

    Lidex

    Here's the link:

    http://www.alsa-project.org/db/?f=b2...6aab2fed8e7973

    Hope you can help.

    Regards

    Trevor

  5. #15
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: laptop internal speakers don't work

    Quote Originally Posted by Trevor4706 View Post
    Lidex
    Here's the link:
    http://www.alsa-project.org/db/?f=b2...6aab2fed8e7973
    Hope you can help.
    Regards
    Trevor
    Alsa is using a generic parser as it doesn't quite recognize your codec. Try updating your alsa-driver-modules.
    Using a Terminal="Applications->Accessories->Terminal"
    Add the ubuntu-audio-dev ppa:
    Code:
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    Now install:
    Code:
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    Reboot
    Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
    On the output tab choose the correct device.
    Post your results and also this output please:
    Code:
    aplay -l
    dpkg -l | grep "alsa"
    head -n 1 /proc/asound/card*/codec#*

  6. #16
    Join Date
    Sep 2005
    Beans
    28

    Re: laptop internal speakers don't work

    Lidex

    Excellent result. On board speakers now work. Here's the infor you requested:

    trevor@trevor-netbook:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    trevor@trevor-netbook:~$ dpkg -l | grep "alsa"
    ii alsa-base 1.0.22.1+dfsg-0ubuntu3 ALSA driver configuration files
    ii alsa-utils 1.0.22-0ubuntu5 ALSA utilities
    ii bluez-alsa 4.60-0ubuntu8 Bluetooth audio support
    ii gnome-alsamixer 0.9.7~cvs.20060916.ds.1-2 ALSA sound mixer for GNOME
    ii gstreamer0.10-alsa 0.10.28-1 GStreamer plugin for ALSA
    ii linux-alsa-driver-modules-2.6.32-27-generic 2.6.32-27.201012291600 Ubuntu-supplied Linux modules for version 2.

    trevor@trevor-netbook:~$ head -n 1 /proc/asound/card*/codec#*
    Codec: IDT 92HD88B1

    Do you have expertise with getting internal microphones to work as well, or should I try another post?

  7. #17
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: laptop internal speakers don't work

    Did you remove
    Code:
    options snd-hda-intel model=ideapad
    from alsa-base.conf and reboot?

    First, for mic problem, check this.
    Gnome-alsamixer
    Using Alt+F2 run dialog
    Code:
     gnome-alsamixer
    Use 'Edit -> Sound Card Properties' menu to enable elements.
    Soundcard tab to select / adjust levels.
    To install:
    Code:
    sudo apt-get install gnome-alsamixer
    Then go to 'Sound Preferences' to select and unmute your mic in 'Input' tab.
    Make sure you have selected a profile with 'duplex' or 'analog input' for the correct sound device on the 'Hardware' tab.
    Use Pulse Audio Volume Control (pavucontrol) to unlock stereo sliders for the mic in 'Input Devices' tab. Drag the right slider down to zero. The mic is a mono device.

    From alsa documentation:
    Capture Problems
    ~~~~~~~~~~~~~~~~
    The capture problems are often because of missing setups of mixers.
    Thus, before submitting a bug report, make sure that you set up the
    mixer correctly. For example, both "Capture Volume" and "Capture
    Switch" have to be set properly in addition to the right "Capture
    Source" or "Input Source" selection. Some devices have "Mic Boost"
    volume or switch.

    When the PCM device is opened via "default" PCM (without pulse-audio
    plugin), you'll likely have "Digital Capture Volume" control as well.
    This is provided for the extra gain/attenuation of the signal in
    software, especially for the inputs without the hardware volume
    control such as digital microphones. Unless really needed, this
    should be set to exactly 50%, corresponding to 0dB -- neither extra
    gain nor attenuation. When you use "hw" PCM, i.e., a raw access PCM,
    this control will have no influence, though.
    No joy? Please sign on to this bug report:
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/671814

  8. #18
    Join Date
    Sep 2005
    Beans
    28

    Re: laptop internal speakers don't work

    Lidex

    Thanks for your assistance in getting the internal speakers up and running. Still no joy regarding the internal mic. I've signed into the bug as you suggested, and will just have to wait and see if anything comes up to correct the problem.

    Regards

    Trevor

  9. #19
    Join Date
    Sep 2005
    Beans
    28

    Re: laptop internal speakers don't work

    Probably should have tried this earlier, but this morning I decided to run the 10.04 netbook remix from a live USB stick to see if everything worked out-of-the-box in the live environment. I was surprised to find that it did. The internal mic worked as advertised. Altho sound quality was scratchy, it was certainly readable. Checking the live set-up in sound preferences, there were no differences from the set-up I have in the installed version on my HD.

    Curious.

  10. #20
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: laptop internal speakers don't work

    At this point it may be helpful to run alsa-info script from usb version and also from dedicated install and check for differences.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •