Results 1 to 10 of 16

Thread: File Manager Autospawns at startup + gvfsd trash uses 100% of CPU

Threaded View

  1. #1
    Join Date
    Aug 2010
    Beans
    15

    Question File Manager Autospawns at startup + gvfsd trash uses 100% of CPU

    I have seen some of the same issues come up in other threads and have attempted without success the various fixed suggested in those threads. I was advised to open a new thread for this issue since the other threads were marked as [solved].

    I am running Ubuntu 10.04 64-bit.
    I am using gnome 1.2.28+1ubuntu3 and Nautilus 1:2.31.1-ubuntu2~ppa92

    After logging in Nautilus spawns thousands of instances for a couple minutes. My panel fills up with "Starting File Manager" indicators, which never seem to finish loading. They fill the panel and then finally disappear, or I can close them with
    Code:
     killall nautilus
    . Concurrently, gvfsd-trash is reported to be using up 100% of the CPU.

    After I close nautilus, I can reopen it and everything is back to normally working fine, including the gvfsd-trash. When I first encountered this error, the "Starting File Manager" indicators would continue appearing periodically (although in fewer numbers), but still failing to open and then disappearing after a few minutes. Apparently this doesn't happen anymore and I only experience the symptoms right after I login.


    I'm not sure if this problem started occurring after a specific update, but I don't recall changing any settings before it began to happen. I've read all the threads I can on this but no solutions have worked for me. This problem seems to be pretty widespread though, and across several versions of Ubuntu.

    I have tried the following things:


    [*]This thread discusses the link with gvfsd-trash
    https://bugzilla.gnome.org/show_bug.cgi?id=553776

    While the error is occuring, the top three processes running by memory usage are gvfsd-trash, dbus-daemon, and nautilus.

    I've noticed that my swap reports 0% usage at any given time, even when I've been running a lot of memory intensive programs. (although I have 6 gigs of ram which still should be a lot.) This may be unrelated, but perhaps there is an issue with the way I am mounting my drives and memory? This seemed to be implied in one of the threads I read.

    I'm pretty new to Ubuntu so any guidance on this would be a great help. From the several forum threads I've seen around I know this is a pretty widespread issue and has happened to many users. Unfortunately most of those forum threads are inconclusive or their solutions have not worked for me.

    I'd also appreciate some instruction on how to grab diagnostics and system specs to post here for a better understanding of whats going on in the system.


    EDIT: After I killall nautilus, and re-start it by entering
    Code:
    nautilus
    in the terminal, it opens and works fine but I get the following message:
    Code:
    Initializing nautilus-gdu extension
    
    (nautilus:2295): Gtk-WARNING **: Undo: missing action Undo
    
    (nautilus:2295): Gtk-WARNING **: Redo: missing action Redo
    
    (nautilus:2295): Gtk-WARNING **: Reset to Defaults: missing action Reset to Defaults
    
    (nautilus:2295): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed
    Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
    Please ask your system administrator to enable user sharing.
    It doesn't look like its related, but just thought I'd post it in case.
    Last edited by notjingo; December 30th, 2010 at 05:45 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •