Results 1 to 10 of 14

Thread: Mount usb drive attached to N300 wireless N netgear router

Hybrid View

  1. #1
    Join Date
    Oct 2006
    Location
    Dumfries, Scotland
    Beans
    54
    Distro
    Ubuntu 11.04 Natty Narwhal

    Mount usb drive attached to N300 wireless N netgear router

    I can currently access my USB drive attached to the USB port of my router, and can copy files to and from it etc. On the router administration interface, the device name is given as "readyshare". When accessing via Samba the pathway smb://readyshare/usb_storage/ appears in nautilus.

    However I can not save files directly to it from an application and assume that for this to work, I would have to mount the drive. I have been attempting to do this via an entry in fstab: here is one failed attempt:

    //192.168.0.1/readyshare/usb_storage /media/readyshare vfat defaults 0 2

    On running sudo mount -a the following error is returned: mount: special device //192.168.0.1/readyshare/usb_storage does not exist.



    What should I do to mount this drive in fstab?
    Last edited by Stephen Shellard; December 28th, 2010 at 03:35 PM. Reason: Incorrect information given in the error message.
    "The best laid schemes o' mice an' men
    Gang aft agley
    "
    From: To a Mouse, by Robert Burns (25 January 1759 – Died Dumfries, 21 July 1796)

  2. #2
    Join Date
    Oct 2006
    Location
    Milton Keynes, UK
    Beans
    1,141
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount usb drive attached to N300 wireless N netgear router

    If you can copy files to & from drive then it is already mounted.

    To see list of mounted drives from a terminal run

    Code:
    sudo fdisk -l
    On running sudo mount -a the following error is returned: //192.168.0.1/readyshare/usb_storage /media/readyshare vfat defaults 0 2
    The actual error would be helpful.
    Linux Registered User #443947 Ubuntu Regestered User #12604

    Hakunamatata ...... No worries !

  3. #3
    Join Date
    Oct 2006
    Location
    Dumfries, Scotland
    Beans
    54
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount usb drive attached to N300 wireless N netgear router

    I see now that I did not quote error message correctly: it is:

    mount: special device //192.168.0.1/readyshare/usb_storage does not exist.

    Out put from
    Code:
    sudo fdisk -l
    :

    Disk /dev/sda: 82.3 GB, 82348277760 bytes
    255 heads, 63 sectors/track, 10011 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xd7b7d7b7

    Device Boot Start End Blocks Id System
    /dev/sda1 1 10012 80416768 83 Linux

    Disk /dev/sdb: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xa9ac0f06

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 1257 10096821 83 Linux
    /dev/sdb2 38176 38913 5927954+ 5 Extended
    /dev/sdb3 1258 38175 296543835 83 Linux
    /dev/sdb5 38176 38913 5927953+ 82 Linux swap / Solaris

    Partition table entries are not in disk order
    I am not seeing my 2GB USB drive in this.

    Thanks very much for your interest!
    Last edited by Stephen Shellard; December 24th, 2010 at 07:19 PM.
    "The best laid schemes o' mice an' men
    Gang aft agley
    "
    From: To a Mouse, by Robert Burns (25 January 1759 – Died Dumfries, 21 July 1796)

  4. #4
    Join Date
    Oct 2006
    Location
    Milton Keynes, UK
    Beans
    1,141
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount usb drive attached to N300 wireless N netgear router

    Samba the pathway smb://readyshare/usb_storage/
    Silly thought but worth a try... if smaba sees it as //readyshare/usb_storage/ try mounting that ....

    Code:
    sudo mount -t smbfs //readyshare/usb_storage/ /media/readyshare
    Obviously the mount point /media/readyshare must exist.
    Linux Registered User #443947 Ubuntu Regestered User #12604

    Hakunamatata ...... No worries !

  5. #5
    Join Date
    Feb 2009
    Beans
    2

    Re: Mount usb drive attached to N300 wireless N netgear router

    I posted something in another thread that might help:

    http://ubuntuforums.org/showthread.php?p=10394497

  6. #6
    Join Date
    Nov 2007
    Beans
    7

    Re: Mount usb drive attached to N300 wireless N netgear router

    I've got a N300 to, spent an half an hour on the docs, hope this helps some other users.

    $sudo smbclient -L 192.168.1.1
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.13]

    Sharename Type Comment
    --------- ---- -------
    USB_Storage Disk read:all-no password;write:all-no password
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.13]

    Server Comment
    --------- -------
    READYSHARE readyshare

    Workgroup Master
    --------- -------
    WORKGROUP READYSHARE


    Why O Why do they call the Sharename USB_Storage but it's readyshare on windows shrug

    sudo apt-get install smbfs

    sudo smbmount //192.168.1.1/USB_Storage /media/nas
    sudo mount -t smbfs //192.168.1.1/USB_Storage /media/nas

    Haven't bothered putting it in fstab though I'm sure it will be pretty straight forward now with the correct share name.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •