Results 1 to 6 of 6

Thread: x forwarding not working when ipv6 disabled

  1. #1
    Join Date
    Oct 2008
    Location
    Almere, The Netherlands
    Beans
    5
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    x forwarding not working when ipv6 disabled

    Hi,

    Got Ubuntu Server 10.10 installed as a virtual machine (vmware). When i forward X through SSH (putty) i can start xeyes, xcalc,etc.

    Now when i disable ipv6 putty can't set the display variable and i get "Error: can't open display". I haven't changed anything in putty or win 7 (the host system).

    I disable ipv6 by putting these lines in /etc/sysctl.conf

    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1

    Has anyone have any idea why this is happening? Thanks

  2. #2
    Join Date
    Feb 2011
    Beans
    29

    Re: x forwarding not working when ipv6 disabled

    Same issue here. Did you manage to resolve it?

  3. #3
    Join Date
    Oct 2009
    Beans
    3

    Re: x forwarding not working when ipv6 disabled

    A workaround is appending

    Code:
    AddressFamily inet
    in the remote host /etc/ssh/sshd_config file, then

    Code:
    sudo service ssh restart
    Had the same issue and now is working!

  4. #4
    Join Date
    Apr 2007
    Beans
    Hidden!

    Re: x forwarding not working when ipv6 disabled

    Quote Originally Posted by Ubscenee View Post
    A workaround is appending

    Code:
    AddressFamily inet
    in the remote host /etc/ssh/sshd_config file, then

    Code:
    sudo service ssh restart
    Had the same issue and now is working!
    Awesome! Thanks for sharing this!

    Hopefully a work around will be implemented so that when IPv6 is disabled it won't disable running X apps via ssh.

  5. #5
    Join Date
    Jan 2007
    Location
    North Carolina, USA
    Beans
    540
    Distro
    Ubuntu

    Re: x forwarding not working when ipv6 disabled

    Quote Originally Posted by Ubscenee View Post
    A workaround is appending

    Code:
    AddressFamily inet
    in the remote host /etc/ssh/sshd_config file, then

    Code:
    sudo service ssh restart
    Had the same issue and now is working!
    Wow, I have tried everything and the kitchen sink to get this fixed and here it is!

  6. #6
    Join Date
    Nov 2010
    Beans
    2

    Re: x forwarding not working when ipv6 disabled

    Thnx Ubscenee!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •