Results 1 to 2 of 2

Thread: 10.04 Server Edition: no open ports?

  1. #1
    Join Date
    Dec 2010
    Beans
    3

    10.04 Server Edition: no open ports?

    Hi,

    I've tried to set up a Hadoop cluster on a few freshly-installed 10.04 Server Edition machines and hit a problem. (I was able to set up the cluster using Desktop edition previously). The issue is that I can't connect to the service even though the Java process is running and listening on the port and there is no error in the logs.

    anyway, I started to wonder if it was firewall issue so I googled it and found conflicting information.

    1. "Ubuntu Server has no open ports by default" - http://www.ubuntu.com/server/features/security

    2. iptables shows different info. ufw is also disabled.

    =============================
    hadoopadmin@machine-1:~$ sudo iptables -L
    [sudo] password for hadoopadmin:
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    hadoopadmin@machine-1:~$ sudo ufw status verbose
    Status: inactive
    =============================

    I even tried to enable ufw and did "sudo ufw default allow incoming" but still no help. The only package I manually selected during installation is OpenSSH server.

    Thanks,
    J

  2. #2
    Join Date
    Oct 2005
    Location
    Al Ain
    Beans
    8,957

    Re: 10.04 Server Edition: no open ports?

    If it ain't listening on localhost, then it ain't listening:
    $ telnet localhost 80

    Use ps -e to see what is running.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •