Quote Originally Posted by akshay.guleria@gmail.com View Post
Problem:
Got a brand new HP laptop - HP g62x. Installed ubuntu 10.10 and found that I do not have a wlan interface as one would expect with an active wireless connection.

Thanks to
Great discussion on similar work here @ http://ubuntuforums.org/showthread.php?t=1600498. Just a different card.

Solution:
I used the above thread to do my work - banged my head against the wall a couple of times but it was fun . I am listing down steps that finally worked for me. But before that, my configurations:
  • Ubuntu 10.10
  • 64 bit
  • WPA2 wireless network
  • OS was freshly installed and there was no specific customization prior to this
  • RaLink Device 5390. (use lspci to see your model number)



  1. Download the driver from ralinktech.com --> Software --> Linux
  2. Unzip the download zip file anywhere. I did it in the default Downloads directory
  3. cd to the 2010_xxx extracted directory
  4. cd os/linux/
  5. Edit the config.mk file as below:
    HAS_ATE=y (no change, it was originally as is)
    HAS_WPA_SUPPLICANT=y (no change, it was originally as is)
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y (no change, it was originally as is)
    HAS_ANTENNA_DIVERSITY_SUPPORT=y originally was n -- this was the only thing I modified)
  6. Go back to the 2010_xx directory
  7. run command 'make'
  8. Make sure 'make compile' exists without errors. I got an error "too many arguments to format" towards the end of the compile but it did compile successfully eventually. And so I ignored the errors. You would see ***errors*** if the compile is not successful. In which, something went wrong and you may need to tweak the makefile or config.mk files before compile is successful.
  9. run command 'make install' as root. This is not listed in the README_STA_pci file that comes with downloaded driver zip file. This takes of copying the file to /lib/modules/2.6.35-22-generic/kernel/drivers/net/wireless/rt5390sta.ko. running depmod, creating /etc/Wireless/... folder.
  10. Edit the /etc/modules and add the line at the end of this file
    rt5390sta
  11. Edit the file /etc/modprobe.d/blacklist.conf and add the below line to it...
    blacklist rt2800pci
  12. Reboot and you should see an ra0 interface when you run the command 'ifconfig'
  13. You may have to run '/etc/init.d/network-manager restart' command to have it show in the first go.
  14. Once, the wireless icon shows up, look for your wireless SSID and there you go surfing
Hi, thanks for the thread! Sorry to reopen it after so many months, but I'm having the same issue, and when I ran the make command, I got *** errors ***.
I'm running 11.04 on a compaq presario CQ56, I have the Ralink 5390 card. I don't really know how to tweak the Makefile or config.mk file to get it to complete successfully.


Here is the error message I got:

/home/samz/2010_1216_RT5390_LinuxSTA_V2.4.0.4_WiFiBTCombo_DPO/os/linux/../../os/linux/cfg80211.c:2594:2: warning: format ‘%d’ expects type ‘int’, but argument 2 has type ‘long unsigned int’
make[2]: *** [/home/samz/2010_1216_RT5390_LinuxSTA_V2.4.0.4_WiFiBTCombo_DPO/os/linux/../../os/linux/cfg80211.o] Error 1
make[1]: *** [_module_/home/samz/2010_1216_RT5390_LinuxSTA_V2.4.0.4_WiFiBTCombo_DPO/os/linux] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
make: *** [LINUX] Error 2



For whatever it's worth, this is the relevant output of lspci -v:

02:00.0 Network controller: Ralink corp. Device 5390
Subsystem: Hewlett-Packard Company Device 1636
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at 93500000 (32-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>


Any help on this would really be appreciated!