Page 1 of 3 123 LastLast
Results 1 to 10 of 128

Thread: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

Hybrid View

  1. #1

    Smile Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    Problem:
    Got a brand new HP laptop - HP g62x. Installed ubuntu 10.10 and found that I do not have a wlan interface as one would expect with an active wireless connection.

    Thanks to
    Great discussion on similar work here @ http://ubuntuforums.org/showthread.php?t=1600498. Just a different card.

    Solution:
    I used the above thread to do my work - banged my head against the wall a couple of times but it was fun . I am listing down steps that finally worked for me. But before that, my configurations:
    • Ubuntu 10.10
    • 64 bit
    • WPA2 wireless network
    • OS was freshly installed and there was no specific customization prior to this
    • RaLink Device 5390. (use lspci to see your model number)



    1. Download the driver from ralinktech.com --> Software --> Linux
    2. Unzip the download zip file anywhere. I did it in the default Downloads directory
    3. cd to the 2010_xxx extracted directory
    4. cd os/linux/
    5. Edit the config.mk file as below:
      HAS_ATE=y (no change, it was originally as is)
      HAS_WPA_SUPPLICANT=y (no change, it was originally as is)
      HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y (no change, it was originally as is)
      HAS_ANTENNA_DIVERSITY_SUPPORT=y originally was n -- this was the only thing I modified)
    6. Go back to the 2010_xx directory
    7. run command 'make'
    8. Make sure 'make compile' exists without errors. I got an error "too many arguments to format" towards the end of the compile but it did compile successfully eventually. And so I ignored the errors. You would see ***errors*** if the compile is not successful. In which, something went wrong and you may need to tweak the makefile or config.mk files before compile is successful.
    9. run command 'make install' as root. This is not listed in the README_STA_pci file that comes with downloaded driver zip file. This takes of copying the file to /lib/modules/2.6.35-22-generic/kernel/drivers/net/wireless/rt5390sta.ko. running depmod, creating /etc/Wireless/... folder.
    10. Edit the /etc/modules and add the line at the end of this file
      rt5390sta
    11. Edit the file /etc/modprobe.d/blacklist.conf and add the below line to it...
      blacklist rt2800pci
    12. Reboot and you should see an ra0 interface when you run the command 'ifconfig'
    13. You may have to run '/etc/init.d/network-manager restart' command to have it show in the first go.
    14. Once, the wireless icon shows up, look for your wireless SSID and there you go surfing
    Last edited by akshay.guleria@gmail.com; December 18th, 2010 at 07:03 AM. Reason: reformatted

  2. #2
    Join Date
    Dec 2010
    Beans
    3

    Re: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    Thanks a lot man.

    How to edit the /etc/modprobe to add the line rt5390sta ???

    I am waiting for your answer

    Thanks..

  3. #3

    Re: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    Quote Originally Posted by waseemriyaz View Post
    Thanks a lot man.

    How to edit the /etc/modprobe to add the line rt5390sta ???

    I am waiting for your answer

    Thanks..
    Sorry, that should be modules - typo
    sudo gedit /etc/modules

  4. #4
    Join Date
    Dec 2010
    Beans
    3

    Re: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    I actually skipped step 9 and it worked fine for me. Thanks a lot. I thought I could never use ubuntu on hp g62x without wireless...

    the only change I made was , for make file to successfully compile without errors, you need to login to root then run make file.... then it will compile without errors..


  5. #5

    Re: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    glad my post helped. The "make install" generally does the whole trick so i guess after some more feedback, i could be confident that this is actually optional. I also have it disabled for me and it still works

  6. #6
    Join Date
    Dec 2010
    Beans
    2

    Re: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    Thanks for this!

    Just did a fresh install 10.04 and followed the steps, worked great....then when I updated to the latest kernel it stopped working and had to redo make/make install. So it may have to be done every time?

  7. #7
    Join Date
    Sep 2009
    Beans
    5
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    Quote Originally Posted by akshay.guleria@gmail.com View Post
    Problem:


    1. Download the driver from ralinktech.com --> Software --> Linux
    2. Unzip the download zip file anywhere. I did it in the default Downloads directory
    3. cd to the 2010_xxx extracted directory
    4. cd os/linux/
    5. Edit the config.mk file as below:
      HAS_ATE=y (no change, it was originally as is)
      HAS_WPA_SUPPLICANT=y (no change, it was originally as is)
      HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y (no change, it was originally as is)
      HAS_ANTENNA_DIVERSITY_SUPPORT=y originally was n -- this was the only thing I modified)
    6. Go back to the 2010_xx directory
    Thank you for your detailed instructions !!! You've saved my life

    I have changed them slightly, however:

    7. sudo make
    8 sudo make install

    Reboot, and voilà, surfing !!!

  8. #8
    Join Date
    Jan 2009
    Beans
    94
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    Still have issues, no change in my wireless connection other than that r5390 shows up in my Additional Drivers area. Not sure where I went wrong as I'm not incredibly savvy with the terminal. Everything appeared fine as I was doing it, that's probably not the case though.

  9. #9
    Join Date
    Apr 2011
    Beans
    5

    Re: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    Quote Originally Posted by akshay.guleria@gmail.com View Post
    Problem:
    Got a brand new HP laptop - HP g62x. Installed ubuntu 10.10 and found that I do not have a wlan interface as one would expect with an active wireless connection.

    Thanks to
    Great discussion on similar work here @ http://ubuntuforums.org/showthread.php?t=1600498. Just a different card.

    Solution:
    I used the above thread to do my work - banged my head against the wall a couple of times but it was fun . I am listing down steps that finally worked for me. But before that, my configurations:
    • Ubuntu 10.10
    • 64 bit
    • WPA2 wireless network
    • OS was freshly installed and there was no specific customization prior to this
    • RaLink Device 5390. (use lspci to see your model number)



    1. Download the driver from ralinktech.com --> Software --> Linux
    2. Unzip the download zip file anywhere. I did it in the default Downloads directory
    3. cd to the 2010_xxx extracted directory
    4. cd os/linux/
    5. Edit the config.mk file as below:
      HAS_ATE=y (no change, it was originally as is)
      HAS_WPA_SUPPLICANT=y (no change, it was originally as is)
      HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y (no change, it was originally as is)
      HAS_ANTENNA_DIVERSITY_SUPPORT=y originally was n -- this was the only thing I modified)
    6. Go back to the 2010_xx directory
    7. run command 'make'
    8. Make sure 'make compile' exists without errors. I got an error "too many arguments to format" towards the end of the compile but it did compile successfully eventually. And so I ignored the errors. You would see ***errors*** if the compile is not successful. In which, something went wrong and you may need to tweak the makefile or config.mk files before compile is successful.
    9. run command 'make install' as root. This is not listed in the README_STA_pci file that comes with downloaded driver zip file. This takes of copying the file to /lib/modules/2.6.35-22-generic/kernel/drivers/net/wireless/rt5390sta.ko. running depmod, creating /etc/Wireless/... folder.
    10. Edit the /etc/modules and add the line at the end of this file
      rt5390sta
    11. Edit the file /etc/modprobe.d/blacklist.conf and add the below line to it...
      blacklist rt2800pci
    12. Reboot and you should see an ra0 interface when you run the command 'ifconfig'
    13. You may have to run '/etc/init.d/network-manager restart' command to have it show in the first go.
    14. Once, the wireless icon shows up, look for your wireless SSID and there you go surfing
    Hello, thanks for the info.

    I have been able to follow this guide up until number 7, the make command. Each time I run it, I receive the following error:

    make[2]: *** [/home/donald/Downloads/wireless/os/linux/../../os/linux/cfg80211.o] Error 1
    make[1]: *** [_module_/home/donald/Downloads/wireless/os/linux] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
    make: *** [LINUX] Error 2

    You mention that I should perhaps modify my config.mk or makefile - I am new to Linux, so perhaps you could shed some light on what I should look out for?

    I am trying this on 11.04, could this be the cause of my problems?

    Thanks.

  10. #10
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,474
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Ralink 5390 wifi card in Ubuntu 10.10 64 bit

    You mention that I should perhaps modify my config.mk or makefile - I am new to Linux, so perhaps you could shed some light on what I should look out for?

    I am trying this on 11.04, could this be the cause of my problems?

    Thanks.
    Please see your other thread. You need to make the patches I referred you to.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •