Results 1 to 8 of 8

Thread: Disabling "legacy usb" in BIOS: problems

  1. #1
    Join Date
    Apr 2007
    Beans
    20

    Disabling "legacy usb" in BIOS: problems

    I recently bought an external usb HD drive that I want to keep plugged into the computer (not a laptop) at all times.

    However when I booted with the HD plugged in the PC would just hang at boot when "checking for devices". I searched for a solution and eventually found it: I disabled the "legacy usb support" feature in my BIOS and the computer started booting again without hanging.

    However after that a new problem emerged with my usb keyboard. I am now unable to use the keyboard during grub and until the default OS (Ubuntu 10.10) is loaded. This is obviously related to the keyboard being a usb one.

    How can I get both my HD and my keyboard to work at the same time?

  2. #2
    Join Date
    Apr 2007
    Beans
    20

    Re: Disabling "legacy usb" in BIOS: problems

    Is there something I can do to make this question more easily answerable?

  3. #3
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    3,060
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: Disabling "legacy usb" in BIOS: problems

    Check your drive boot order in BIOS. I think you typically need to have Legacy or Auto enabled for USB legacy support in order to boot from a USB drive, but maybe your system is trying to boot the USB drive when there is no OS on it. So that is why you should check your boot drive order.

    How different computers handle that differs. I have my laptop set to boot USB before its internal drive, so if a bootable USB is connected, it automatically boots USB. But I have not tried booting that with a USB drive with no OS, or a boot loader and no OS.

    For my old and new desktops and company laptop, regardless of boot order set in BIOS (other than which internal drive to boot), it will not even try to boot an internal drive unless I press a certain key during BIOS splash screen. That is probably to avoid accidentally booting from something (possibly malicious) if you do not intend to. The only virus I ever caught in Windows (3.1 and 95) was spread by floppy disks many years ago.
    i5 650 3.2 GHz, 8 GB, nvidia GTX 1060, 32" 1080p & assorted older computers

  4. #4
    Join Date
    Apr 2007
    Beans
    20

    Re: Disabling "legacy usb" in BIOS: problems

    Thank you, efflandt.
    However the USB drive does not appear in the boot order list, only my regular SATA drives. If I turn legacy USB on, the process hangs at "Detecting USB drive:", right after successfully detecting the SATA drives.
    I noticed that my keyboard is active during the first phase of the boot (I can press Del to get into the BIOS). It stops working only during boot.

    Maybe there's another option I can set? Will disabling the USB 2.0 controller have negative effects on the performance of my drives?

  5. #5
    Join Date
    Apr 2007
    Beans
    20

    Re: Disabling "legacy usb" in BIOS: problems

    A friend told me that maybe I should update the usb drive's firmware. It sounds like a slightly risky endeavor, so I want to be sure it's really necessary.
    Does anybody have advice on this?

  6. #6
    Join Date
    Feb 2009
    Location
    Praha
    Beans
    5
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Disabling "legacy usb" in BIOS: problems

    Do you have "removable devices" in the drive boot order menu? If yes try to disable them or put them back in the boot order list. Unfortunately I am not sure if this could avoid detection of USB drives.

  7. #7
    Join Date
    Apr 2007
    Beans
    20

    Re: Disabling "legacy usb" in BIOS: problems

    Thanks but no, the boot order list only contains "proper" drives. I don't think it's a boot priority problem, because the loading sequence stops during the POST, when it is just checking for devices, not yet trying to boot an OS.

    The problem still persists. I wonder what all the other people with external drives do to prevent this...

  8. #8
    Join Date
    May 2012
    Beans
    1

    Re: Disabling "legacy usb" in BIOS: problems

    Quote Originally Posted by nac.est View Post
    I recently bought an external usb HD drive that I want to keep plugged into the computer (not a laptop) at all times.

    However when I booted with the HD plugged in the PC would just hang at boot when "checking for devices". I searched for a solution and eventually found it: I disabled the "legacy usb support" feature in my BIOS and the computer started booting again without hanging.

    However after that a new problem emerged with my usb keyboard. I am now unable to use the keyboard during grub and until the default OS (Ubuntu 10.10) is loaded. This is obviously related to the keyboard being a usb one.

    How can I get both my HD and my keyboard to work at the same time?
    BIOS fails to recognize external USB Hard Drive when a USB mouse is connected

    I known that this is an Ubuntu forum, but problems that occur during BIOS processing are often quite distinct from problems that may occur later as an operating system is booted.

    Note: If you want to use a USB mouse or USB keyboard before the operating system is fully loaded, then you must enable "Legacy USB Support" in the BIOS, otherwise they will not work during the BIOS processing or during the operating system boot until appropriate drivers have been loaded - See notes below.

    My Windows 7 home premium 64 bit Fujitsu PH300 desktop has an AMI Aptio 4.6 BIOS mounted on a Fujitsu D2990-A1 rev C motherboard. I use an External USB 2.0 hard drive (Samsung HD400LD WQ10) which has a separate power cable plugged into a mains socket that is switched on, a Fujitsu PS/2 keyboard and a Fujitsu USB mouse.

    My problem was that every other time I booted my PC, the BIOS would intermittently fail to recognize the external USB hard drive and when I looked in the BIOS list of detected USB devices, the external USB hard drive was absent. Also the blue LED activity light on the USB drive blinked continuously as the BIOS queried the drive for type and model information
    and the BIOS was kept so busy that anything I typed at the keyboard took about 10 seconds to appear and the screen rendering was incredibly slow. It took minutes for Windows 7 to boot and often Windows just wouldn't boot at all.

    Solution: I replaced the USB mouse with a PS/2 mouse and Hey Presto! - my PC has worked perfectly ever since.

    A day later, since I no longer use either a USB mouse or USB keyboard, I disabled the "Legacy USB Support" in the BIOS because it is no longer required.

    I don't know what the exact cause of the problem was, but replacing the USB mouse with a PS/2 mouse fixed it.
    Either the BIOS or the USB Controller cannot cope with an external USB Hard Drive and a USB mouse being plugged in at the same time, even when they were plugged into USB ports owned by different hubs.
    A further complication was the presence of a USB mouse but with a PS/2 keyboard which may have confused the BIOS "Legacy USB Support".

    -----------------------------------------------------------------------
    Legacy USB Support refers to the USB mouse and USB keyboard support.
    When this option is not enabled, any attached USB mouse or USB keyboard will not work until a USB compatible operating system is fully booted with all USB drivers loaded. When this option is enabled, any attached USB mouse or USB keyboard can control the system even when there is no USB drivers loaded on the system.

    Disabled: set this value to prevent the use of any USB device in DOS or
    during system boot.
    Enabled: set this value to allow the use of USB devices during boot and while using DOS.
    Auto: this option detects automatically USB keyboards or mice and if found, allows them to be used during boot and while using DOS.
    -----------------------------------------------------------------------
    Last edited by Aewzzz1; May 8th, 2012 at 01:35 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •