Results 1 to 10 of 10

Thread: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switchable

  1. #1
    Join Date
    Nov 2010
    Beans
    28

    Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switchable

    I downloaded ATI Catalyst 10.9 Proprietary Linux x86 Display Driver and installed it on my HP Pavilion dv6 i5 64 bit, with Ubuntu 10.10 installed. However, I get the following errors:

    jiangnan@jiangnan-PC:~/Downloads$ ./ati-driver-installer-10-9-x86.x86_64.run
    Created directory fglrx-install.eQuJUX
    Verifying archive integrity... All good.
    Uncompressing ATI Catalyst(TM) Proprietary Driver-8.771............................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ................................................
    ================================================== ===================
    ATI Technologies Catalyst(TM) Proprietary Driver Installer/Packager
    ================================================== ===================

    Error: ./default_policy.sh does not support version
    default:v286_64:lib32::none:2.6.35-23-generic:; make sure that the version is being
    correctly set by --iscurrentdistro

    ================================================== ===================
    ATI Technologies Catalyst(TM) Proprietary Driver Installer/Packager
    ================================================== ===================

    Error: ./default_policy.sh does not support version
    default:v286_64:lib32::none:2.6.35-23-generic:; make sure that the version is being
    correctly set by --iscurrentdistro

    Removing temporary directory: fglrx-install.eQuJUX


    Any solutions for the 2 errors?

    Many thanks

  2. #2
    Join Date
    Mar 2008
    Beans
    33

    Re: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switch

    Don't bother about ati drivers... it's not worth it... I have tried installing ati drivers several times on my Pavilion DV6-3040ec - intel i5 graphics + ati radeon hd 5650, kubuntu 10.10 32bit pae kernel (kubuntu reinstalled each time after installing ati drivers). All you get is bad 3D performance and unworkable switcheroo.

  3. #3
    Join Date
    Nov 2010
    Beans
    28

    Angry Re: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switch

    After I installed the drivers and restart the computer, I could no longer boot in my Ubuntu system. All I got is "failed to get i915 symbols graphics turbo disabled". How can I solve this problem and re-enter my Ubuntu?

  4. #4
    Join Date
    Mar 2008
    Beans
    33

    Re: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switch

    go to recovery mode (second grub option), log in to terminal as root and remove fglrx

    Code:
    apt-get purge fglrx

  5. #5
    Join Date
    Nov 2010
    Beans
    28

    Re: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switch

    Thanks!

    Quote Originally Posted by depeha View Post
    go to recovery mode (second grub option), log in to terminal as root and remove fglrx

    Code:
    apt-get purge fglrx

  6. #6
    Join Date
    Mar 2008
    Beans
    33

    Re: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switch

    Let me know if you´ll get working drivers pls...

  7. #7
    Join Date
    Nov 2010
    Beans
    28

    Re: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switch

    Quote Originally Posted by depeha View Post
    Let me know if you´ll get working drivers pls...
    Hi~~
    I have tried many times installing ATI driver ati-driver-installer-10-12-x86.x86_64.run on my 64 bit Ubuntu 10.10 with this 5470 graphic card. However, every time when I reboot I only get a black screen. Then I have to remove /etc/X11/xorg.conf to get things back to normal. Why does the driver not work for me? I just wanna get it work.

    By default, is my GPU used by Ubuntu 10.10, or is it just wasted? If I could successfully install the driver, will gnome-system-monitor and Xorg use less CPU, and will Win7 in my VirtualBox have better performance?

  8. #8
    Join Date
    Mar 2008
    Beans
    33

    Re: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switch

    Don't know why, but it just doesn't work. Maybe 5xxx series is too new
    Anyway, it uses power in ubuntu even if it´s not in use.
    You can turn it off for better battery life:
    Code:
    sudo su
    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    and chceck, if it works:
    Code:
    cat /sys/kernel/debug/vgaswitcheroo/switch
    (My HP DV6-3040 gets from 45W to around 20W, switcheroo doesn´t support ati drivers)


    By default, ubuntu uses Intel graphics, so even if you´ll get working ati drivers, CPU usage will be same.
    And about VirtualBox.. I don´t think you´ll get better performance for virtual windows.

  9. #9
    Join Date
    Nov 2010
    Beans
    28

    Re: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switch

    Thanks!
    I hope some day Ubuntu will itself be able to use my GPU......

  10. #10
    Join Date
    Mar 2008
    Beans
    33

    Re: Problems with installing drivers for 512MB ATI Mobility Radeon(TM) HD 5470 switch

    you can switch to Radeon

    Code:
    sudo su
    echo DDIS > /sys/kernel/debug/vgaswitcheroo/switch
    (it will use opensource driver), but it's much slower than integrated intel.

    to switch back:
    Code:
    echo DIGD > /sys/kernel/debug/vgaswitcheroo/switch

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •