Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Foreign language showing up on Google page in Firefox

  1. #1
    Join Date
    Dec 2010
    Beans
    24

    Foreign language showing up on Google page in Firefox

    The past few days, when I do a Google search in FF, I get results with a foreign language as part of the results. This language can be seen on other areas of the page, as well. I found a link at the bottom of the page where you can set the page to English, but it reverts back. Is this a hijack or something?

    Below is a copy/paste of the first result when I search for Ubuntu Forum. Note the foreign character in the summary. Thanks.




    Ubuntu Forums

    Welcome to the Ubuntu Forums, we encourage you to REGISTER on our forums and participate in the community. Ubuntu is a complete Linux-based operating system ...
    ubuntuforums.org/ - ᎠᏍᏆᏂᎪᏗ - ᎤᏠᏱ
    Search
    Absolute Beginner Talk
    Installation & Upgrades
    Networking & Wireless
    Development & Programming
    General Help
    Multimedia & Video
    Desktop Environments
    ᎤᎪᏗ ᏂᏚᎵᏍᏔᏅᎢ ubuntuforums.org »

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Foreign language showing up on Google page in Firefox


  3. #3
    Join Date
    Aug 2008
    Beans
    1

    Re: Foreign language showing up on Google pages in Firefox

    Re: Foreign language showing up on Google pages in Firefox. I have the same problem and my preferences are already set to English. I repeated that action and still have the problem. It's impossible to know what I'm clicking on. Help! (Thanks)

  4. #4
    Join Date
    Dec 2010
    Beans
    24

    Re: Foreign language showing up on Google page in Firefox

    Yes, my preference is already set to English... Still getting the foreign language. I'm not even sure what the language is... It also keeps changing my location (in the left column) to Washington Heights, NY.

  5. #5
    Join Date
    Jun 2009
    Beans
    286

    Re: Foreign language showing up on Google page in Firefox

    Quote Originally Posted by Flipper628 View Post
    That doesn't look like a foreign language to me, rather a character set problem.

    Edit > Preferences > Content > Fonts & Colors Advanced...

    What does it show as your default character encoding? It should be Western (ISO-8859-1). If it's not, change it; if it is, try another encoding, such as Unicode (UTF8 or UTF-16. If the problem persists, something else is going on.

    I take it back; I just copied your "odd" characters, and pasted them into a Google search box. See image. It looks like characters are "leaking" in from an Indic character set, plus some Greek, and Latin characters.

    Strange.
    Attached Images Attached Images
    Last edited by libssd; December 11th, 2010 at 03:51 AM.

  6. #6
    Join Date
    Jun 2009
    Beans
    286

    Re: Foreign language showing up on Google page in Firefox

    More: I'm seeing the same artifacts with Google Chrome, so this isn't a browser dependency. I think Google itself is screwing something up.

    There is another thread on this: http://ubuntuforums.org/showthread.php?t=1536811

    But, I'm not buying the solution, as my language settings in both browsers appear to be what they should be.
    Attached Images Attached Images
    Last edited by libssd; December 11th, 2010 at 04:14 AM.

  7. #7
    Join Date
    Dec 2010
    Beans
    24

    Re: Foreign language showing up on Google page in Firefox

    I appreciate the efforts. Checked my settings and they are as they should be. Going on to read the other thread. Thanks, libssd.

  8. #8
    Join Date
    Dec 2010
    Beans
    24

    Re: Foreign language showing up on Google page in Firefox

    This solution worked for me that I found in the other thread:

    Quote Originally Posted by mirzmaster View Post
    I've actually been seeing the same issue, but it only appears sometimes. I checked the Language settings of Firefox via Edit -> Preferences -> Content -> Languages. After you hit the "Choose..." button, you will be shown the preferred Language ordering of Firefox.

    Oddly enough, on that Languages screen, the only language in the list was "chrome://global/locale/intl.properties"!

    To rectify the problem, I added "English [en]" to the list, and moved it above the strange entry in the ordering. Refreshing Google now shows the correct character set.
    I had to change the order so that [en] was on top. The strange characters are now gone. Thanks, all, for the help.

  9. #9
    Join Date
    Apr 2009
    Beans
    3

    Re: Foreign language showing up on Google page in Firefox

    Thanks guys, I was having this problem just now in March 2011, looks like a bug that hasn't been fixed yet?

  10. #10
    Join Date
    Jun 2007
    Beans
    7
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Foreign language showing up on Google page in Firefox

    jay76. I agree this is still an issue. I just had to deal with it this morning.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •