Results 1 to 3 of 3

Thread: Issue Mounting CIFS Share

  1. #1
    Join Date
    Feb 2008
    Beans
    5

    Issue Mounting CIFS Share

    Hi all,

    I'm trying to mount a share on a Windows 7 desktop from my Ubuntu build. the share I'm trying to connect to is the administrative share "C$". the command I'm entering is

    mount -t cifs //IP_Address/C$ -o username=domain_name\windows_username,password=win dows_password /mnt/ntserver

    and I am getting the following error

    mount error(111): Connection refused
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


    I did attempt this to another share (Temp) with everyone read access however I got the same error as above. The account I'm trying to authenticate is a local administrator of the Windows 7 build.

    I'm not a Linux expert so be gentle

    Thanks.

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    7,799
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Issue Mounting CIFS Share

    A couple of things:

    The dollar sign ($) is an special character on bash, it maybe necessary to "escape it". Try this:
    Code:
    $ mount -t cifs //IP_Address/C\$ ...
    In order to mount samba shares on bash, you need an additional package besides samba. Check if it is install:
    Code:
    $ dpkg -l | grep smbfs
    If it isn't install, get it like this:
    Code:
    $ sudo apt-get install smbfs
    Good Luck!
    Last edited by papibe; December 2nd, 2010 at 05:50 AM. Reason: spelling

  3. #3
    Join Date
    May 2011
    Beans
    1

    Re: Issue Mounting CIFS Share

    Hi,

    I know this is a bit of an old post, but better late than never hey?

    I managed to resolve similar issues connecting to the windows 7 admin shares (c$ d$ etc) from xubuntu 11.04.

    The problem was with the windows machine, there is setting in the windows registry that prevents local network users connecting to the admin shares. You just have to put a new reg key in to fix it.

    Key goes in:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Policies\System

    Key DWORD (32-bit): LocalAccountTokenFilterPolicy
    Key Value : 1

    Further information from Microsoft available here

    Hope that helps
    Last edited by RustySheriffsBadge; May 7th, 2011 at 04:00 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •