Page 1 of 5 123 ... LastLast
Results 1 to 10 of 47

Thread: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

  1. #1
    Join Date
    Aug 2009
    Beans
    1,419

    HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    This is how I set up my Hauppauge HVR-950Q so that I can watch and record live tv on myth .24. I don't cover how to set up a remote or storage groups, etc. This set up works for me, but YMMV.

    Preliminary Steps

    If you have mythbuntu 10.10, I'm going to assume you have pulseaudio installed. You should also install the helper utilities:
    Code:
    sudo aptitude install pavucontrol paprefs pavumeter
    If you are going to use remote frontends, you need to set up your backend box so that it has a fixed address on your network.

    If you live in the US or Canada, I strongly suggest that you pay the $20 (US) and get a one-year subscription to Schedules Direct. It's by far the easiest way to get programming information for the analog channels on the card, and I use it to get programming information for the digital channels as well (for reasons detailed below).

    I installed mousepad as my text editor on mythbuntu. You can use whatever you're comfortable with.

    Step 1: Getting Audio to Work

    In my experience, the thing I had the most trouble with was getting audio to work. Until audio was sorted out, my mythtv would hang and/or crash randomly. Although most of the information I'll give in the rest of this how-to came from Mark Ackermans's comments on the Kernel Labs blog, his suggestion to use /dev/desp1 as the audio device for the analog card doesn't work on mythbuntu 10.10, since OSS was removed from the kernel. Therefore, following the information here, we're going to set up or modify an asound.conf file:

    Code:
    sudo mousepad /etc/asound.conf
    We're going to add the following to the file:

    Code:
    pcm.pulse {
        type pulse
    }
    ctl.pulse {
        type pulse
    }
    pcm.!default {
        type pulse
    }
    ctl.!default {
        type pulse
    }
    That makes pulseaudio the default sound driver for alsa, which is what we want. NOTE: It will NOT work to create this file as ".asoundrec" in your home directory, since it needs to be system-wide. You should also be aware that, unlike earlier incarnations of mythtv, it is NOT necessary to pass "EXPERIMENTALLY_ALLOW_PULSE_AUDIO=1" to the environment if you are using mythtv .24, since the audio system of mythtv was re-written to include pulseaudio support.

    Go to your mixer settings, which should be accessible by clicking the appropriate icon (it looks like a speaker) on the top panel of the mythbuntu screen. Under "Sound card", choose "HVR-950Q (Alsa Mixer)". If that tab is blank, click on the "Select Controls..." button. The only control I have is "Digital In"; click it to make it active. Check the box for "Digital In".

    Step 2: Dealing with the Time-Out Issues on the 950Q.

    You'll need to edit or create two files, and put the same information in both.

    Code:
    sudo mousepad /etc/modprobe.d/local.conf
    sudo mousepad /etc/modprobe.d/xc5000.conf
    In each file, place the following:
    Code:
    options xc5000 no_poweroff=1 debug=1

    Step 3: Testing


    Now is a good time to re-boot your computer to make all of the above-mentioned changes take place. After re-booting, I used tvtime (which you can get through synaptic) to see if I could tune analog channels. It worked without a hitch, so I moved on to setting up the mythtv backend.

    Step 4: Setting up the MythTV Backend

    First, open the "General Settings" section. If you set up a fixed ip for your mythbox on your network, you need to enter it in the "IP address" sections for both Local Backend and Master Backend. I left the rest of the settings on the first page of the General Settings section untouched. Since I'm using cable, I chose "us-cable" for the "Channel frequency table" part of Locale Settings (the second page of the "General Settings" section). I left the rest of the settings under General Settings alone. Now, we can start setting up the digital and analog parts of the tuner.

    Step 5: The Digital Tuner

    Choose "Capture Cards" to start setting up the tuners.

    Assuming you don't have any tuners set up, choose "New capture card." (If you already tried to set up the tuners and it didn't work, you may consider deleting all tuners first. The "Card type" for the digital part of the 950Q is "DVB DTV capture card (v3.x)."

    Click on "Recording Options" and change "Max Recordings" to 1. Although the card supports up to 2 recordings on the digital side, I've had it lead to weird hangs.

    I also unclick the "Use DVB card for active EIT scan", due to occasional hangs when it is checked.

    Click on the "Finish" button, and then go to "Video Sources."

    Since my cable carrier (Insight) has two different sets of listings for digital and analog cable, I set up two different listings within my Schedules Direct account (you can have up to four within one S.D. account). Likewise, I set up two different video sources for the card in mythtv.

    For the digital part of the card, I entered "insight-digital" (you can call it whatever you want) in the section for "Video source name." Then I provided my Schedules Direct information, and made sure that it pointed to the digital listing for my cable carrier when I clicked on the "Retrieve Lineups" button. Then, it was time to hit "Finish" and move on to "Input Connections."

    Click on the DVB listing to set it up. I gave it the name, "digital" (without the quotes, of course) in the section "Display name." Then I pointed the "Video source" to the "insight-digital" source I had created. I chose "Never" for "Use quick tuning" and un-checked the "Use Dish-Net long-term EIT data" since I'm using Schedules Direct for my listings. Then, click on the "Scan for channels" button. The only way I could get myth to reliably find all available channels was to choose the "Scan of all existing transports" option under "Scan Type." In fact, I scanned for channels twice to make sure all channels were captured. After the scans were done, I closed the backend setup.

    DO NOT RUN "mythfilldatabase" at this point! You're not done, yet.

    Step 6: Setting up Sound on the Front End

    Open mythfrontend. Go to "Utilities / Setup". Choose "Setup", then "General". First, make sure your "Hostname" points to the same ip address noted in your backend setup. then, click "Next" a few times until you get to "Audio System." Click the "Scan for audio devices" button. Choose "ALSA: Pulse" for your device. On the next page, click the box for "Use internal volume control". Under "Mixer device" choose "ALSA:default". For "Mixer controls" choose "Master". Set the volume for both the Master mixer and PCM mixer to 100. Click "Next" a few times, then exit. Close down mythfrontend to allow the changes to take effect.

    Step 7: Setting up the Channels for the Digital Tuner

    You should now be able to open mythfrontend and watch tv on the digital tuner. At this point, I went through all the channels and decided which ones I wanted to keep, and made a note of the corresponding channels on the Schedules Direct listing. For example, AMC has two listing on my Schedules Direct lineup for digital cable: channel 26 and channel 610. In order to avoid conflicts with the analog listings (which only go from 2-99), I chose the upper listing for each channel I wanted to keep (e.g., I chose 610 for AMC, above).

    After going through each channel, I closed mythfrontend and re-opened mythbackend. Then I went to Channel Editor. First, I deleted the channels I knew I wasn't keeping (the half-dozen shopping channels, etc.). For the remaining channels, I edited each entry to make sure that the channel number corresponded to the listing in Schedules Direct, making sure that there would be no conflicts with my analog listings. Again, as an example, I changed the listing for AMC from "1-3" to "610" (rather than "26", which would have conflicted with the analog listing). I also used the "Channel Name" and "Callsign" given by Schedules Direct. I left the "Use on air guide XMLTV ID" checkbox unchecked, since I'm using Schedules Direct for my listings.

    After editing each entry appropriately, it was time to set up the analog tuner.

    Step 8: The Analog Tuner

    Choose "Capture Cards" to begin.

    Choose "New capture card." The "Card type" for the analog part of the card is "Analog V4L capture card." The "Video device" is "/dev/video0"" on my system. The "Audio device" is "ALSA:default". I set the "Force audio sampling rate" to 48000. Click "Finish"

    Now, set up a video source to be used by the card. Click on "Video sources" in the main menu. Choose "New video source". After choosing a name for this source ("insight-analog", in my case), I again added my information for Schedules Direct, but made sure that this entry pointed to the analog listing I had set up on the Schedules Direct site. After that was finished, I moved on to "Input connections" in the main menu.

    Choose the "[V4L:/dev/video0]" listing under the Input connections menu. In the "Display name" box I wrote "analog". I pointed the "Video source:" to the newly-created "insight-analog" video source I created. This time, instead of choosing to scan for channels, I clicked on "Fetch channels from listing source". After that ran for a moment, I clicked "Next", then "Finish".

    At this point, you can close mythbackend setup. This time, you DO want to run "mythfilldatabase". You can go make yourself some coffee or a sandwich while it runs, because it takes a while.

    Step 9: Setting up Recording Profiles

    This is particularly important if you're going to stream your tv to other devices. When mythfilldatabase finishes, re-open mythfrontend. Go back to "Utilities / Setup". Click on "Setup", then "TV Settings". Scroll down to "Recording Profiles".

    You shouldn't have to make any changes to the settings under Hardware DVB Encoders. For Software Encoders (V4L based), make the following changes:

    Go to each profile (Default, Live TV, High Quality and Low Quality) and make the following changes:

    - Change the "Width" from "480" to "720".
    - On the next page, choose "MPEG-4" for the Codec.
    - On the next page after that, choose "MP3" for the audio Codec. Again, I set the Sampling rate to 48000.

    Once you've updated all four profiles, you may want to shut down and then restart mythfrontend.

    You should now be able to re-open mythfrontend, and watch/stream/record live TV. Good luck.
    Last edited by thatguruguy; December 7th, 2010 at 10:17 PM.

  2. #2
    Join Date
    Nov 2010
    Beans
    12

    Re: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    Great guide!!!
    Im reinstalling a fresh copy now and will step through this in a few min.

    Thanks for taking the time to post this!

    Brian

  3. #3
    Join Date
    Nov 2010
    Beans
    12

    Re: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    Quote Originally Posted by brianmay27 View Post
    Great guide!!!
    Im reinstalling a fresh copy now and will step through this in a few min.

    Thanks for taking the time to post this!

    Brian
    Ok, I have went through the guide and I have a question before I go too far, I don't have digital cable at all, the school still uses all analog, do I have to still setup the capture card to have a digital side or can I just setup the analog card?

  4. #4
    Join Date
    Aug 2009
    Beans
    1,419

    Re: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    You can certainly run the analog part of the card without setting up the digital part.

    Also, I just realized that I had left out step 6 on setting up audio on the front end. That's now been fixed.

  5. #5
    Join Date
    Nov 2010
    Beans
    12

    Re: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    Quote Originally Posted by thatguruguy View Post
    You can certainly run the analog part of the card without setting up the digital part.

    Also, I just realized that I had left out step 6 on setting up audio on the front end. That's now been fixed.
    Hmm, having problems then. I went back and updated the audio on the frontend but when I go to watch live tv, It shows the first station fine, but when i try to change the channel it goes black and exits out back to the home screen.
    I tried the tuner in tvtime and all the channels work find there.

    Any idea of whats wrong?

  6. #6
    Join Date
    Aug 2009
    Beans
    1,419

    Re: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    That happened to me the first time. A reboot solved it.

    You may also have better luck if you change channels by first pulling up the program guide (hit the "S" key) and choosing the next channel from there.

  7. #7
    Join Date
    Nov 2010
    Beans
    12

    Re: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    Quote Originally Posted by thatguruguy View Post
    That happened to me the first time. A reboot solved it.

    You may also have better luck if you change channels by first pulling up the program guide (hit the "S" key) and choosing the next channel from there.
    Still nothing, tried both.

    my log is at http://mythbuntu.pastebin.com/YMNcWy4t
    Code:
    1. 2010-11-30 13:45:59.249 TVRec(1): Changing from None to WatchingLiveTV
    2. 2010-11-30 13:45:59.318 TVRec(1): HW Tuner: 1->1
    3. 2010-11-30 13:46:01.015 ProgramInfo(): Updated pathname '':'' -> '1002_20101130134600.nuv'
    4. 2010-11-30 13:46:01.127 NVR(/dev/video0): Unknown video codec. Please go into the TV Settings, Recording Profiles and setup the four 'Software Encoders' profiles. Assuming RTjpeg for now.
    5. 2010-11-30 13:46:01.174 NVR(/dev/video0) Error: Unknown audio codec
    6. ALSA lib pulse.c:229:(pulse_connect) PulseAudio: Unable to connect: Connection refused
    7. 2010-11-30 13:46:01.376 AudioInALSA(default) Error: pcm open failed: Connection refused
    8. 2010-11-30 13:46:01.426 NVR(/dev/video0) Error: Failed to open audio device ALSA:default
    9. 2010-11-30 13:46:01.468 NVR(/dev/video0) Error: Failed to init audio input device
    10. 2010-11-30 13:46:01.542 AutoExpire: CalcParams(): Max required Free Space: 2.0 GB w/freq: 15 min
    11. ALSA lib pulse.c:229:(pulse_connect) 2010-11-30 13:46:01.597 ProgramInfo(): Updated pathname '':'' -> '1002_20101130134600.nuv'
    12. PulseAudio: Unable to connect: Connection refused
    13. 2010-11-30 13:46:01.795 AudioInALSA(default) Error: pcm open failed: Connection refused
    14. 2010-11-30 13:46:01.870 NVR(/dev/video0) Error: Failed to open audio device ALSA:default
    15. 2010-11-30 13:46:01.868 RecBase(1:/dev/video0): GetKeyframePositions(0,9223372036854775807,#1) out of 1
    16. 2010-11-30 13:46:01.798 ProgramInfo(): Updated pathname '':'' -> '1002_20101130134600.nuv'
    17. 2010-11-30 13:46:02.129 ProgramInfo(): Updated pathname '':'' -> '1002_20101130134600.nuv'
    18. 2010-11-30 13:46:02.192 ProgramInfo(): Updated pathname '':'' -> '1002_20101130134600.nuv'
    19. 2010-11-30 13:46:02.244 ProgramInfo(): Updated pathname '':'' -> '1002_20101130134600.nuv'
    20. 2010-11-30 13:46:04.499 TVRec(1): HW Tuner: 1->1
    21. 2010-11-30 13:46:11.556 ProgramInfo(): Updated pathname '':'' -> '1002_20101130134600.nuv'
    22. 2010-11-30 13:46:11.649 MainServer::ANN Playback
    23. 2010-11-30 13:46:11.698 adding: DVR as a client (events: 0)
    24. 2010-11-30 13:46:11.750 ProgramInfo(): Updated pathname '':'' -> '1002_20101130134600.nuv'
    25. 2010-11-30 13:46:11.799 TVRec(1): Changing from WatchingLiveTV to None

    Also when it exits it gives the error irrecoverable recorder error

  8. #8
    Join Date
    Aug 2009
    Beans
    1,419

    Re: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    It looks like pulseaudio isn't set up correctly. Did you follow the instructions in step 1?

    Also, make sure you have libasound2-plugins installed in synaptic.

    Your post reminded me that I didn't include set up instructions for Recording profiles. Give me a second and I'll correct that omission.

  9. #9
    Join Date
    Aug 2009
    Beans
    1,419

    Re: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    Also, open the ALSA volume control on your top panel. You should have "HVR-950Q" as an option under Sound card. Make sure that the box for "Digital In" is checked.

  10. #10
    Join Date
    Nov 2010
    Beans
    12

    Re: HOWTO set up a Hauppauge HVR-950Q on myth .24 and mythbuntu 10.10

    Quote Originally Posted by thatguruguy View Post
    Also, open the ALSA volume control on your top panel. You should have "HVR-950Q" as an option under Sound card. Make sure that the box for "Digital In" is checked.
    Hmm well I had a problems there, I had to make sure the mac mini drivers for audio were installed correctly, even then the volume indicator never showed up so I installed the gui alsa and the audio output showed up as well as the hvr. I ensured the digital in was selected. I never got the volume to work either in the tvtime or on the one channel in mythtv.

    Its weird that it seems to work with what ever channel It open to but it just cant change. I removed the install to try something else but I plan on reinstalling it and re-following the instructions.

    Could it be that the drivers for the mac sound are not working and thats causing all the problems? In anycase I dont need the audio to work on this computer, I plan on using a remote frontend most of the time (If i can get that to work)

    Thanks again for your time! Its really helping.

    Also Im going to try it in a vm to see if I get a different outcome. Fingers crossed
    Last edited by brianmay27; December 2nd, 2010 at 12:07 AM.

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •