Hi all. . . I'm fairly new to Ubuntu, but have been around Unix/Linux for ages. Earlier this year I spent some time to get 9.10 booting from a LiveUSB stick. It worked great, everything just as I'd hoped, but ran out of time to pursue it.

So, now I'd really like to build a LiveUSB with 10.10, in the same environment that was working so well earlier. That means 10.10 in a subdirectory on the USB stick so it will co-exist with other Live Distros, and also boot on my Macbook.

With 10.10 in the root of the USB, everything works perfectly. However, as soon as I move Ubuntu down into a subdirectory and modify the /syslinux/txt.cfg file, it boots part way, dumps me into a BusyBox shell, and fails with the following error message.

(initramfs) Unable to find a medium containing a live file system
I've searched here and elsewhere, but haven't found the answer yet. Here's the syslinux entry from the modified txt.cfg file. This is similar to the entry that works great with 9.10, but that did not have the 'preseed file' entry and did not use persistence.

  kernel /ubuntu/casper/vmlinuz
  append noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper persistent initrd=/ubuntu/casper/initrd.lz splash --
Both vmlinuz and initrd.lz load, I get the splash screen, then the LED on the USB flashes for a while (but less than a minute), and then gives the above msg. The only changes made to the above was prefixing with the /ubuntu subdirectory. (I also tried adding the subdirectory prefix to the preseed file, but that didn't work either.)

What other info would help? I'm using the 32-bit Desktop Ubuntu on an older Gateway with AMD cpu. I used the PendriveLinux Universal USB Installer v1.8.1.5 downloaded today to do the initial Live setup in USB's root dir.

I hope this is possible. Any suggestions?