Results 1 to 7 of 7

Thread: Gnome-Panel doesn't start on login

  1. #1
    Join Date
    Feb 2008
    Beans
    8
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Gnome-Panel doesn't start on login

    I've had this problem multiple times on multiple different computers, on multiple different installs of Ubuntu 10.10.

    It seems to only happen in Ubuntu 10.10, and not in other distros like Debian, or even Linux Mint 10 which is based on Ubuntu 10.10.


    When I login, I'm greeted by my wallpaper, and nothing else. Gnome-Panel does not launch. I can use the hotkey (Ctrl + Alt + T) and then launch gnome-panel manually, and it works fine. It is not malfunctioning, but when I login, it doesn't start automatically.

    I'm not 100% sure, but it seems to happen after I install my graphics driver, since that's the last thing I did before my last reboot.

    I have tried resetting my gconf settings, which brought everything back to defaults, but gnome-panel still does not start on login.

    Before you ask, gnome-panel is showing in the required-components in gconf-editor.


    Any suggestions? I could always put it under Startup Applications, but I'll never live with myself knowing something isn't quite working right =/

  2. #2
    wojox is offline I Ubuntu, Therefore, I Am
    Join Date
    Apr 2009
    Beans
    8,628

    Re: Gnome-Panel doesn't start on login

    Run these two commands from your terminal. You may need to log out and back in.


    Code:
    gconftool --recursive-unset /apps/panel
    pkill gnome-panel

  3. #3
    Join Date
    May 2010
    Beans
    26

    Re: Gnome-Panel doesn't start on login

    I'm having the same problem (in Maverick)... resetting gconf settings didn't help...

  4. #4
    Join Date
    Mar 2009
    Location
    dusseldorf, germany
    Beans
    115
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Gnome-Panel doesn't start on login

    May be this can help: run gconf-editor in a terminal. Then go to /desktop/gnome/session/required_components

    see the name 'panel' and confirm that gnome-panel is written as its value.

  5. #5
    Join Date
    May 2011
    Beans
    2

    Re: Gnome-Panel doesn't start on login

    Hello folks, i hope I'm not to late on this matter.

    I had the same problem after i upgraded to Ubuntu 10.10 and i managed to figure a work-around for this problem, it worked for me and it has to work for you guys:

    1- Open System -> Preferences -> Startup Applications
    2- Click Add
    3- Write Panel in the name
    4- In the Command write: bash -c "gnome-panel"
    5- Add a Comment if you want to (e.g: WIN!)
    6- Click Add and Restart

    Regards,
    Pedro.
    Last edited by Biokiller2510; May 30th, 2011 at 03:43 PM.

  6. #6
    Join Date
    May 2009
    Beans
    1

    Re: Gnome-Panel doesn't start on login

    Quote Originally Posted by wojox View Post
    Run these two commands from your terminal. You may need to log out and back in.


    Code:
    gconftool --recursive-unset /apps/panel
    pkill gnome-panel
    Yes, it's work

    Thanks

  7. #7
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    24,432
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Gnome-Panel doesn't start on login

    Old thread closed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •