Results 1 to 4 of 4

Thread: UNR - Lost wifi after suspend on upgrade to Maverick

  1. #1
    Join Date
    Nov 2010
    Ubuntu UNR

    UNR - Lost wifi after suspend on upgrade to Maverick

    I'm using a Asus eeePC1000HE netbook with UNR. Just upgraded to 10.10 Maverick from 10.04. Before upgrading, my wifi worked fine. On upgrade I found that wifi worked fine until I put the PC into suspend mode. On resuming from suspend, network manager failed to find the wifi device (Ralink RT2860), and wnt into an infinite wifi scan.

    I tried the following solutions, none of which worked (all sourced via Google):

    * replacing the released drivers with ndiswrapper and xxx driver
    * replacing network-manager with wicd
    * upgrading to latest kernel
    * blacklisting rt drivers
    * etc....

    Finally, I found a solution from elsewhere in these forums that fixed it:
    Create a file called 'config' in /etc/pm/config.d, and insert in it the following line:

    (replace ndiswrapper with whatever your driver name is. Use lspci -v)

    Since doing this, the wifi resumes from suspend. Only minor problem is that it takes about 5 secs.

    Just thought I'd post this, as it was painful for me over 2 weeks.

  2. #2
    Join Date
    Dec 2010

    Smile Re: UNR - Lost wifi after suspend on upgrade to Maverick

    I had the same problem on my Asus Eee PC 1000H with Ubuntu Maverick Desktop version. For months I could not solve the issue. I even downgraded to Lucid to get suspend and resume running.
    Thank you very much for posting this solution. It worked immediately on my Eee PC. Now I have Maverick installed again.
    Last edited by Finnwal; December 23rd, 2010 at 08:35 AM.

  3. #3
    Join Date
    Feb 2008

    Re: UNR - Lost wifi after suspend on upgrade to Maverick

    I have this same problem but as a newbie to ubuntu,. I can't follow the instructions.......please could you explain precisely how to do this in greater detail?

    thanks in advance


  4. #4
    Join Date
    Jan 2011
    Salamanca, Spain

    Re: UNR - Lost wifi after suspend on upgrade to Maverick

    Hi there buddy!

    First of all thank you very much for the info, it was very good.

    The second issue could be seen as an explanation in response to antigooner. As have been said before, you can extract your drivers name using the command "lspci -v". I have an Asus eee pc 1000h and the output (only the wifi one) is:

    01:00.0 Network controller: RaLink RT2860
    Subsystem: RaLink Device 2790
    Physical Slot: eeepc-wifi
    Flags: bus master, fast devsel, latency 0, IRQ 19
    Memory at fbef0000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: rt2800pci
    Kernel modules: rt2860sta, rt2800pci
    The red one is the driver name (at least I used that and it works).
    Also and if you have an Asus eee pc 1000h, you can use this command:

    sudo echo "SUSPEND_MODULES=\"\$SUSPEND_MODULES rt2800pci\" ">>/etc/pm/config.d/config
    to create the file with the needed text.

    I hope you can found this useful.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts