Page 8 of 23 FirstFirst ... 67891018 ... LastLast
Results 71 to 80 of 226

Thread: iPhone no longer mounting after iOS 4.2 upgrade

  1. #71
    Join Date
    Jan 2011
    Location
    Montreal
    Beans
    2
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Quote Originally Posted by migmruiz View Post
    Step-by-step workaround

    Add the ppa to your repos
    Code:
    sudo add-apt-repository ppa:pmcenery/ppa
    then update and upgrade your packages
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    That worked for some people,
    if it DIDN'T for you, install libimobiledevice-utils
    Code:
    sudo apt-get install libimobiledevice-utils
    and then run from the command-line
    Code:
    idevicepair unpair
    idevicepair pair
    idevicepair validate
    I still couldn't mount my iPhone after following those steps, so I followed step 2 on http://www.taranfx.com/sync-iphone-linux, but replacing libiphone-utils by libimobiledevice-utils, libiphone0 by libimobiledevice1 and python-iphone by python-imobiledevice:

    Code:
    sudo apt-get install gvfs gvfs-backends gvfs-bin gvfs-fuse libgvfscommon0 ifuse libgpod-dev libgpod-common libimobiledevice-utils libimobiledevice1 python-imobiledevice libplist++1 libplist-utils python-plist libusb-1.0-0 libusb-1.0-0-dev libusbmuxd1 usbmuxd
    I'm now able again to copy music/photos from/to my iPhone. I think it's because libimobiledevice1 also needed to be updated to 1.0.4, not just libimobiledevice-utils. You may not need to install all the other libraries as I did.

  2. #72
    Join Date
    May 2010
    Beans
    12

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    I followed the previously mentioned steps and (only after restarting) my ipod is getting recognized.

    However, when syncing with Rhythmbox, everything is OK, except that the files never appear in the ipod.
    When I replug it, and, in the autorun dialog, choose Amarok, the latter actually reads the files I've previously synced in Rhythmbox. But Rhythmbox itself doesn't read anything.

    How do I get these files to show up in the ipod itself though ?

    PS: This is the same problem mentioned by spegru and Add3r in page 7 of this thread... seems to be rather common.
    I'm running the latest ipod touch 4.2.1 iOS and Ubuntu Lucid Lynx 10.04
    I wonder what systems are running the people who managed to sync files.

    PPS: Amarok doesn't read the ipod in its sources... the files come up straight in the playlist when I choose autorun in amarok.... I'd prefer working with Amarok when syncing my music rather than Rhythmbox...
    Last edited by JacquesKik; January 5th, 2011 at 09:42 PM.

  3. #73
    Join Date
    Feb 2010
    Beans
    7

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Quote Originally Posted by jmyette View Post
    I still couldn't mount my iPhone after following those steps, so I followed step 2 on http://www.taranfx.com/sync-iphone-linux, but replacing libiphone-utils by libimobiledevice-utils, libiphone0 by libimobiledevice1 and python-iphone by python-imobiledevice:

    Code:
    sudo apt-get install gvfs gvfs-backends gvfs-bin gvfs-fuse libgvfscommon0 ifuse libgpod-dev libgpod-common libimobiledevice-utils libimobiledevice1 python-imobiledevice libplist++1 libplist-utils python-plist libusb-1.0-0 libusb-1.0-0-dev libusbmuxd1 usbmuxd
    I'm now able again to copy music/photos from/to my iPhone. I think it's because libimobiledevice1 also needed to be updated to 1.0.4, not just libimobiledevice-utils. You may not need to install all the other libraries as I did.

    Thanks jmyette,
    I tried as you said, also verifying that I had the last packages from ppmcenery in Synaptic. At first, I couldn't read anymore the filesystem of the iPod, then, after I did the pair/unpair/validate, I coud browse the iPhone again.
    However, now, when I try to transfer music with Rhythmbox, I get the error "Error transferring track: Error while getting peer-to-peer dbus connection: The name :1.90 was not provided by any .service files"

    At least something changes...does anyone have an idea of what I could have done wrong?

    By the way, if I am allowed to ask a silly question:
    since iOs 4.2.1 is the source of all evil, could there be a way to use the access, that Ubuntu grants us the the iPhone's filesystem, to put back a good old version of ios?
    I can delete and add files there, (but the iPhone itself won't read them), thus I guess I could also delete/modify system files
    (there's a lot of technical knowledge I miss about that, but maybe it's theoretically possible!)

    Cheers!

  4. #74
    Join Date
    Jan 2007
    Beans
    21

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Quote Originally Posted by spegru View Post
    Well that is exactly the same problem as I have with and iPhone 4 so I would say that it is a known problem.
    However Axel112 seems to have it working
    I wonder if he (or she) knows clearly all the versions and everything that has been done?
    The only thing I did, was adding the pmcenery repo and then:
    Code:
    apt-get install libimobiledevice-utils
    Ubuntu then installed libimobiledevice-utils:i386 (1.0.4-1ubuntu1~maverick1) and upgraded libimobiledevice1:i386 (1.0.1-1, 1.0.4-1ubuntu1~maverick1)

    I then did
    Code:
    idevicepair unpair
    idevicepair pair
    idevicepair validate
    And it worked. Oh, by the way, it's he.

  5. #75
    Join Date
    Dec 2006
    Location
    UK
    Beans
    290
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    can someone confirm what is the point of
    sudo apt-get upgrade ?

    I didn't do that one so far as am a little reluctant to use it on my Mint system as I have had problems between Ubuntu and mint Repositories before using that command
    Last edited by spegru; January 6th, 2011 at 11:01 PM.

  6. #76
    Join Date
    May 2010
    Beans
    12

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Update:

    If I open the ipod touch icon that appears on my desktop, in the iTunes_Control>Device directory, there's a file named: SysInfoExtended (24.7 kb) and the songs synced but which do not appear on the ipod appear in the same folders (the F** folders) with the ones synced on iTunes and which appear on the ipod.

    However, in my /home/ipod/iTunes_Control/Device there is a different file called SysInfo (19 Bytes) and no songs show up anywhere.

    I'm wondering what does this difference in the directories reflect, and what is the true directory of the iPod icon that appears on the desktop ?

    This is getting frustrating...

    PS: I should've noted that I'm running a 60bit Toshiba, and that my iPod is not jailbroken.

  7. #77
    Join Date
    Nov 2010
    Beans
    62

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    I have a lot of the same issues. iPod mounts, appears in Rhythmbox, file copy results in a syncing message, but it never shows up in Music.app.

  8. #78
    Join Date
    Dec 2006
    Location
    UK
    Beans
    290
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    A bit of an update.
    Tried the libimobiledevice-utils and unpair, pair validate steps but it made no difference, music transferred to the iphone did not show up.
    However I discovered that music transferred to the phone from itunes was then visible from Rhythmbox and could be transferred successfully to the PC

    Only one step missing! Music on Linux PC to phone not working......

    Is there a logfile to look at?

  9. #79
    Join Date
    May 2010
    Beans
    12

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    That's exactly my situation spegru...

    Today I tried deleting a song from Rhythmbox... to my surprise, it worked! well, partially, at least.
    The file still appeared in the "Artists" tab on the iPod, but disappeared from the "Songs", and when I tried to play it (from the artists tab), it would automatically start the next song.

    So the delete function works partially.

    I wonder if someone is working on a fix for this problem, or are we still considered isolated cases ?

    Thanks all

  10. #80
    Join Date
    May 2010
    Beans
    12

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    message inadvertently posted twice

Page 8 of 23 FirstFirst ... 67891018 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •