Page 5 of 23 FirstFirst ... 3456715 ... LastLast
Results 41 to 50 of 226

Thread: iPhone no longer mounting after iOS 4.2 upgrade

  1. #41
    Join Date
    Oct 2010
    Beans
    3

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Hey guys!

    My iPhone is mounting once again, since I've updated the libimobiledevice to the version 1.0.4!!!

    But I notice a strange behavior:

    Before the libimobiledevice update, I was able to see the iPhone charging status in the power management icon in the notification area, with my laptop charging status.

    But now, I can't see the iphone status and in addition, the Power Management is unable to notice if my notebook is under A/C power or battery as long the iPhone is plugged in.

    Can anyone help me ?

    Thanks in advance!

  2. #42
    Join Date
    Jun 2006
    Beans
    19
    Distro
    Ubuntu 6.06

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Worked perfectly for me first time.

    phone: iPhone 3GS with 4.2.1
    laptop: Maverick 64: 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 02:41:37 UTC 2010 x86_64 GNU/Linux

    I appended the two lines to /etc/apt/sources.list
    then used synaptic to update/upgrade / install libimobiledevice-utils.
    Unplugged and plugged in usb cable - bingo!

    Just dragged and dropped 100 tracks onto my iPhone using Rhythmbox.

    Great post - good job .
    thanks.

  3. #43
    Join Date
    Nov 2010
    Beans
    3

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Quote Originally Posted by tc7 View Post
    Worked perfectly for me first time.

    phone: iPhone 3GS with 4.2.1
    laptop: Maverick 64: 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 02:41:37 UTC 2010 x86_64 GNU/Linux

    I appended the two lines to /etc/apt/sources.list
    then used synaptic to update/upgrade / install libimobiledevice-utils.
    Unplugged and plugged in usb cable - bingo!

    Just dragged and dropped 100 tracks onto my iPhone using Rhythmbox.

    Great post - good job .
    thanks.

    I have almost same configuration
    phone: iphone 3GS with IOS 4.2.1
    desktop: Ubuntu 10.04 64bit Desktop

    After following multiple threads, I can mount the iphone and fspot was able to see the photos...but nothing else works. Does not show on desktop and Rhythmbox does not see phone.

    Suggestions?

  4. #44
    Join Date
    Jul 2009
    Beans
    8

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Quote Originally Posted by gb@ssan View Post
    Hey guys!

    My iPhone is mounting once again, since I've updated the libimobiledevice to the version 1.0.4!!!

    But I notice a strange behavior:

    Before the libimobiledevice update, I was able to see the iPhone charging status in the power management icon in the notification area, with my laptop charging status.

    But now, I can't see the iphone status and in addition, the Power Management is unable to notice if my notebook is under A/C power or battery as long the iPhone is plugged in.

    Can anyone help me ?

    Thanks in advance!
    perhaps if the A/C cable in connected u are under A/C power, otherwise u are under battery.

    now, seriously, I really think we are going to live with that until natty
    or, at last, 'til next year
    https://bugs.launchpad.net/ubuntu/+s...ce/+bug/682331

    if you wanna help, I think a Stable Realease Update or a Backport is needed and follow the SRU or the Backport process might be helpful
    https://bugs.launchpad.net/ubuntu/+s...331/comments/5

    Quote Originally Posted by jeff.scott View Post
    I have almost same configuration
    phone: iphone 3GS with IOS 4.2.1
    desktop: Ubuntu 10.04 64bit Desktop

    After following multiple threads, I can mount the iphone and fspot was able to see the photos...but nothing else works. Does not show on desktop and Rhythmbox does not see phone.

    Suggestions?
    as ThePengwin already said

    Quote Originally Posted by ThePengwin View Post
    the libimobiledevice site says that the iPad and iPhone on 4.2.1 are currently unable to sync the music database. They are working on it though.

  5. #45
    Join Date
    Apr 2006
    Beans
    180

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Tried all of the above still getting error message from dbus

    Running ilibmobiledevice 1.0.4 Ubuntu 10.10

    Tried idevicepair unpair

    Still nothing

    MrG
    MrGreen

  6. #46
    Join Date
    Apr 2006
    Beans
    180

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Make sure /usr/local/lib/ does not have any libimobile stuff in it

    I removed those file and my phone is now mounting again

    http://libiphone.lighthouseapp.com/p...#ticket-181-10



    YMMV

    MrG
    MrGreen

  7. #47
    Join Date
    Apr 2007
    Beans
    4

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Quote Originally Posted by migmruiz View Post
    Step-by-step workaround

    Add the ppa to your repos
    Code:
    sudo add-apt-repository ppa:pmcenery/ppa
    then update and upgrade your packages
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    That worked for some people,
    if it DIDN'T for you, install libimobiledevice-utils
    Code:
    sudo apt-get install libimobiledevice-utils
    and then run from the command-line
    Code:
    idevicepair unpair
    idevicepair pair
    idevicepair validate
    This worked for me, Thanks m8

  8. #48
    Join Date
    Sep 2006
    Location
    Pennsylvania
    Beans
    38

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Quote Originally Posted by migmruiz View Post
    Step-by-step workaround

    Add the ppa to your repos
    Code:
    sudo add-apt-repository ppa:pmcenery/ppa
    then update and upgrade your packages
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    That worked for some people,
    if it DIDN'T for you, install libimobiledevice-utils
    Code:
    sudo apt-get install libimobiledevice-utils
    and then run from the command-line
    Code:
    idevicepair unpair
    idevicepair pair
    idevicepair validate
    This worked for me too, on my non-jailbroken iPhone 4.

    I have a question though: I did need to install the libimobiledevice-utils package (and then run the 3 idevicepair commands). But in the past, I've never had to do anything special to get my iPhone to work with Ubuntu; I just plugged it in, and then I could always go to the computer:/// location in Nautilus and browse the iPhone's contents (photos is mainly what I need to access this way). So does this mean that, going forward, the libimobiledevice-utils package is always required for iPhone support? And will it then eventually be included in Ubuntu automatically? I'm just trying to determine whether I need to keep a note of this, and trying to avoid having any extra packages installed that aren't strictly necessary.

    Thanks,

    --
    Anthony DiSante
    http://encodable.com/
    http://nodivisions.com/

  9. #49
    Join Date
    Dec 2010
    Location
    glastonbury, uk
    Beans
    1
    Distro
    Ubuntu 10.04 Lucid Lynx

    Smile Re: iPhone no longer mounting after iOS 4.2 upgrade

    Quote Originally Posted by dorjem View Post
    migmruiz (and everyone else on this thread) many thanks for sharing your time and expertise.

    Had same problem here
    Ubuntu 10.04 / iPhone 3GS running iOS 4.2.1
    and suddenly couldn't connect to the phone at all

    did the applications / accessories / terminal
    lsusb
    and could see the Apple device connected

    But it never showed up on the desktop (didn't mount in other words)

    I used applications / Ubuntu software centre
    to install iFuse

    but pluging in my iPhone still didn't show on the desktop

    In the terminal window I did the following to get the libimobile files installed (this took a while, to get the syntax etc right. You'll need to enter the password for a user with ROOT access)

    sudo add-apt-repository ppamcenery/ppa
    sudo apt-get update
    sudo apt-get upgrade

    but there was a message that some packages had been kept back

    So I read
    http://ubuntuforums.org/showthread.php?t=228788

    Which told me I should try

    sudo aptitude dist-upgrade
    This updated the packages which had been kept back (some of which were GVFS related)

    Anyway the really useful page I got to was

    http://www.taranfx.com/sync-iphone-linux

    I did steps 1 2 3 4 then rebooted as it instructs in 5
    I forgot to unplug my iPhone
    And hey presto when I logged in here was my iPhone on the desktop asking me what I wanted to do open Fspot (images) open Rythmbox (music) blah blah

    So I'm thrilled and hope others find this useful too. And it only took 2 and a half hours

    Many thanks to all of you here, cannonical and everyone for the ubuntu you show by sharing

    ************************************************** ************
    iphone 3g - jailbroken - unlocked - 4.2os - ubuntu 10.04
    So, this worked for me, Thank you SO much for the S-B-Step guide.
    Brilliant
    Perfect
    Sharing is Caring
    All the best
    Smiffy
    ************************************************** ************

  10. #50
    Join Date
    Oct 2008
    Location
    /dev/my_house
    Beans
    214
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: iPhone no longer mounting after iOS 4.2 upgrade

    Ok.. I tried the above solutions, and no success with my iPod touch. Info below:

    iPod Touch 4
    iOS 4.2.1 ( 8C148 )

    Ubuntu 10.04 desktop (32 bit)
    Linux 2.6.32-24-generic

    Please Help!

Page 5 of 23 FirstFirst ... 3456715 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •