Results 1 to 2 of 2

Thread: Trouble with Wireless Monitor Mode

  1. #1
    Join Date
    Jun 2008
    Beans
    11

    Trouble with Wireless Monitor Mode

    I am attempting to put my wireless card into monitor mode on a specific channel via the airmon-ng tool. While my card does indeed go into monitor mode just fine, I cannot choose which channel to launch the mon0 interface on.

    Some other user had this issue and found a fix be applying a couple of patches per this bug: https://bugs.launchpad.net/ubuntu/+s...ng/+bug/643788

    The fix is as follows:
    --------------------------------------
    wget http://wireless.kernel.org/download/...-10-16.tar.bz2
    tar -jxf compat-wireless-2010-10-16.tar.bz2
    cd compat-wireless-2010-10-16
    wget http://patches.aircrack-ng.org/mac80...g+ack_v1.patch
    patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch
    wget http://patches.aircrack-ng.org/chann...ne-maxim.patch
    patch ./net/wireless/chan.c channel-negative-one-maxim.patch
    gedit scripts/update-initramfs
    #*** FIND LINE 13: KLIB=/lib/modules/2.6.31-wl/build
    #*** REPLACE WITH: KLIB=/lib/modules/$(uname -r)/build
    make
    sudo make install
    sudo make unload
    sudo reboot
    ---------------------------------

    When I first applied the fix it worked like a charm. However, at some point it has quit working for me.

    If the forum users would be so kind as to help me troubleshoot, I would be very grateful.

  2. #2
    Join Date
    Dec 2010
    Beans
    76

    Re: Trouble with Wireless Monitor Mode

    This worked for me, however my PC started freezing soon afterwards, the only thing that i can think was causing it was this!

    So any ideas on how to remove it from the system?

    P.S It worked fine on my laptop, just my PC freezes up now

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •